aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-04-21 14:31:16 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-04-22 07:25:15 +0000
commitf365336113039825140dd68ddb69340a5ecf0ab4 (patch)
tree8453006d8feee5ecfef67ed4fa7261312bf95880
parent5ac58edc57f032444d53c11d8381022f2e4c997b (diff)
downloadports-f365336113039825140dd68ddb69340a5ecf0ab4.tar.gz
ports-f365336113039825140dd68ddb69340a5ecf0ab4.zip
KDE Applications: sanitize DOCS option
If a port has no documentation, it doesn't need a DOCS option (which turns on, or off, exactly an empty set of documentation). This is now handled correctly by kde.mk since ports 620d7678c8. KDE **applications** with a DOCS option get doctools_build added for free; this covers the majority of KDE-things-with documentation. Note that DOCS isn't expected to **change** anything: most of the ports that have (or had) that option didn't do anything with it and always built the docs anyway. PR: 255260 Reported by: Naram Qashat
-rw-r--r--Mk/Uses/kde.mk8
-rw-r--r--graphics/kdegraphics-mobipocket/Makefile2
-rw-r--r--graphics/kdegraphics-svgpart/Makefile2
-rw-r--r--graphics/kdegraphics-thumbnailers/Makefile2
-rw-r--r--graphics/libkdcraw/Makefile2
-rw-r--r--graphics/libkexiv2/Makefile2
-rw-r--r--graphics/libkipi/Makefile2
-rw-r--r--multimedia/kdemultimedia-ffmpegthumbs/Makefile2
-rw-r--r--net-im/kaccounts-integration/Makefile2
-rw-r--r--print/print-manager/Makefile2
-rw-r--r--sysutils/kdialog/Makefile2
-rw-r--r--sysutils/signon-kwallet-extension/Makefile2
12 files changed, 7 insertions, 23 deletions
diff --git a/Mk/Uses/kde.mk b/Mk/Uses/kde.mk
index 5ddeeccd61f7..ac6d3cd1c328 100644
--- a/Mk/Uses/kde.mk
+++ b/Mk/Uses/kde.mk
@@ -17,12 +17,17 @@
# To simplify the ports, also:
# CATEGORIES If the port is part of one of the KDE Software distribution,
# it can add, in addition to 'kde' one of the following:
-# kde-application: part of applications release
+# kde-applications: part of applications release
# kde-frameworks: part of frameworks release
# kde-plasma: part of plasma release
# this will then set default values for MASTER_SITES and DIST_SUBDIR
# as well as CPE_VENDOR and LICENSE.
#
+# option DOCS If the port is part of kde-applications (see CATEGORIES,
+# above) and has an option defined for DOCS then a dependency
+# for doctools_build is added. The option itself doesn't
+# have to do anything -- the dependency is always there.
+#
# KDE_INVENT If the port does not have a regular release, and should
# be fetched from KDE Invent (a GitLab instance) it can set
# KDE_INVENT to 3 space-separated values:
@@ -162,6 +167,7 @@ _KDE_OPTIONS= bogus ${OPTIONS_DEFINE}
. if ${_KDE_OPTIONS:MDOCS}
DOCSDIR= ${PREFIX}/share/doc
PORTDOCS?= HTML/*
+USE_KDE+= doctools_build
. endif
# Further pass along a SHLIB_VER PLIST_SUB
PLIST_SUB+= KDE_APPLICATIONS_SHLIB_VER=${KDE_APPLICATIONS_SHLIB_VER} \
diff --git a/graphics/kdegraphics-mobipocket/Makefile b/graphics/kdegraphics-mobipocket/Makefile
index 72587016aee2..92c84b3985a4 100644
--- a/graphics/kdegraphics-mobipocket/Makefile
+++ b/graphics/kdegraphics-mobipocket/Makefile
@@ -13,6 +13,4 @@ USE_QT= concurrent core dbus gui network widgets \
USE_LDCONFIG= yes
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>
diff --git a/graphics/kdegraphics-svgpart/Makefile b/graphics/kdegraphics-svgpart/Makefile
index e0d5c6b9f44b..946f3ba86180 100644
--- a/graphics/kdegraphics-svgpart/Makefile
+++ b/graphics/kdegraphics-svgpart/Makefile
@@ -13,6 +13,4 @@ USE_KDE= auth codecs completion config configwidgets coreaddons ecm \
USE_QT= concurrent core dbus gui network svg widgets xml \
buildtools_build qmake_build
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>
diff --git a/graphics/kdegraphics-thumbnailers/Makefile b/graphics/kdegraphics-thumbnailers/Makefile
index e35ed07a9dae..5317e61bfaac 100644
--- a/graphics/kdegraphics-thumbnailers/Makefile
+++ b/graphics/kdegraphics-thumbnailers/Makefile
@@ -11,6 +11,4 @@ USE_KDE= archive completion config coreaddons ecm jobwidgets libkdcraw \
USE_QT= concurrent core dbus gui network widgets \
buildtools_build qmake_build
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>
diff --git a/graphics/libkdcraw/Makefile b/graphics/libkdcraw/Makefile
index 737831de5efb..dfd999b025d6 100644
--- a/graphics/libkdcraw/Makefile
+++ b/graphics/libkdcraw/Makefile
@@ -21,6 +21,4 @@ USE_LDCONFIG= yes
CMAKE_ARGS= -DWITH_OpenMP:BOOL=False \
-DENABLE_RAWSPEED=True
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>
diff --git a/graphics/libkexiv2/Makefile b/graphics/libkexiv2/Makefile
index b69c31753e20..a241142b58eb 100644
--- a/graphics/libkexiv2/Makefile
+++ b/graphics/libkexiv2/Makefile
@@ -13,6 +13,4 @@ USE_QT= core gui \
buildtools_build qmake_build
USE_LDCONFIG= yes
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>
diff --git a/graphics/libkipi/Makefile b/graphics/libkipi/Makefile
index 021560221889..5763300f551f 100644
--- a/graphics/libkipi/Makefile
+++ b/graphics/libkipi/Makefile
@@ -15,6 +15,4 @@ USE_QT= core dbus gui widgets xml \
buildtools_build qmake_build
USE_LDCONFIG= yes
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>
diff --git a/multimedia/kdemultimedia-ffmpegthumbs/Makefile b/multimedia/kdemultimedia-ffmpegthumbs/Makefile
index 926ad520571d..eda414740c10 100644
--- a/multimedia/kdemultimedia-ffmpegthumbs/Makefile
+++ b/multimedia/kdemultimedia-ffmpegthumbs/Makefile
@@ -16,6 +16,4 @@ USE_KDE= completion config coreaddons i18n jobwidgets kio service widgetsaddons
USE_QT= concurrent core dbus gui network widgets xml \
buildtools_build qmake_build
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>
diff --git a/net-im/kaccounts-integration/Makefile b/net-im/kaccounts-integration/Makefile
index 8c45983e15f5..cd5ef38774a2 100644
--- a/net-im/kaccounts-integration/Makefile
+++ b/net-im/kaccounts-integration/Makefile
@@ -20,6 +20,4 @@ USE_KDE= auth codecs config configwidgets coreaddons dbusaddons ecm \
USE_QT= dbus core declarative gui network widgets xml \
buildtools_build qmake_build
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>
diff --git a/print/print-manager/Makefile b/print/print-manager/Makefile
index 0c7adf446f7a..b03e3de46db4 100644
--- a/print/print-manager/Makefile
+++ b/print/print-manager/Makefile
@@ -15,8 +15,6 @@ USE_KDE= auth codecs completion config configwidgets coreaddons \
USE_QT= concurrent core dbus declarative gui network widgets xml \
buildtools_build qmake_build
-OPTIONS_DEFINE= DOCS
-
post-patch:
${REINPLACE_CMD} '/CUPS_DATADIR/s|/usr/share/cups|${LOCALBASE}/share/cups|' \
${PATCH_WRKSRC}/libkcups/KCupsRequest.cpp
diff --git a/sysutils/kdialog/Makefile b/sysutils/kdialog/Makefile
index b52fe198a6cf..ccb8d5fdd470 100644
--- a/sysutils/kdialog/Makefile
+++ b/sysutils/kdialog/Makefile
@@ -16,6 +16,4 @@ USE_QT= concurrent core dbus gui network printsupport widgets xml \
buildtools_build qmake_build
USE_XORG= x11
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>
diff --git a/sysutils/signon-kwallet-extension/Makefile b/sysutils/signon-kwallet-extension/Makefile
index 6b6aa3bf7e13..ab223127fe29 100644
--- a/sysutils/signon-kwallet-extension/Makefile
+++ b/sysutils/signon-kwallet-extension/Makefile
@@ -15,6 +15,4 @@ USE_LDCONFIG= ${KDE_PREFIX}/${SE_DIR}
PLIST_FILES= ${SE_DIR}/libkeyring-kwallet.so
SE_DIR= lib/signon/extensions
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>