aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2023-04-16 13:40:01 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2023-04-16 13:40:01 +0000
commitf374ddf115d4f8d15c5f255c0a0be756f986bd66 (patch)
tree49f6f0ede28e40468d5102a1ce8cd2205a8b24fc
parentdffad46a57efdcd434ac5fbec1625109a0bf2931 (diff)
downloadports-f374ddf115d4f8d15c5f255c0a0be756f986bd66.tar.gz
ports-f374ddf115d4f8d15c5f255c0a0be756f986bd66.zip
net/tightvnc: restore from attic
-rw-r--r--MOVED1
-rw-r--r--net/Makefile1
-rw-r--r--net/tightvnc/Makefile73
-rw-r--r--net/tightvnc/distinfo3
-rw-r--r--net/tightvnc/files/patch-Imakefile10
-rw-r--r--net/tightvnc/files/patch-Xvnc__config__cf__FreeBSD.cf50
-rw-r--r--net/tightvnc/files/patch-Xvnc__config__cf__Imake.cf15
-rw-r--r--net/tightvnc/files/patch-Xvnc__config__cf__vnclibs.def19
-rw-r--r--net/tightvnc/files/patch-Xvnc__config__imake__imakemdep.h21
-rw-r--r--net/tightvnc/files/patch-Xvnc__include__Xos.h10
-rw-r--r--net/tightvnc/files/patch-Xvnc__programs__Xserver__dix__Imakefile20
-rw-r--r--net/tightvnc/files/patch-Xvnc__programs__Xserver__hw__vnc__sockets.c10
-rw-r--r--net/tightvnc/files/patch-Xvnc__programs__Xserver__hw__xfree86__common__compiler.h11
-rw-r--r--net/tightvnc/files/patch-Xvnc__programs__Xserver__os__Imakefile11
-rw-r--r--net/tightvnc/files/patch-Xvnc__programs__Xserver__os__access.c11
-rw-r--r--net/tightvnc/files/patch-vncserver11
-rw-r--r--net/tightvnc/files/patch-vncviewer__Imakefile30
-rw-r--r--net/tightvnc/files/patch-vncviewer__rfbproto.c11
-rw-r--r--net/tightvnc/pkg-descr8
-rw-r--r--net/tightvnc/pkg-plist30
20 files changed, 355 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index c5a3224c39b1..fae903aa6790 100644
--- a/MOVED
+++ b/MOVED
@@ -17858,7 +17858,6 @@ multimedia/dvdrip||2023-03-31|Has expired: Depends on broken transcode port
multimedia/mkxvcd||2023-03-31|Has expired: Depends on broken transcode port
multimedia/win32-codecs||2023-03-31|Has expired: Obsolete and users are recommended to utilize ffmpeg instead
net/minisapserver||2023-03-31|Has expired: Obsolete utility, functionality is now included in multimedia/vlc
-net/tightvnc||2023-03-31|Has expired: Last release in 2009, newer version 2.x is available for Windows only
news/nntpcache||2023-03-31|Has expired: Upstream site no longer available
ports-mgmt/p5-FreeBSD-Portindex||2023-03-31|Has expired: Not working, and no fix forthcoming
print/ghostscript9-x11||2023-03-31|Has expired: Released over 10 years ago and unsupported by upstream, consider print/ghostscript9-agpl-x11
diff --git a/net/Makefile b/net/Makefile
index 072b2fdfe933..00cfc8f845b5 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1517,6 +1517,7 @@
SUBDIR += tigervnc-server
SUBDIR += tigervnc-viewer
SUBDIR += tigervnc-viewer-java
+ SUBDIR += tightvnc
SUBDIR += timed
SUBDIR += tintin++
SUBDIR += tiny-network-utilities
diff --git a/net/tightvnc/Makefile b/net/tightvnc/Makefile
new file mode 100644
index 000000000000..b96254e222b3
--- /dev/null
+++ b/net/tightvnc/Makefile
@@ -0,0 +1,73 @@
+PORTNAME= tightvnc
+PORTVERSION= 1.3.10
+PORTREVISION= 6
+CATEGORIES= net java
+MASTER_SITES= SF/vnc-tight/TightVNC-unix/${PORTVERSION}
+DISTNAME= ${PORTNAME}-${PORTVERSION}_unixsrc
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Enhanced version of VNC
+WWW= https://www.tightvnc.com/
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENCE.TXT
+
+RUN_DEPENDS= showrgb:x11/rgb \
+ xauth:x11/xauth \
+ xorg-fonts>=7.2:x11-fonts/xorg-fonts
+
+USES= cpe imake jpeg shebangfix perl5 tar:bzip2 xorg
+USE_XORG= ice sm x11 xaw xext xmu xt xpm
+
+CFLAGS+= -fcommon # for build with clang-11, see https://sourceforge.net/p/vnc-tight/bugs/1523/
+
+MAKE_JOBS_UNSAFE= yes
+CONFLICTS= tigervnc
+WRKSRC= ${WRKDIR}/vnc_unixsrc
+SHEBANG_FILES= vncserver
+CFLAGS+= -Wno-return-type
+ALL_TARGET= World
+MAKE_ARGS= CC=${CC}
+
+OPTIONS_DEFINE= JVNC_VIEWER
+OPTIONS_SUB= yes
+JVNC_VIEWER_DESC= Install Java-based vnc viewer
+JVNC_VIEWER_USE= JAVA=yes
+JVNC_VIEWER_VARS= JAVA_RUN=yes
+
+.ifdef(TIGHTVNC_BASE)
+PREFIX=${TIGHTVNC_BASE}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == aarch64
+USE_GCC= yes
+.endif
+
+.if exists(${PREFIX}/share/vnc/classes/index.vnc)
+IGNORE= vnc has already been installed, please uninstall it first
+.endif
+
+post-patch:
+.for file in vncviewer/Imakefile Xvnc/config/cf/vnclibs.def
+ @${REINPLACE_CMD} -i '' -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/${file}
+.endfor
+ @${REINPLACE_CMD} -i '' -e "s|/usr/local/vnc/classes|${DATADIR}/classes|g" \
+ ${WRKSRC}/vncserver
+ @${REINPLACE_CMD} -i '' -e "s|%%CC%%|${CC}|g ; \
+ s|%%CFLAGS%%|${CFLAGS}|g" ${WRKSRC}/Xvnc/config/cf/FreeBSD.cf
+
+do-install:
+ @(cd ${WRKSRC}; ./vncinstall ${STAGEDIR}${PREFIX}/bin ${STAGEDIR}${PREFIX}/man)
+.if defined(STRIP) && ${STRIP} != ""
+.for FILE in Xvnc vncviewer vncpasswd vncconnect
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${FILE}
+.endfor
+.endif
+
+do-install-JVNC_VIEWER-on:
+ @${MKDIR} ${STAGEDIR}${DATADIR}/classes
+ ${INSTALL_DATA} ${WRKSRC}/classes/*.* ${STAGEDIR}${DATADIR}/classes
+
+.include <bsd.port.post.mk>
diff --git a/net/tightvnc/distinfo b/net/tightvnc/distinfo
new file mode 100644
index 000000000000..981955d66bb1
--- /dev/null
+++ b/net/tightvnc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1681652343
+SHA256 (tightvnc-1.3.10_unixsrc.tar.bz2) = f48c70fea08d03744ae18df6b1499976362f16934eda3275cead87baad585c0d
+SIZE (tightvnc-1.3.10_unixsrc.tar.bz2) = 1780510
diff --git a/net/tightvnc/files/patch-Imakefile b/net/tightvnc/files/patch-Imakefile
new file mode 100644
index 000000000000..6e9d0c3b8184
--- /dev/null
+++ b/net/tightvnc/files/patch-Imakefile
@@ -0,0 +1,10 @@
+--- Imakefile.orig 2002-04-30 13:07:31 UTC
++++ Imakefile
+@@ -11,6 +11,7 @@ World:
+ @echo Built $(SUBDIRS).
+ @echo 'To build Xvnc, do "cd Xvnc", followed by "./configure" then "make"'
+ @echo ""
++ ( cd Xvnc && ./configure && make )
+
+ libs:
+ @echo 'No libraries included.'
diff --git a/net/tightvnc/files/patch-Xvnc__config__cf__FreeBSD.cf b/net/tightvnc/files/patch-Xvnc__config__cf__FreeBSD.cf
new file mode 100644
index 000000000000..286200ca89c1
--- /dev/null
+++ b/net/tightvnc/files/patch-Xvnc__config__cf__FreeBSD.cf
@@ -0,0 +1,50 @@
+--- Xvnc/config/cf/FreeBSD.cf.orig 2000-06-11 12:00:51 UTC
++++ Xvnc/config/cf/FreeBSD.cf
+@@ -223,7 +223,9 @@ XCOMM operating system: OSName (OSMajorVersion./**/OS
+ # define GccGasOption /**/
+ #endif
+
++#ifndef x86_64Architecture
+ #define ServerExtraDefines GccGasOption XFree86ServerDefines
++#endif
+
+ #define StandardDefines -DCSRG_BASED
+
+@@ -253,11 +255,17 @@ XCOMM operating system: OSName (OSMajorVersion./**/OS
+ #endif
+
+ #ifdef i386Architecture
+-# define OptimizedCDebugFlags DefaultGcc2i386Opt
++# define OptimizedCDebugFlags %%CFLAGS%%
+ #else
+-# define OptimizedCDebugFlags -O2
++# define OptimizedCDebugFlags %%CFLAGS%%
+ #endif
+
++#ifdef x86_64Architecture
++# define OptimizedCDebugFlags %%CFLAGS%%
++# define ServerOSDefines XFree86ServerOSDefines -DDDXTIME
++# define ServerExtraDefines GccGasOption XFree86ServerDefines -D_XSERVER64
++#endif /* x86_64Architecture */
++
+ #ifndef PreIncDir
+ # define PreIncDir /usr/include
+ #endif
+@@ -353,12 +361,15 @@ install.man::
+ #define HasBsdMake YES
+ #endif
+
++#if OSMajorVersion > 5 || (OSMajorVersion == 5 && OSMinorVersion >= 3)
++#define HasFfsl YES
++#endif
++
+ #ifndef StaticLibrary
+ #define StaticLibrary(libpath,libname) -Wl,-Bstatic Concat(-L,libpath) Concat(-l,libname) -Wl,-Bdynamic
+ #endif
+
+ #include <bsdLib.rules>
+
+-#ifdef i386Architecture
+ #include <xfree86.cf>
+-#endif
++
diff --git a/net/tightvnc/files/patch-Xvnc__config__cf__Imake.cf b/net/tightvnc/files/patch-Xvnc__config__cf__Imake.cf
new file mode 100644
index 000000000000..0a6f6502e43a
--- /dev/null
+++ b/net/tightvnc/files/patch-Xvnc__config__cf__Imake.cf
@@ -0,0 +1,15 @@
+--- Xvnc/config/cf/Imake.cf.orig 2006-12-23 12:07:55 UTC
++++ Xvnc/config/cf/Imake.cf
+@@ -206,6 +206,12 @@ XCOMM $XFree86: xc/config/cf/Imake.cf,v 3.66 2001/04/1
+ # define i386Architecture
+ # undef i386
+ # endif
++# ifdef __x86_64__
++# ifndef x86_64Architecture
++# define x86_64Architecture
++# endif
++# undef __x86_64__
++# endif
+ # ifdef __alpha__
+ # define AlphaBsdArchitecture
+ # define AlphaArchitecture
diff --git a/net/tightvnc/files/patch-Xvnc__config__cf__vnclibs.def b/net/tightvnc/files/patch-Xvnc__config__cf__vnclibs.def
new file mode 100644
index 000000000000..56df2fe3629b
--- /dev/null
+++ b/net/tightvnc/files/patch-Xvnc__config__cf__vnclibs.def
@@ -0,0 +1,19 @@
+--- Xvnc/config/cf/vnclibs.def.orig 2003-05-03 09:31:55 UTC
++++ Xvnc/config/cf/vnclibs.def
+@@ -5,13 +5,6 @@
+ * and programs/Xserver/hw/vnc whenever you change this file.
+ */
+
+-VNCLIBS = $(TOP)/../libvncauth/libvncauth.a
+-
+-#ifdef OSF1Architecture
+-/* Avoid linking with different libjpeg in /usr/shlib under Tru64. */
+-VNCSYSLIBS = /usr/local/lib/libjpeg.a /usr/local/lib/libz.a -lcrypt
+-#else
+-VNCSYSLIBS = -L/usr/local/lib -ljpeg -lz -lcrypt
+-#endif
+-
+-VNCCPPFLAGS = -I$(TOP)/../include -I/usr/local/include
++VNCLIBS = $(TOP)/../libvncauth/libvncauth.a %%LOCALBASE%%/lib/libjpeg.a
++VNCCPPFLAGS = -I$(TOP)/../include -I%%LOCALBASE%%/include -L%%LOCALBASE%%/lib
++VNCSYSLIBS = -L%%LOCALBASE%%/lib -ljpeg -lz -lcrypt
diff --git a/net/tightvnc/files/patch-Xvnc__config__imake__imakemdep.h b/net/tightvnc/files/patch-Xvnc__config__imake__imakemdep.h
new file mode 100644
index 000000000000..7b19d50df4b8
--- /dev/null
+++ b/net/tightvnc/files/patch-Xvnc__config__imake__imakemdep.h
@@ -0,0 +1,21 @@
+--- Xvnc/config/imake/imakemdep.h.orig 2003-02-19 16:39:54 UTC
++++ Xvnc/config/imake/imakemdep.h
+@@ -225,6 +225,9 @@ in this Software without prior written authorization f
+ #ifdef hpux
+ #define USE_CC_E
+ #endif
++#if defined(__FreeBSD__)
++#define USE_CC_E
++#endif
+ #ifdef WIN32
+ #define USE_CC_E
+ #define DEFAULT_CC "cl"
+@@ -253,7 +256,7 @@ in this Software without prior written authorization f
+ #ifdef _CRAY
+ #define DEFAULT_CPP "/lib/pcpp"
+ #endif
+-#if defined(__386BSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__FreeBSD__)
++#if defined(__386BSD__) || defined(__NetBSD__) || defined(__OpenBSD__)
+ #define DEFAULT_CPP "/usr/libexec/cpp"
+ #endif
+ #if defined(__sgi) && defined(__ANSI_CPP__)
diff --git a/net/tightvnc/files/patch-Xvnc__include__Xos.h b/net/tightvnc/files/patch-Xvnc__include__Xos.h
new file mode 100644
index 000000000000..f1aa9b3b65a3
--- /dev/null
+++ b/net/tightvnc/files/patch-Xvnc__include__Xos.h
@@ -0,0 +1,10 @@
+--- Xvnc/include/Xos.h.orig 2000-06-11 12:00:51 UTC
++++ Xvnc/include/Xos.h
+@@ -151,7 +151,6 @@ extern int sys_nerr;
+ #endif /* X_NOT_POSIX else */
+
+ #ifdef CSRG_BASED
+-#include <stdlib.h>
+ #include <unistd.h>
+ #endif /* CSRG_BASED */
+
diff --git a/net/tightvnc/files/patch-Xvnc__programs__Xserver__dix__Imakefile b/net/tightvnc/files/patch-Xvnc__programs__Xserver__dix__Imakefile
new file mode 100644
index 000000000000..6999b947181f
--- /dev/null
+++ b/net/tightvnc/files/patch-Xvnc__programs__Xserver__dix__Imakefile
@@ -0,0 +1,20 @@
+--- Xvnc/programs/Xserver/dix/Imakefile.orig 2009-03-05 06:38:33 UTC
++++ Xvnc/programs/Xserver/dix/Imakefile
+@@ -43,15 +43,11 @@ OBJS = atom.o colormap.o cursor.o devices.o dispatch.o
+ * changed.
+ */
+
+-#ifdef DefaultFontPath
+-DEFAULTFONTPATH = DefaultFontPath
++DEFAULTFONTPATH = ${LOCALBASE}/share/fonts/misc
+ SITE_FONT_PATH = -DCOMPILEDDEFAULTFONTPATH=\"$(DEFAULTFONTPATH)\"
+-#endif
+
+-#ifdef DefaultRGBDatabase
+-DEFAULTRGBDATABASE = DefaultRGBDatabase
++DEFAULTRGBDATABASE = ${LOCALBASE}/lib/X11/rgb
+ SITE_RGB_DB = -DRGB_DB=\"$(DEFAULTRGBDATABASE)\"
+-#endif
+
+ #ifdef DefaultDisplayClass
+ DEFAULTDISPLAYCLASS = DefaultDisplayClass
diff --git a/net/tightvnc/files/patch-Xvnc__programs__Xserver__hw__vnc__sockets.c b/net/tightvnc/files/patch-Xvnc__programs__Xserver__hw__vnc__sockets.c
new file mode 100644
index 000000000000..9ff1dcdce046
--- /dev/null
+++ b/net/tightvnc/files/patch-Xvnc__programs__Xserver__hw__vnc__sockets.c
@@ -0,0 +1,10 @@
+--- Xvnc/programs/Xserver/hw/vnc/sockets.c.orig 2006-12-23 12:07:55 UTC
++++ Xvnc/programs/Xserver/hw/vnc/sockets.c
+@@ -38,6 +38,7 @@
+ */
+
+ #include <stdio.h>
++#include <string.h>
+ #include <sys/types.h>
+ #include <sys/time.h>
+ #include <sys/socket.h>
diff --git a/net/tightvnc/files/patch-Xvnc__programs__Xserver__hw__xfree86__common__compiler.h b/net/tightvnc/files/patch-Xvnc__programs__Xserver__hw__xfree86__common__compiler.h
new file mode 100644
index 000000000000..938ce65b1e0b
--- /dev/null
+++ b/net/tightvnc/files/patch-Xvnc__programs__Xserver__hw__xfree86__common__compiler.h
@@ -0,0 +1,11 @@
+--- Xvnc/programs/Xserver/hw/xfree86/common/compiler.h.orig 2000-06-11 12:00:51 UTC
++++ Xvnc/programs/Xserver/hw/xfree86/common/compiler.h
+@@ -371,7 +371,7 @@ static __inline__ unsigned long ldw_u(unsigned short *
+ #define mem_barrier() /* NOP */
+ #define write_mem_barrier() /* NOP */
+
+-#if !defined(FAKEIT) && !defined(__mc68000__)
++#if !defined(FAKEIT) && !defined(__mc68000__) && !defined(__arm__) && !defined(__powerpc__) && !defined(__riscv)
+ #ifdef GCCUSESGAS
+
+ /*
diff --git a/net/tightvnc/files/patch-Xvnc__programs__Xserver__os__Imakefile b/net/tightvnc/files/patch-Xvnc__programs__Xserver__os__Imakefile
new file mode 100644
index 000000000000..daf52ebd5668
--- /dev/null
+++ b/net/tightvnc/files/patch-Xvnc__programs__Xserver__os__Imakefile
@@ -0,0 +1,11 @@
+--- Xvnc/programs/Xserver/os/Imakefile.orig 2000-06-11 12:00:51 UTC
++++ Xvnc/programs/Xserver/os/Imakefile
+@@ -135,7 +135,7 @@ SpecialCObjectRule(xalloc,$(ICONFIGFILES),NullParamete
+ #if defined(SparcArchitecture) && HasGcc && !HasGcc2
+ oscolor.o: oscolor.c $(ICONFIGFILES)
+ $(RM) $@
+- cc -c $(DBM_DEFINES) $(CDEBUGFLAGS) $(ALLDEFINES) $*.c
++ $(CC) -c $(DBM_DEFINES) $(CDEBUGFLAGS) $(ALLDEFINES) $*.c
+ #else
+ SpecialCObjectRule(oscolor,$(ICONFIGFILES),$(DBM_DEFINES))
+ #endif
diff --git a/net/tightvnc/files/patch-Xvnc__programs__Xserver__os__access.c b/net/tightvnc/files/patch-Xvnc__programs__Xserver__os__access.c
new file mode 100644
index 000000000000..ac2de3ac6a0c
--- /dev/null
+++ b/net/tightvnc/files/patch-Xvnc__programs__Xserver__os__access.c
@@ -0,0 +1,11 @@
+--- Xvnc/programs/Xserver/os/access.c.orig 2000-06-11 12:00:51 UTC
++++ Xvnc/programs/Xserver/os/access.c
+@@ -634,7 +634,7 @@ DefineSelf (fd)
+ #endif
+ ifc.ifc_len = sizeof (buf);
+ ifc.ifc_buf = buf;
+- if (ifioctl (fd, (int) SIOCGIFCONF, (pointer) &ifc) < 0)
++ if (ifioctl (fd, SIOCGIFCONF, (pointer) &ifc) < 0)
+ Error ("Getting interface configuration (4)");
+
+ #ifdef ISC
diff --git a/net/tightvnc/files/patch-vncserver b/net/tightvnc/files/patch-vncserver
new file mode 100644
index 000000000000..8dbd47bdae27
--- /dev/null
+++ b/net/tightvnc/files/patch-vncserver
@@ -0,0 +1,11 @@
+--- vncserver.orig 2019-03-26 05:19:17 UTC
++++ vncserver
+@@ -34,7 +34,7 @@ $depth = 24;
+ $desktopName = "X";
+ $vncClasses = "/usr/local/vnc/classes";
+ $vncUserDir = "$ENV{HOME}/.vnc";
+-$fontPath = "unix/:7100";
++#$fontPath = "unix/:7100";
+ $authType = "-rfbauth $vncUserDir/passwd";
+
+ # Read configuration from the system-wide and user files if present.
diff --git a/net/tightvnc/files/patch-vncviewer__Imakefile b/net/tightvnc/files/patch-vncviewer__Imakefile
new file mode 100644
index 000000000000..3851b177dd48
--- /dev/null
+++ b/net/tightvnc/files/patch-vncviewer__Imakefile
@@ -0,0 +1,30 @@
+--- vncviewer/Imakefile.orig 2003-03-12 16:20:34 UTC
++++ vncviewer/Imakefile
+@@ -10,17 +10,12 @@ XCOMM seems to cause problems on Digital Unix.
+ DEFINES = -DMITSHM
+ #endif
+
+-ZLIB_INC = -I/usr/local/include
+-JPEG_INC = -I/usr/local/include
++ZLIB_INC = -I%%LOCALBASE%%/include
++JPEG_INC = -I%%LOCALBASE%%/include
+ INCLUDES = -I../include -I. $(ZLIB_INC) $(JPEG_INC) -I/usr/include
+ VNCAUTH_LIB = ../libvncauth/libvncauth.a
+-ZLIB_LIB = -L/usr/local/lib -lz
+-#ifdef OSF1Architecture
+-XCOMM Avoid linking with different libjpeg in /usr/shlib under Tru64.
+-JPEG_LIB = /usr/local/lib/libjpeg.a
+-#else
+-JPEG_LIB = -L/usr/local/lib -ljpeg
+-#endif
++ZLIB_LIB = -L%%LOCALBASE%%/lib -lz
++JPEG_LIB = -L%%LOCALBASE%%/lib -ljpeg
+
+ DEPLIBS = XawClientDepLibs $(VNCAUTH_LIB)
+ LOCAL_LIBRARIES = XawClientLibs $(VNCAUTH_LIB) $(ZLIB_LIB) $(JPEG_LIB)
+@@ -45,4 +40,4 @@ SRCS = \
+
+ OBJS = $(SRCS:.c=.o)
+
+-ComplexProgramTarget(vncviewer)
++ComplexProgramTargetNoMan(vncviewer)
diff --git a/net/tightvnc/files/patch-vncviewer__rfbproto.c b/net/tightvnc/files/patch-vncviewer__rfbproto.c
new file mode 100644
index 000000000000..0ebb8037ce64
--- /dev/null
+++ b/net/tightvnc/files/patch-vncviewer__rfbproto.c
@@ -0,0 +1,11 @@
+--- vncviewer/rfbproto.c.orig 2006-12-08 07:20:03 UTC
++++ vncviewer/rfbproto.c
+@@ -569,7 +569,7 @@ AuthenticateVNC(void)
+ passwd = getpass("Password: ");
+ }
+
+- if (!passwd || strlen(passwd) == 0) {
++ if (!passwd) {
+ fprintf(stderr, "Reading password failed\n");
+ return False;
+ }
diff --git a/net/tightvnc/pkg-descr b/net/tightvnc/pkg-descr
new file mode 100644
index 000000000000..b90d23e01671
--- /dev/null
+++ b/net/tightvnc/pkg-descr
@@ -0,0 +1,8 @@
+Enhanced version of VNC, called TightVNC (grown from the VNC Tight Encoder
+project), which is optimized to work over slow network connections such as
+low-speed modem links. While original VNC may be very slow when your
+connection is not fast enough, with TightVNC you can work remotely almost
+in real time in most environments. Besides bandwidth optimizations,TightVNC
+also includes many other improvements, optimizations and bugfixes over VNC.
+Note that TightVNC is free, cross-platform and compatible with the standard
+VNC.
diff --git a/net/tightvnc/pkg-plist b/net/tightvnc/pkg-plist
new file mode 100644
index 000000000000..c024c33fa745
--- /dev/null
+++ b/net/tightvnc/pkg-plist
@@ -0,0 +1,30 @@
+bin/Xvnc
+bin/vncconnect
+bin/vncpasswd
+bin/vncserver
+bin/vncviewer
+%%JVNC_VIEWER%%%%DATADIR%%/classes/AuthPanel.class
+%%JVNC_VIEWER%%%%DATADIR%%/classes/ButtonPanel.class
+%%JVNC_VIEWER%%%%DATADIR%%/classes/CapabilityInfo.class
+%%JVNC_VIEWER%%%%DATADIR%%/classes/CapsContainer.class
+%%JVNC_VIEWER%%%%DATADIR%%/classes/ClipboardFrame.class
+%%JVNC_VIEWER%%%%DATADIR%%/classes/DesCipher.class
+%%JVNC_VIEWER%%%%DATADIR%%/classes/InStream.class
+%%JVNC_VIEWER%%%%DATADIR%%/classes/MemInStream.class
+%%JVNC_VIEWER%%%%DATADIR%%/classes/OptionsFrame.class
+%%JVNC_VIEWER%%%%DATADIR%%/classes/RecordingFrame.class
+%%JVNC_VIEWER%%%%DATADIR%%/classes/ReloginPanel.class
+%%JVNC_VIEWER%%%%DATADIR%%/classes/RfbProto.class
+%%JVNC_VIEWER%%%%DATADIR%%/classes/SessionRecorder.class
+%%JVNC_VIEWER%%%%DATADIR%%/classes/SocketFactory.class
+%%JVNC_VIEWER%%%%DATADIR%%/classes/VncCanvas.class
+%%JVNC_VIEWER%%%%DATADIR%%/classes/VncCanvas2.class
+%%JVNC_VIEWER%%%%DATADIR%%/classes/VncViewer.class
+%%JVNC_VIEWER%%%%DATADIR%%/classes/VncViewer.jar
+%%JVNC_VIEWER%%%%DATADIR%%/classes/ZlibInStream.class
+%%JVNC_VIEWER%%%%DATADIR%%/classes/index.vnc
+man/man1/Xvnc.1.gz
+man/man1/vncconnect.1.gz
+man/man1/vncpasswd.1.gz
+man/man1/vncserver.1.gz
+man/man1/vncviewer.1.gz