aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2023-10-24 04:29:05 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2023-11-16 12:14:26 +0000
commitf3b40ea4f82f3c3891457a631f9b2967893073aa (patch)
tree554ab2bccd2cc7620c927837acedc161332312f7
parent07cc5bacc3148177b6fe8c42d8f54c7d230566e3 (diff)
downloadports-f3b40ea4f82f3c3891457a631f9b2967893073aa.tar.gz
ports-f3b40ea4f82f3c3891457a631f9b2967893073aa.zip
Mk/bsd.java.mk: Complete support for Java 19, 20 and 21
PR: 273979 Reported by: vvd@ (cherry picked from commit c94ba5ed5035397001e226a67386973fcfd2b910)
-rw-r--r--Mk/bsd.java.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/Mk/bsd.java.mk b/Mk/bsd.java.mk
index 9a7362612c45..162e2836e236 100644
--- a/Mk/bsd.java.mk
+++ b/Mk/bsd.java.mk
@@ -22,7 +22,8 @@ Java_Include_MAINTAINER= java@FreeBSD.org
#
# JAVA_VERSION List of space-separated suitable java versions for the
# port. An optional "+" allows you to specify a range of
-# versions. (allowed values: 8[+] 11[+] 17[+] 18[+])
+# versions. (allowed values: 8[+] 11[+] 17[+] 18[+] 19[+]
+# 20[+] 21[+])
#
# JAVA_OS List of space-separated suitable JDK port operating systems
# for the port. (allowed values: native linux)
@@ -159,7 +160,7 @@ SUB_LIST+= JAVA_OS="${JAVA_OS}"
. endif
# The complete list of Java versions, os and vendors supported.
-__JAVA_VERSION_LIST= 8 11 17 18
+__JAVA_VERSION_LIST= 8 11 17 18 19 20 21
_JAVA_VERSION_LIST= ${__JAVA_VERSION_LIST} ${__JAVA_VERSION_LIST:S/$/+/}
_JAVA_OS_LIST= native linux
_JAVA_VENDOR_LIST= openjdk oracle