aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2024-05-22 21:05:39 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2024-05-22 22:16:08 +0000
commitf3cdb4abac6565355fa045817e25c3deb5cd5ecd (patch)
tree4e91ad1a50d0a1f5697e6fc3cff8a0d8ef5b9ca8
parentc8c7a6d175aba07e9ddf8ddd622e42a9d9d7603f (diff)
downloadports-f3cdb4abac6565355fa045817e25c3deb5cd5ecd.tar.gz
ports-f3cdb4abac6565355fa045817e25c3deb5cd5ecd.zip
irc/soju: Update to 0.8.0
- strip executables - add patches for missing constants in PAM headers
-rw-r--r--irc/soju/Makefile7
-rw-r--r--irc/soju/distinfo14
-rw-r--r--irc/soju/files/patch-doc_getting-started.md8
-rw-r--r--irc/soju/files/patch-vendor_github.com_msteinert_pam_v2_errors.go16
-rw-r--r--irc/soju/files/patch-vendor_github.com_msteinert_pam_v2_transaction.go17
5 files changed, 48 insertions, 14 deletions
diff --git a/irc/soju/Makefile b/irc/soju/Makefile
index 4c414677bd34..52078b468e95 100644
--- a/irc/soju/Makefile
+++ b/irc/soju/Makefile
@@ -1,7 +1,6 @@
PORTNAME= soju
DISTVERSIONPREFIX= v
-DISTVERSION= 0.7.0
-PORTREVISION= 7
+DISTVERSION= 0.8.0
CATEGORIES= irc
MAINTAINER= ashish@FreeBSD.org
@@ -13,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= go:modules,no_targets sqlite:3
USE_GITHUB= nodefault
-GH_TUPLE= golang:sys:v0.13.0:sys
+GH_TUPLE= golang:sys:v0.18.0:sys
OPTIONS_DEFAULT= DOCS
OPTIONS_DEFINE= DOCS
@@ -52,6 +51,7 @@ post-patch:
@${REINPLACE_CMD} -r -e 's,[$$]\(([^)]+)\),$${\1},g' \
-e 's,(/cmd/sojuctl)$$,\1 ${CONTRIBS},' \
-e '/^config_path/s,=.*$$,= ${ETCDIR}/config,' \
+ -e '/^RUNDIR/s,=.*$$,= /var/run,' \
-e '/^commands/s,$$, ${CONTRIBS:T},' \
-e '/^sojudb/s,^,${CONTRIBS:T} ,' \
-e '/^\.PHONY/s,$$, ${CONTRIBS:T},' \
@@ -67,5 +67,6 @@ post-install:
${MV} ${STAGEDIR}${PREFIX}/bin/${EXE} ${STAGEDIR}${PREFIX}/bin/soju-${EXE}
.endfor
${MV} ${STAGEDIR}${ETCDIR}/config ${STAGEDIR}${ETCDIR}/config.sample
+ ${FIND} ${STAGEDIR}${PREFIX}/bin -type f -exec ${STRIP_CMD} {} \;
.include <bsd.port.mk>
diff --git a/irc/soju/distinfo b/irc/soju/distinfo
index 5e174e5ed495..5115a919eb81 100644
--- a/irc/soju/distinfo
+++ b/irc/soju/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1701113515
-SHA256 (go/irc_soju/soju-v0.7.0/v0.7.0.mod) = 97993c9163614d9675c14d58e844cb315498f1617cab327d9458b7de8d0a73d0
-SIZE (go/irc_soju/soju-v0.7.0/v0.7.0.mod) = 1939
-SHA256 (go/irc_soju/soju-v0.7.0/v0.7.0.zip) = 7a3dd079a72603d2087bdd60d9ed43476d38456bd7d90bfc8a4d17d4dc7b2039
-SIZE (go/irc_soju/soju-v0.7.0/v0.7.0.zip) = 178361
-SHA256 (go/irc_soju/soju-v0.7.0/golang-sys-v0.13.0_GH0.tar.gz) = 8877d20a8f1b2533ddef00e65b6b3b9cebbcbffa319ed525df0bc229f583e2b6
-SIZE (go/irc_soju/soju-v0.7.0/golang-sys-v0.13.0_GH0.tar.gz) = 1442250
+TIMESTAMP = 1716410424
+SHA256 (go/irc_soju/soju-v0.8.0/v0.8.0.mod) = 7a59d4f81d35ba67366ca41e6222104f35264ccddcd3ec0ba650369d33825ee7
+SIZE (go/irc_soju/soju-v0.8.0/v0.8.0.mod) = 1720
+SHA256 (go/irc_soju/soju-v0.8.0/v0.8.0.zip) = 93e5173361dcd927726cb8336ad6ddcc632e73b1bc1d0ee0fe0f21658269aabc
+SIZE (go/irc_soju/soju-v0.8.0/v0.8.0.zip) = 186524
+SHA256 (go/irc_soju/soju-v0.8.0/golang-sys-v0.18.0_GH0.tar.gz) = cee1944ab655ddf7eab6301e15cb6d01fdd6cd0a0f0b5896050ee60b124e084c
+SIZE (go/irc_soju/soju-v0.8.0/golang-sys-v0.18.0_GH0.tar.gz) = 1448211
diff --git a/irc/soju/files/patch-doc_getting-started.md b/irc/soju/files/patch-doc_getting-started.md
index 0f3db775d41b..656e0bc54be0 100644
--- a/irc/soju/files/patch-doc_getting-started.md
+++ b/irc/soju/files/patch-doc_getting-started.md
@@ -1,8 +1,8 @@
---- doc/getting-started.md.orig 2021-09-17 09:56:56 UTC
+--- doc/getting-started.md.orig 1979-11-30 00:00:00 UTC
+++ doc/getting-started.md
-@@ -12,6 +12,10 @@ channels from a ZNC config file:
+@@ -20,6 +20,10 @@ channels from a ZNC config file:
- go run ./contrib/znc-import.go <znc config file>
+ go run ./contrib/znc-import <znc config file>
+For FreeBSD port users:
+
@@ -10,4 +10,4 @@
+
## Client side
- soju can operate in two different modes: multi upstream and single upstream.
+ ### Client supporting `soju.im/bouncer-networks`
diff --git a/irc/soju/files/patch-vendor_github.com_msteinert_pam_v2_errors.go b/irc/soju/files/patch-vendor_github.com_msteinert_pam_v2_errors.go
new file mode 100644
index 000000000000..177271d673ee
--- /dev/null
+++ b/irc/soju/files/patch-vendor_github.com_msteinert_pam_v2_errors.go
@@ -0,0 +1,16 @@
+--- vendor/github.com/msteinert/pam/v2/errors.go.orig 2024-05-22 21:03:02 UTC
++++ vendor/github.com/msteinert/pam/v2/errors.go
+@@ -79,13 +79,6 @@ const (
+ ErrModuleUnknown Error = C.PAM_MODULE_UNKNOWN
+ // ErrBadItem indicates a bad item passed to pam_*_item().
+ ErrBadItem Error = C.PAM_BAD_ITEM
+- // ErrConvAgain indicates a conversation function is event driven and data
+- // is not available yet.
+- ErrConvAgain Error = C.PAM_CONV_AGAIN
+- // ErrIncomplete indicates to please call this function again to complete
+- // authentication stack. Before calling again, verify that conversation
+- // is completed.
+- ErrIncomplete Error = C.PAM_INCOMPLETE
+ )
+
+ // Error returns the error message for the given status.
diff --git a/irc/soju/files/patch-vendor_github.com_msteinert_pam_v2_transaction.go b/irc/soju/files/patch-vendor_github.com_msteinert_pam_v2_transaction.go
new file mode 100644
index 000000000000..5fa6d3313646
--- /dev/null
+++ b/irc/soju/files/patch-vendor_github.com_msteinert_pam_v2_transaction.go
@@ -0,0 +1,17 @@
+--- vendor/github.com/msteinert/pam/v2/transaction.go.orig 2024-05-22 21:03:02 UTC
++++ vendor/github.com/msteinert/pam/v2/transaction.go
+@@ -257,14 +257,6 @@ const (
+ Ruser Item = C.PAM_RUSER
+ // UserPrompt is the string use to prompt for a username.
+ UserPrompt Item = C.PAM_USER_PROMPT
+- // FailDelay is the app supplied function to override failure delays.
+- FailDelay Item = C.PAM_FAIL_DELAY
+- // Xdisplay is the X display name
+- Xdisplay Item = C.PAM_XDISPLAY
+- // Xauthdata is the X server authentication data.
+- Xauthdata Item = C.PAM_XAUTHDATA
+- // AuthtokType is the type for pam_get_authtok
+- AuthtokType Item = C.PAM_AUTHTOK_TYPE
+ )
+
+ // SetItem sets a PAM information item.