aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-10-21 17:59:45 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-10-21 19:01:37 +0000
commitf3df06b4926c09b6c9ad214a14c1d884ac5fa7bd (patch)
treecbdb7b236ab6f71e56f2c61457b38dbe86447442
parentb3ffd0a785eb358e0171233ad76a613d3d58cdb0 (diff)
downloadports-f3df06b4926c09b6c9ad214a14c1d884ac5fa7bd.tar.gz
ports-f3df06b4926c09b6c9ad214a14c1d884ac5fa7bd.zip
devel/allegro: Remove USES=makeinfo
- Distfile ships with info files and no need to regenereate these files - Pet portclippy
-rw-r--r--devel/allegro/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/devel/allegro/Makefile b/devel/allegro/Makefile
index 0f2991292d6f..9ccc15813e03 100644
--- a/devel/allegro/Makefile
+++ b/devel/allegro/Makefile
@@ -17,28 +17,27 @@ LIB_DEPENDS= libogg.so:audio/libogg \
libpng.so:graphics/png \
libvorbis.so:audio/libvorbis
-USES= cmake gl makeinfo pkgconfig xorg
+USES= cmake gl pkgconfig xorg
USE_GL= gl glu
-USE_XORG= ice sm x11 xcursor xext xpm xxf86dga xxf86vm
USE_LDCONFIG= yes
+USE_XORG= ice sm x11 xcursor xext xpm xxf86dga xxf86vm
-INFO= allegro
-PORTDOCS= *
-PORTEXAMPLES= *
-
-PLIST_SUB= SHLIB_VER="${PORTVERSION:R}"
CMAKE_ARGS= -DDOCDIR="${DOCSDIR}"
-CMAKE_OFF= WANT_EXAMPLES WANT_MODULES
CMAKE_ON= WANT_LOGG
+CMAKE_OFF= WANT_EXAMPLES WANT_MODULES
# Wrong versioning upstream
PORTSCOUT= ignore:1
+INFO= allegro
+PLIST_SUB= SHLIB_VER="${PORTVERSION:R}"
+PORTDOCS= *
+PORTEXAMPLES= *
+
OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_DEFAULT= OSS
OPTIONS_MULTI= AUDIO
OPTIONS_MULTI_AUDIO= ALSA JACK OSS SNDIO
-OPTIONS_DEFAULT= OSS
-
OPTIONS_SUB= yes
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib