aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-18 20:30:10 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-19 02:52:47 +0000
commitf3eeadc739f9c01520fbd0bac6bcaa84fb404645 (patch)
tree720b4a71bc7e0d38746ad0700f4f3a5f940fdc66
parent9740b3236e12fa9bf194600ec39d88efb3fe62db (diff)
downloadports-f3eeadc739f9c01520fbd0bac6bcaa84fb404645.tar.gz
ports-f3eeadc739f9c01520fbd0bac6bcaa84fb404645.zip
math/blahtexml: Fix build on 14
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--math/blahtexml/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/math/blahtexml/Makefile b/math/blahtexml/Makefile
index f86f51ff37ec..3619a4cf7b1a 100644
--- a/math/blahtexml/Makefile
+++ b/math/blahtexml/Makefile
@@ -26,6 +26,15 @@ LDFLAGS+= -liconv
PLIST_FILES= bin/${PORTNAME}
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
+USES+= llvm:max=15
+CC= clang${LLVM_VERSION}
+CPP= clang-cpp${LLVM_VERSION}
+CXX= clang++${LLVM_VERSION}
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin