aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-05-08 16:47:40 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-05-08 18:02:05 +0000
commitf4e10173daa2938bee600467b46e219b9c2cc7dd (patch)
tree3279fce423664c1acc817f23ee752e077af415c2
parentd7594e8f4ad179e58bd6b8ed5d3649cc0437a785 (diff)
downloadports-f4e10173daa2938bee600467b46e219b9c2cc7dd.tar.gz
ports-f4e10173daa2938bee600467b46e219b9c2cc7dd.zip
math/SoPlex: Update 5.0.2 -> 6.0.0
Reported by: portscout
-rw-r--r--math/SoPlex/Makefile4
-rw-r--r--math/SoPlex/distinfo6
-rw-r--r--math/SoPlex/files/patch-CMakeLists.txt6
-rw-r--r--math/SoPlex/files/patch-src_CMakeLists.txt26
-rw-r--r--math/SoPlex/pkg-plist12
5 files changed, 32 insertions, 22 deletions
diff --git a/math/SoPlex/Makefile b/math/SoPlex/Makefile
index 442089078580..d8e50f7f0bc7 100644
--- a/math/SoPlex/Makefile
+++ b/math/SoPlex/Makefile
@@ -1,7 +1,7 @@
# Created by: Yuri Victorovich <yuri@FreeBSD.org>
PORTNAME= SoPlex
-DISTVERSION= 5.0.2
+DISTVERSION= 6.0.0
CATEGORIES= math science
MASTER_SITES= http://soplex.zib.de/download/release/
DISTNAME= ${PORTNAME:tl}-${DISTVERSION}
@@ -17,7 +17,7 @@ LICENSE_PERMS= no-dist-mirror no-pkg-mirror no-auto-accept
LIB_DEPENDS= libboost_program_options.so:devel/boost-libs \
libgmp.so:math/gmp
-USES= cmake compiler:c++11-lang tar:tgz
+USES= cmake compiler:c++14-lang tar:tgz
USE_LDCONFIG= yes
TEST_TARGET= test
diff --git a/math/SoPlex/distinfo b/math/SoPlex/distinfo
index a4d2cc258995..638813cf0956 100644
--- a/math/SoPlex/distinfo
+++ b/math/SoPlex/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1627695735
-SHA256 (soplex-5.0.2.tgz) = eaaf3b1d0e8832b25e9f4c1e44bd935c869a487b26e86c2c41856f850b22f4dd
-SIZE (soplex-5.0.2.tgz) = 984244
+TIMESTAMP = 1652027488
+SHA256 (soplex-6.0.0.tgz) = 110298221afdb42c030532d02599b7dce7c7f2597f429533e4dcb50d42031e9e
+SIZE (soplex-6.0.0.tgz) = 984637
diff --git a/math/SoPlex/files/patch-CMakeLists.txt b/math/SoPlex/files/patch-CMakeLists.txt
index 3110dc26d27d..b393b96887ab 100644
--- a/math/SoPlex/files/patch-CMakeLists.txt
+++ b/math/SoPlex/files/patch-CMakeLists.txt
@@ -1,9 +1,9 @@
- Allow shared libraries by removing CMAKE_CXX_VISIBILITY_PRESET=hidden.
---- CMakeLists.txt.orig 2021-07-31 19:54:04 UTC
+--- CMakeLists.txt.orig 2022-01-19 13:02:23 UTC
+++ CMakeLists.txt
-@@ -68,7 +68,7 @@ set(CMAKE_MACOSX_RPATH ON)
- set(CMAKE_CXX_STANDARD 11)
+@@ -71,7 +71,7 @@ set(CMAKE_MACOSX_RPATH ON)
+ set(CMAKE_CXX_STANDARD 14)
# set function visibility default to hidden
-set(CMAKE_CXX_VISIBILITY_PRESET hidden)
diff --git a/math/SoPlex/files/patch-src_CMakeLists.txt b/math/SoPlex/files/patch-src_CMakeLists.txt
index eebf23d1c6d4..138e72060f20 100644
--- a/math/SoPlex/files/patch-src_CMakeLists.txt
+++ b/math/SoPlex/files/patch-src_CMakeLists.txt
@@ -1,22 +1,22 @@
- Change to shared libraries.
---- src/CMakeLists.txt.orig 2021-05-27 15:31:06 UTC
+--- src/CMakeLists.txt.orig 2022-01-19 13:02:23 UTC
+++ src/CMakeLists.txt
-@@ -119,7 +119,7 @@ file(GLOB headers
- )
+@@ -129,7 +129,7 @@ if(MSVC)
+ endif()
- # create soplex library with pic
-- add_library(libsoplex-pic STATIC ${sources})
-+ add_library(libsoplex-pic SHARED ${sources})
- set_target_properties(libsoplex-pic PROPERTIES
- POSITION_INDEPENDENT_CODE on
- VERSION ${SOPLEX_VERSION_MAJOR}.${SOPLEX_VERSION_MINOR}.${SOPLEX_VERSION_PATCH}.${SOPLEX_VERSION_SUB}
-@@ -128,7 +128,7 @@ add_dependencies(libsoplex-pic soplex_update_githash)
+ # create soplex library with pic
+-add_library(libsoplex-pic STATIC ${sources})
++add_library(libsoplex-pic SHARED ${sources})
+ if(MSVC)
+ setLibProperties(libsoplex-pic "libsoplex-pic")
+ else()
+@@ -148,7 +148,7 @@ target_include_directories(libsoplex-pic PUBLIC
target_link_libraries(libsoplex-pic ${libs})
# create soplex library without pic
-add_library(libsoplex STATIC ${sources})
+add_library(libsoplex SHARED ${sources})
- set_target_properties(libsoplex PROPERTIES
- VERSION ${SOPLEX_VERSION_MAJOR}.${SOPLEX_VERSION_MINOR}.${SOPLEX_VERSION_PATCH}.${SOPLEX_VERSION_SUB}
- SOVERSION ${SOPLEX_VERSION_MAJOR}.${SOPLEX_VERSION_MINOR})
+ if(MSVC)
+ setLibProperties(libsoplex "libsoplex")
+ else()
diff --git a/math/SoPlex/pkg-plist b/math/SoPlex/pkg-plist
index 5c7574857959..32c4ac2e255f 100644
--- a/math/SoPlex/pkg-plist
+++ b/math/SoPlex/pkg-plist
@@ -1,14 +1,16 @@
bin/soplex
include/soplex.h
include/soplex.hpp
-include/soplex/args.hpp
include/soplex/array.h
include/soplex/basevectors.h
include/soplex/changesoplex.hpp
include/soplex/classarray.h
+include/soplex/classset.h
include/soplex/clufactor.h
include/soplex/clufactor.hpp
include/soplex/clufactor_rational.h
+include/soplex/clufactor_rational.hpp
+include/soplex/config.h
include/soplex/cring.h
include/soplex/dataarray.h
include/soplex/datahashtable.h
@@ -39,11 +41,13 @@ include/soplex/notimer.h
include/soplex/random.h
include/soplex/rational.h
include/soplex/ratrecon.h
+include/soplex/ratrecon.hpp
include/soplex/slinsolver.h
include/soplex/slinsolver_rational.h
include/soplex/slufactor.h
include/soplex/slufactor.hpp
include/soplex/slufactor_rational.h
+include/soplex/slufactor_rational.hpp
include/soplex/sol.h
include/soplex/solbase.h
include/soplex/solvedbds.hpp
@@ -86,10 +90,12 @@ include/soplex/spxleastsqsc.h
include/soplex/spxleastsqsc.hpp
include/soplex/spxlp.h
include/soplex/spxlpbase.h
+include/soplex/spxlpbase_rational.hpp
include/soplex/spxlpbase_real.hpp
include/soplex/spxmainsm.h
include/soplex/spxmainsm.hpp
include/soplex/spxout.h
+include/soplex/spxpapilo.h
include/soplex/spxparmultpr.h
include/soplex/spxparmultpr.hpp
include/soplex/spxpricer.h
@@ -139,6 +145,7 @@ include/soplex/validation.hpp
include/soplex/vector.h
include/soplex/vectorbase.h
include/soplex/wallclocktimer.h
+include/soplex_interface.h
lib/cmake/soplex/soplex-config-version.cmake
lib/cmake/soplex/soplex-config.cmake
lib/cmake/soplex/soplex-targets-%%CMAKE_BUILD_TYPE%%.cmake
@@ -149,3 +156,6 @@ lib/libsoplex-pic.so.%%SHL4%%
lib/libsoplex.so
lib/libsoplex.so.%%SHL2%%
lib/libsoplex.so.%%SHL4%%
+lib/libsoplexshared.so
+lib/libsoplexshared.so.%%SHL2%%
+lib/libsoplexshared.so.%%SHL4%%