aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Vyskubov <alexey@pentode.fi>2024-06-18 19:30:16 +0000
committerKurt Jaeger <pi@FreeBSD.org>2024-06-18 19:30:16 +0000
commitf4eb5cbd9c5087eed36da918f15ba04702004352 (patch)
treeb5642791b503945a2167a64bcc3d3f474eb833d8
parent3eaa8e5ef44a7c9b3ee8fed7f94d42365ca3b0c5 (diff)
downloadports-f4eb5cbd9c5087eed36da918f15ba04702004352.tar.gz
ports-f4eb5cbd9c5087eed36da918f15ba04702004352.zip
x11/wmctrl: upstream no longer exists
- submitter provided fork with updates - MOVED points to new version PR: 277348 Reviewed: zirias
-rw-r--r--MOVED1
-rw-r--r--x11/wmctrl-fork/Makefile21
-rw-r--r--x11/wmctrl-fork/distinfo3
-rw-r--r--x11/wmctrl-fork/pkg-descr (renamed from x11/wmctrl/pkg-descr)0
-rw-r--r--x11/wmctrl/Makefile21
-rw-r--r--x11/wmctrl/distinfo2
-rw-r--r--x11/wmctrl/files/patch-main.c61
7 files changed, 25 insertions, 84 deletions
diff --git a/MOVED b/MOVED
index 1fb5ac90ca76..914ab2e57978 100644
--- a/MOVED
+++ b/MOVED
@@ -23,6 +23,7 @@
# This file can be linted with Tools/scripts/MOVEDlint.awk
#
# Port|Moved to|Date|Why
+x11/wmctrl|x11/wmctrl-fork|2024-05-18|Forked due to the upstream being no longer available; the port had no maintainer
www/wt3|www/wt|2021-01-03|Has expired: Upstream end of life, switch to www/wt instead
archivers/ecm|archivers/cmdpack|2021-01-04|ECM is now included in cmdpack
math/qhull5|math/qhull|2021-01-04|Has expired: Legacy version of port no longer required by math/octave
diff --git a/x11/wmctrl-fork/Makefile b/x11/wmctrl-fork/Makefile
new file mode 100644
index 000000000000..6d7420dd0a73
--- /dev/null
+++ b/x11/wmctrl-fork/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= wmctrl-fork
+DISTVERSION= 1.09.02
+CATEGORIES= x11
+MASTER_SITES= https://github.com/avysk/wmctrl-fork/releases/download/1.09.02/
+
+MAINTAINER= alexey@pentode.fi
+COMMENT= Command line tool to interact with an EWMH/NetWM compatible X managers
+WWW= https://github.com/avysk/wmctrl-work
+
+LICENSE= GPLv2
+
+USES= gnome pkgconfig xorg
+
+GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
+USE_XORG= ice sm x11 xmu xext xt
+USE_GNOME= glib20
+
+PLIST_FILES= bin/wmctrl share/man/man1/wmctrl.1.gz
+
+.include <bsd.port.mk>
diff --git a/x11/wmctrl-fork/distinfo b/x11/wmctrl-fork/distinfo
new file mode 100644
index 000000000000..f321a380a276
--- /dev/null
+++ b/x11/wmctrl-fork/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1716028371
+SHA256 (wmctrl-fork-1.09.02.tar.gz) = 5883338fa542bc82f59c8653c867df4b1e8e66fbf3931fcfda25a8ed705bc2f5
+SIZE (wmctrl-fork-1.09.02.tar.gz) = 119254
diff --git a/x11/wmctrl/pkg-descr b/x11/wmctrl-fork/pkg-descr
index e26e6cf83e06..e26e6cf83e06 100644
--- a/x11/wmctrl/pkg-descr
+++ b/x11/wmctrl-fork/pkg-descr
diff --git a/x11/wmctrl/Makefile b/x11/wmctrl/Makefile
deleted file mode 100644
index c4595c94b23b..000000000000
--- a/x11/wmctrl/Makefile
+++ /dev/null
@@ -1,21 +0,0 @@
-PORTNAME= wmctrl
-PORTVERSION= 1.07
-PORTREVISION= 8
-CATEGORIES= x11
-MASTER_SITES= http://sweb.cz/tripie/utils/wmctrl/dist/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Command line tool to interact with an EWMH/NetWM compatible X managers
-WWW= http://sweb.cz/tripie/utils/wmctrl/
-
-LICENSE= GPLv2
-
-USES= gnome pkgconfig xorg
-GNU_CONFIGURE= yes
-GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
-USE_XORG= x11 xmu xext xt
-USE_GNOME= glib20
-
-PLIST_FILES= bin/wmctrl share/man/man1/${PORTNAME}.1.gz
-
-.include <bsd.port.mk>
diff --git a/x11/wmctrl/distinfo b/x11/wmctrl/distinfo
deleted file mode 100644
index a0228bba333f..000000000000
--- a/x11/wmctrl/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (wmctrl-1.07.tar.gz) = d78a1efdb62f18674298ad039c5cbdb1edb6e8e149bb3a8e3a01a4750aa3cca9
-SIZE (wmctrl-1.07.tar.gz) = 87820
diff --git a/x11/wmctrl/files/patch-main.c b/x11/wmctrl/files/patch-main.c
deleted file mode 100644
index 235048562111..000000000000
--- a/x11/wmctrl/files/patch-main.c
+++ /dev/null
@@ -1,61 +0,0 @@
---- main.c 2005-01-29 03:31:33.000000000 +0000
-+++ main.c 2016-07-01 20:14:55.443662000 +0000
-@@ -210,14 +210,14 @@
- static int close_window (Display *disp, Window win);
- static int longest_str (gchar **strv);
- static int window_to_desktop (Display *disp, Window win, int desktop);
--static void window_set_title (Display *disp, Window win, char *str, char mode);
-+static void window_set_title (Display *disp, Window win, const char *str, char mode);
- static gchar *get_window_title (Display *disp, Window win);
- static gchar *get_window_class (Display *disp, Window win);
- static gchar *get_property (Display *disp, Window win,
- Atom xa_prop_type, gchar *prop_name, unsigned long *size);
- static void init_charset(void);
--static int window_move_resize (Display *disp, Window win, char *arg);
--static int window_state (Display *disp, Window win, char *arg);
-+static int window_move_resize (Display *disp, Window win, const char *arg);
-+static int window_state (Display *disp, Window win, const char *arg);
- static Window Select_Window(Display *dpy);
- static Window get_active_window(Display *dpy);
-
-@@ -629,9 +629,9 @@
- }/*}}}*/
-
- static void window_set_title (Display *disp, Window win, /* {{{ */
-- char *title, char mode) {
-- gchar *title_utf8;
-- gchar *title_local;
-+ const char *title, char mode) {
-+ void *title_utf8;
-+ void *title_local;
-
- if (envir_utf8) {
- title_utf8 = g_strdup(title);
-@@ -734,7 +734,7 @@
- 0, 0, 0, 0, 0);
- }/*}}}*/
-
--static int window_state (Display *disp, Window win, char *arg) {/*{{{*/
-+static int window_state (Display *disp, Window win, const char *arg) {/*{{{*/
- unsigned long action;
- Atom prop1 = 0;
- Atom prop2 = 0;
-@@ -827,7 +827,7 @@
- return FALSE;
- }/*}}}*/
-
--static int window_move_resize (Display *disp, Window win, char *arg) {/*{{{*/
-+static int window_move_resize (Display *disp, Window win, const char *arg) {/*{{{*/
- signed long grav, x, y, w, h;
- unsigned long grflags;
- const char *argerr = "The -e option expects a list of comma separated integers: \"gravity,X,Y,width,height\"\n";
-@@ -1441,6 +1441,9 @@
-
- /* null terminate the result to make string handling easier */
- tmp_size = (ret_format / 8) * ret_nitems;
-+ /* Correct 64 Architecture implementation of 32 bit data */
-+ if (ret_format == 32)
-+ tmp_size *= sizeof(long)/4;
- ret = g_malloc(tmp_size + 1);
- memcpy(ret, ret_prop, tmp_size);
- ret[tmp_size] = '\0';