aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2024-02-01 20:42:28 +0000
committerJason E. Hale <jhale@FreeBSD.org>2024-02-01 21:35:09 +0000
commitf5b24810ef2552f25ffa9f8632ad2b7fbcf18b8d (patch)
treeab1926a62b233c30a050c8065d2423e74fe78d32
parent84df593840db61ce1a440aa91e9202d09472901f (diff)
downloadports-f5b24810ef2552f25ffa9f8632ad2b7fbcf18b8d.tar.gz
ports-f5b24810ef2552f25ffa9f8632ad2b7fbcf18b8d.zip
devel/cmake*: Update to 3.28.2
Install manpages in share/man. Changes made since CMake 3.28.1: - Autogen: Forward dependencies when both Makefile and DEPFILE are used - CUDA/Clang: Record architectures supported by Clang 16 - CUDA/Clang: Update architectures supported by CUDA 12 - CUDAToolkit: Correctly search all include paths from compiler - ExternalProject: revert `BYPRODUCTS` for download outputs - FindBoost: Add support for Boost 1.84 - FindFreetype: Revert use of upstream freetype cmake package - FindMatlab: Accept long ver in matlab_get_release_name_from_version - FindMatlab: Document all registry paths for version lookup - FindMatlab: Document that version mappings do not apply to MCR - FindMatlab: Fix error message from function - FindMatlab: Fix major.minor version lookups in Windows Registry - FindMatlab: Restore support for finding EXACT major.minor version - FindMatlab: Restore support for versions without VersionInfo.xml - FindMatlab: Some versions use major.minor.patch in the registry - FindMatlab: matlab_get_release_name_from_version is a function now - FindMatlab: use correct registry view when extracting versions - HIP: Propagate CMAKE_HIP_PLATFORM from/to the test project in check_language - HIP: Really forward CMAKE_HIP_HOST_COMPILER in check_language(HIP) - Help: Add missing DIRECTORY keyword to set_tests_properties() signature - Help: Fix typo not accounting for addition of visionOS - Help: Fix wrong return values for unset inherited properties - Help: Note CMAKE_IOS_INSTALL_COMBINED deprecation in toolchains example - Help: Update missed text for dynamically generated resource spec files - Help: Use <variable> consistently in property getter commands - Help: Use <xxx> for non-keyword arguments in property command signatures - Help: string(LENGTH): Fix synopsis link to command description - Help: update lua.org links to be HTTPS - Makefile: Fix double escaping when DEPFILE is used - Makefile: Reduce string copies - Ninja: LINK_OPTIONS property should support newlines - Revert use of libuv for process execution for 3.28 - Source: Restore compilation on OpenBSD - Source: Simplify hasher object construction - Tests/CXXModules/scan_properties: use `ixx` extension - Tests/CXXModules: add a test case for VS generation without flags - Tests/CXXModules: add a test with unity build support - Tests: Add missing include in testUVProcessChainHelper on Windows - Tests: Improve C compatibility of LoadCommand tests - Tests: Verify CUDA::cupti existence on a subset of machines - UsePkgConfig: Restore removal of trailing whitespace from pkg-config output - Xcode: Restore support for standalone IMPORTED_LOCATION_ - cmDyndepCollation: clarify CXX_MODULES-without-BMI error message - cmGlobalGenerator: add unity sources after computing target compile features - cmLocalGenerator: ignore scanned sources for unity builds - cmNinjaTargetGenerator: use scan flag for modmap usage inexported commands - cmQtAutoGenInitializer: Improve Const-correctness - cmUVProcessChain: Simplify SetExternalStream usage - cmUVProcessChain: Simplify builder initialization - cmUVProcessChain: Tolerate fileno() of invalid FILE stream - cmVisualStudio10TargetGenerator: always specify scanning - cmVisualStudio10TargetGenerator: fix typo in flag name - cxxmodules: compute link information for C++ module-consuming targets - cxxmodules: make export trampoline script files unique - zlib 2022-10-12 (04f42cec) - zlib: Update script to get zlib 1.2.13 https://www.kitware.com/cmake-3-28-2-available-for-download/
-rw-r--r--Mk/Uses/cmake.mk2
-rw-r--r--devel/cmake-core/Makefile3
-rw-r--r--devel/cmake-core/distinfo6
-rw-r--r--devel/cmake-core/files/patch-Modules_FindFreetype.cmake46
-rw-r--r--devel/cmake-core/files/patch-Source_cmQtAutoGenInitializer.cxx25
-rw-r--r--devel/cmake-gui/Makefile2
-rw-r--r--devel/cmake-gui/pkg-plist2
-rw-r--r--devel/cmake-man/Makefile5
-rw-r--r--devel/cmake-man/pkg-plist50
9 files changed, 34 insertions, 107 deletions
diff --git a/Mk/Uses/cmake.mk b/Mk/Uses/cmake.mk
index c6e1f6ec8305..57575ac913a2 100644
--- a/Mk/Uses/cmake.mk
+++ b/Mk/Uses/cmake.mk
@@ -50,7 +50,7 @@ _INCLUDE_USES_CMAKE_MK= yes
_valid_ARGS= insource run noninja testing _internal
-_CMAKE_VERSION= 3.28.1
+_CMAKE_VERSION= 3.28.2
# Sanity check
. for arg in ${cmake_ARGS}
diff --git a/devel/cmake-core/Makefile b/devel/cmake-core/Makefile
index 0d56c7fc5db9..127a5da4982c 100644
--- a/devel/cmake-core/Makefile
+++ b/devel/cmake-core/Makefile
@@ -4,9 +4,6 @@ DISTVERSION= ${_CMAKE_VERSION}
CATEGORIES= devel
PKGNAMESUFFIX= -core
-PATCH_SITES= https://gitlab.kitware.com/cmake/cmake/-/commit/
-PATCHFILES= 61436858e431b137252b3d5e63ee579c7c575103.patch:-p1 # Fix pkg-config trailing whitespace
-
MAINTAINER= kde@FreeBSD.org
COMMENT= Cross-platform Makefile generator
WWW= https://www.cmake.org/
diff --git a/devel/cmake-core/distinfo b/devel/cmake-core/distinfo
index 836e0fa39de9..0cb0e15d0571 100644
--- a/devel/cmake-core/distinfo
+++ b/devel/cmake-core/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1703157829
-SHA256 (cmake-3.28.1.tar.gz) = 15e94f83e647f7d620a140a7a5da76349fc47a1bfed66d0f5cdee8e7344079ad
-SIZE (cmake-3.28.1.tar.gz) = 11065923
+TIMESTAMP = 1706732211
+SHA256 (cmake-3.28.2.tar.gz) = 1466f872dc1c226f373cf8fba4230ed216a8f108bd54b477b5ccdfd9ea2d124a
+SIZE (cmake-3.28.2.tar.gz) = 11067468
SHA256 (61436858e431b137252b3d5e63ee579c7c575103.patch) = d18eb7ae3ccb364b7a38a8de73f392f8abd4a26b8d59462983038f570df3c146
SIZE (61436858e431b137252b3d5e63ee579c7c575103.patch) = 1949
diff --git a/devel/cmake-core/files/patch-Modules_FindFreetype.cmake b/devel/cmake-core/files/patch-Modules_FindFreetype.cmake
deleted file mode 100644
index 43bee7c19f86..000000000000
--- a/devel/cmake-core/files/patch-Modules_FindFreetype.cmake
+++ /dev/null
@@ -1,46 +0,0 @@
-Hunk 1: Set FREETYPE_INCLUDE_DIR_ft2build and FREETYPE_INCLUDE_DIR_freetype2
-if the freetype config is found for backwards compatibility.
-Regressed by [1].
-
-Hunk 2: Fix some weirdness that happens in games/arx-libertatis where the
-the REMOVE_DUPLICATES directive of the CMake list() command removes the
-OpenAL library from the link libraries list because it was the next
-library in the list. It is unlikely that one would have both the debug
-and release versions of FreeType installed on FreeBSD as we don't
-currently have the infrastructure to simultaneously support a suffixed
-and non-suffixed freetype library. Honestly, I don't even know what this
-contruct is supposed to represent. The CMake set() command [3] doesn't
-specify allowance of metadata constructs like "optimized" and "debug"
-before variable assignment and further confuses ports like
-graphics/ogre3d that try to link against nonsense libraries like
--loptimized and -ldebug.
-Regessed by [2].
-
-[1] https://gitlab.kitware.com/cmake/cmake/-/commit/d83d925045484c882527477b01596073f45d3faa
-[2] https://gitlab.kitware.com/cmake/cmake/-/commit/1cfc708eea11df5fd8c438f517e24940b6cc1917
-[3] https://cmake.org/cmake/help/latest/command/set.html
-
---- Modules/FindFreetype.cmake.orig 2023-12-14 15:47:27 UTC
-+++ Modules/FindFreetype.cmake
-@@ -106,6 +106,8 @@ if (freetype_FOUND)
- INTERFACE_LINK_LIBRARIES freetype)
- endif ()
- get_property(FREETYPE_INCLUDE_DIRS TARGET freetype PROPERTY INTERFACE_INCLUDE_DIRECTORIES)
-+ get_property(FREETYPE_INCLUDE_DIR_ft2build TARGET freetype PROPERTY INTERFACE_INCLUDE_DIRECTORIES)
-+ get_property(FREETYPE_INCLUDE_DIR_freetype2 TARGET freetype PROPERTY INTERFACE_INCLUDE_DIRECTORIES)
- get_property(FREETYPE_LIBRARIES TARGET freetype PROPERTY INTERFACE_LINK_LIBRARIES)
- get_property(_Freetype_location TARGET freetype PROPERTY IMPORTED_IMPLIB)
- if (NOT _Freetype_location)
-@@ -128,11 +130,7 @@ if (freetype_FOUND)
- get_property(_Freetype_location_release TARGET freetype PROPERTY LOCATION_RELWITHDEBINFO)
- endif ()
- get_property(_Freetype_location_debug TARGET freetype PROPERTY LOCATION_DEBUG)
-- if (_Freetype_location_release AND _Freetype_location_debug)
-- set(_Freetype_location
-- optimized "${_Freetype_location_release}"
-- debug "${_Freetype_location_debug}")
-- elseif (_Freetype_location_release)
-+ if (_Freetype_location_release)
- set(_Freetype_location "${_Freetype_location_release}")
- elseif (_Freetype_location_debug)
- set(_Freetype_location "${_Freetype_location_debug}")
diff --git a/devel/cmake-core/files/patch-Source_cmQtAutoGenInitializer.cxx b/devel/cmake-core/files/patch-Source_cmQtAutoGenInitializer.cxx
deleted file mode 100644
index 135878301077..000000000000
--- a/devel/cmake-core/files/patch-Source_cmQtAutoGenInitializer.cxx
+++ /dev/null
@@ -1,25 +0,0 @@
-CMake >= 3.27 exports the CXX std to moc. This is a workaround for
-a moc parsing bug that happens parsing headers from libc++ < 14 when
-the CXX std > 17.
-
-usr/include/c++/v1/concept:318:1: error: Parse error at "::" [1]
-
-Moc should theoretically be able to parse this. [2] Not exactly sure
-why it's failing.
-
-[1] https://cgit.freebsd.org/src/tree/contrib/llvm-project/libcxx/include/concepts?h=stable/12#n318
-[2] https://code.qt.io/cgit/qt/qtbase.git/tree/src/tools/moc/moc.cpp?h=6.6.0#n631
-
---- Source/cmQtAutoGenInitializer.cxx.orig 2023-10-06 13:08:35 UTC
-+++ Source/cmQtAutoGenInitializer.cxx
-@@ -1797,6 +1797,10 @@ bool cmQtAutoGenInitializer::SetupWriteAutogenInfo()
- if (this->Moc.PredefsCmd.size() >= 3) {
- this->Moc.PredefsCmd.insert(this->Moc.PredefsCmd.begin() + 1,
- CompileOptionValue);
-+#if defined(__FreeBSD__) && __FreeBSD_version < 1302000
-+ this->Moc.PredefsCmd.insert(this->Moc.PredefsCmd.begin() + 1,
-+ "-D_LIBCPP_HAS_NO_CONCEPTS");
-+#endif
- }
- }
- info.SetArray("MOC_PREDEFS_CMD", this->Moc.PredefsCmd);
diff --git a/devel/cmake-gui/Makefile b/devel/cmake-gui/Makefile
index 93b80bca5260..891d82a48971 100644
--- a/devel/cmake-gui/Makefile
+++ b/devel/cmake-gui/Makefile
@@ -62,6 +62,6 @@ pre-install:
post-install:
${INSTALL_MAN} ${WRKSRC}/Utilities/Sphinx/man/cmake-gui.1 \
- ${STAGEDIR}${PREFIX}/man/man1
+ ${STAGEDIR}${PREFIX}/share/man/man1
.include <bsd.port.mk>
diff --git a/devel/cmake-gui/pkg-plist b/devel/cmake-gui/pkg-plist
index c8776a4ce24e..ecf8b2669453 100644
--- a/devel/cmake-gui/pkg-plist
+++ b/devel/cmake-gui/pkg-plist
@@ -1,6 +1,6 @@
bin/cmake-gui
-man/man1/cmake-gui.1.gz
share/applications/cmake-gui.desktop
share/icons/hicolor/128x128/apps/CMakeSetup.png
share/icons/hicolor/32x32/apps/CMakeSetup.png
+share/man/man1/cmake-gui.1.gz
share/mime/packages/cmakecache.xml
diff --git a/devel/cmake-man/Makefile b/devel/cmake-man/Makefile
index 52cc7adfd9f1..1be3e0ec0420 100644
--- a/devel/cmake-man/Makefile
+++ b/devel/cmake-man/Makefile
@@ -21,7 +21,8 @@ DISTINFO_FILE= ${.CURDIR}/../cmake-core/distinfo
CMAKE_OFF= SPHINX_HTML SPHINX_QTHELP
CMAKE_ON= SPHINX_MAN
-CMAKE_ARGS= -DCMAKE_DOC_DIR:STRING="${DOCSDIR_REL}"
+CMAKE_ARGS= -DCMAKE_DOC_DIR:STRING="${DOCSDIR_REL}" \
+ -DCMAKE_MAN_DIR:STRING="share/man"
CMAKE_SOURCE_PATH= ${WRKSRC}/Utilities/Sphinx
ALL_TARGET= documentation
@@ -31,6 +32,6 @@ PLIST_SUB= CMAKEVERSION="${DISTVERSION:S/.//g:C/-.*//}"
post-install:
# Installed by devel/cmake-gui
- @${RM} ${STAGEDIR}${PREFIX}/man/man1/cmake-gui.1
+ @${RM} ${STAGEDIR}${PREFIX}/share/man/man1/cmake-gui.1
.include <bsd.port.mk>
diff --git a/devel/cmake-man/pkg-plist b/devel/cmake-man/pkg-plist
index 5c78b9e6bd6e..149ce217571e 100644
--- a/devel/cmake-man/pkg-plist
+++ b/devel/cmake-man/pkg-plist
@@ -1,25 +1,25 @@
-man/man1/ccmake.1.gz
-man/man1/cmake.1.gz
-man/man1/cpack.1.gz
-man/man1/ctest.1.gz
-man/man7/cmake-buildsystem.7.gz
-man/man7/cmake-commands.7.gz
-man/man7/cmake-compile-features.7.gz
-man/man7/cmake-configure-log.7.gz
-man/man7/cmake-cxxmodules.7.gz
-man/man7/cmake-developer.7.gz
-man/man7/cmake-env-variables.7.gz
-man/man7/cmake-file-api.7.gz
-man/man7/cmake-generator-expressions.7.gz
-man/man7/cmake-generators.7.gz
-man/man7/cmake-language.7.gz
-man/man7/cmake-modules.7.gz
-man/man7/cmake-packages.7.gz
-man/man7/cmake-policies.7.gz
-man/man7/cmake-presets.7.gz
-man/man7/cmake-properties.7.gz
-man/man7/cmake-qt.7.gz
-man/man7/cmake-server.7.gz
-man/man7/cmake-toolchains.7.gz
-man/man7/cmake-variables.7.gz
-man/man7/cpack-generators.7.gz
+share/man/man1/ccmake.1.gz
+share/man/man1/cmake.1.gz
+share/man/man1/cpack.1.gz
+share/man/man1/ctest.1.gz
+share/man/man7/cmake-buildsystem.7.gz
+share/man/man7/cmake-commands.7.gz
+share/man/man7/cmake-compile-features.7.gz
+share/man/man7/cmake-configure-log.7.gz
+share/man/man7/cmake-cxxmodules.7.gz
+share/man/man7/cmake-developer.7.gz
+share/man/man7/cmake-env-variables.7.gz
+share/man/man7/cmake-file-api.7.gz
+share/man/man7/cmake-generator-expressions.7.gz
+share/man/man7/cmake-generators.7.gz
+share/man/man7/cmake-language.7.gz
+share/man/man7/cmake-modules.7.gz
+share/man/man7/cmake-packages.7.gz
+share/man/man7/cmake-policies.7.gz
+share/man/man7/cmake-presets.7.gz
+share/man/man7/cmake-properties.7.gz
+share/man/man7/cmake-qt.7.gz
+share/man/man7/cmake-server.7.gz
+share/man/man7/cmake-toolchains.7.gz
+share/man/man7/cmake-variables.7.gz
+share/man/man7/cpack-generators.7.gz