aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2021-07-30 23:10:03 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2021-07-30 23:11:59 +0000
commitf5d4043b88ceef0d12cc0b1ff34667d6a48ca463 (patch)
treeaf0f7e8987a07fb3da2c749375bc4d834c602ee0
parent65a85589ada4460b79f18872e3bbddf41b521287 (diff)
downloadports-f5d4043b88ceef0d12cc0b1ff34667d6a48ca463.tar.gz
ports-f5d4043b88ceef0d12cc0b1ff34667d6a48ca463.zip
sysutils/ansible-sshjail: Patch to work with newer ansible-core
Commit ce62d904fbb3 updated sysutils/py-ansible-core to 2.11.3, changes in this version require this patch to allow ansible-sshjail to work with it.
-rw-r--r--sysutils/ansible-sshjail/Makefile2
-rw-r--r--sysutils/ansible-sshjail/files/patch-sshjail.py38
2 files changed, 29 insertions, 11 deletions
diff --git a/sysutils/ansible-sshjail/Makefile b/sysutils/ansible-sshjail/Makefile
index b40cf6d8eb7c..698d0a95cf34 100644
--- a/sysutils/ansible-sshjail/Makefile
+++ b/sysutils/ansible-sshjail/Makefile
@@ -1,7 +1,7 @@
PORTNAME= ansible-sshjail
DISTVERSIONPREFIX= v
DISTVERSION= 1.1.0-30
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSIONSUFFIX= -g981674f
CATEGORIES= sysutils
diff --git a/sysutils/ansible-sshjail/files/patch-sshjail.py b/sysutils/ansible-sshjail/files/patch-sshjail.py
index f2b5b7d9d0c8..e27ec1ad5eef 100644
--- a/sysutils/ansible-sshjail/files/patch-sshjail.py
+++ b/sysutils/ansible-sshjail/files/patch-sshjail.py
@@ -3,15 +3,9 @@ From: Mohamad Safadieh <self@mhmd.sh>
Date: Wed, 5 May 2021 12:38:26 -0400
Subject: [PATCH] added sshpass_prompt, ssh_transfer_method, timeout
----
- sshjail.py | 42 ++++++++++++++++++++++++++++++++++++++++++
- 1 file changed, 42 insertions(+)
-
-diff --git a/sshjail.py b/sshjail.py
-index 5973380..0e26c68 100644
---- sshjail.py
+--- sshjail.py.orig 2021-01-07 19:31:49 UTC
+++ sshjail.py
-@@ -49,6 +49,17 @@
+@@ -49,6 +49,17 @@ DOCUMENTATION = '''
vars:
- name: ansible_password
- name: ansible_ssh_pass
@@ -29,7 +23,31 @@ index 5973380..0e26c68 100644
ssh_args:
description: Arguments to pass to all ssh cli tools
default: '-C -o ControlMaster=auto -o ControlPersist=60s'
-@@ -247,6 +258,16 @@
+@@ -140,10 +151,9 @@ DOCUMENTATION = '''
+ - key: ssh_extra_args
+ section: ssh_connection
+ version_added: '2.7'
+- retries:
+- # constant: ANSIBLE_SSH_RETRIES
++ reconnection_retries:
+ description: Number of attempts to connect.
+- default: 3
++ default: 0
+ type: integer
+ env:
+ - name: ANSIBLE_SSH_RETRIES
+@@ -153,8 +163,8 @@ DOCUMENTATION = '''
+ - section: ssh_connection
+ key: retries
+ vars:
+- - name: ansible_ssh_retries
+- version_added: '2.7'
++ - name: ansible_ssh_retries
++ version_added: '2.7'
+ port:
+ description: Remote port to connect to.
+ type: int
+@@ -247,6 +257,16 @@ DOCUMENTATION = '''
vars:
- name: ansible_sftp_batch_mode
version_added: '2.7'
@@ -46,7 +64,7 @@ index 5973380..0e26c68 100644
scp_if_ssh:
default: smart
description:
-@@ -270,6 +291,27 @@
+@@ -270,6 +290,27 @@ DOCUMENTATION = '''
vars:
- name: ansible_ssh_use_tty
version_added: '2.7'