aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2021-12-20 18:03:30 +0000
committerBernard Spil <brnrd@FreeBSD.org>2021-12-20 18:03:30 +0000
commitf64391dd014047d542cd394dda3dc00c1d061801 (patch)
tree5ad3842a38450169aafa07517e488b5564accc14
parent512fb19b7c89c88334099ce06daf8a0880c208ac (diff)
downloadports-f64391dd014047d542cd394dda3dc00c1d061801.tar.gz
ports-f64391dd014047d542cd394dda3dc00c1d061801.zip
security/openssl: Fix build on aarch64
* Upstream only partly merged changes PR: 259937, 260572 Reported by: allanjude, "Naram Qashat" <cyberbotx cyberbotx com>
-rw-r--r--security/openssl/Makefile1
-rw-r--r--security/openssl/files/patch-Configurations_10-main.conf16
2 files changed, 17 insertions, 0 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index d0b156e605ea..dcac89a98972 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -2,6 +2,7 @@
PORTNAME= openssl
PORTVERSION= 1.1.1m
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security devel
MASTER_SITES= https://www.openssl.org/source/ \
diff --git a/security/openssl/files/patch-Configurations_10-main.conf b/security/openssl/files/patch-Configurations_10-main.conf
new file mode 100644
index 000000000000..03be5801b885
--- /dev/null
+++ b/security/openssl/files/patch-Configurations_10-main.conf
@@ -0,0 +1,16 @@
+--- Configurations/10-main.conf.orig 2021-12-14 15:45:01 UTC
++++ Configurations/10-main.conf
+@@ -988,6 +988,13 @@ my %targets = (
+ perlasm_scheme => "elf",
+ },
+
++ "BSD-aarch64" => {
++ inherit_from => [ "BSD-generic64", asm("aarch64_asm") ],
++ lib_cppflags => add("-DL_ENDIAN"),
++ bn_ops => "SIXTY_FOUR_BIT_LONG",
++ perlasm_scheme => "linux64",
++ },
++
+ "bsdi-elf-gcc" => {
+ inherit_from => [ "BASE_unix", asm("x86_elf_asm") ],
+ CC => "gcc",