aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2021-10-02 21:48:12 +0000
committerStefan Eßer <se@FreeBSD.org>2021-10-02 21:59:12 +0000
commitf67a898c70a2d2ae2f64cfc6cbdd60bb63bc82e8 (patch)
tree767bef77014b47234fec4bce8f498e54d5bdaa4f
parentedae8a1c040482b1cc559eee4f6d626288d54965 (diff)
downloadports-f67a898c70a2d2ae2f64cfc6cbdd60bb63bc82e8.tar.gz
ports-f67a898c70a2d2ae2f64cfc6cbdd60bb63bc82e8.zip
security/ssl-admin: Fetch from GitHub
In addition to fetching from GitHub the order of definitions in the port Makefile has been normalized, @sample tags are now used in the pkg-plist file, and the BSD3CLAUSE style LICENSE file is included in the generated package. Approved by: ecrist@secure-computing.net (maintainer)
-rw-r--r--security/ssl-admin/Makefile16
-rw-r--r--security/ssl-admin/distinfo5
-rw-r--r--security/ssl-admin/pkg-plist4
3 files changed, 17 insertions, 8 deletions
diff --git a/security/ssl-admin/Makefile b/security/ssl-admin/Makefile
index 6fdf45e81beb..d4bc658a6e2e 100644
--- a/security/ssl-admin/Makefile
+++ b/security/ssl-admin/Makefile
@@ -1,26 +1,34 @@
# Created by: Eric Crist <ecrist@secure-computing.net>
PORTNAME= ssl-admin
+DISTVERSIONPREFIX= v
DISTVERSION= 1.2.1
+PORTREVISION= 1
CATEGORIES= security
-MASTER_SITES= ftp://ftp.secure-computing.net/pub/FreeBSD/ports/ssl-admin/ \
- ftp://ftp2.secure-computing.net/pub/FreeBSD/ports/ssl-admin/
MAINTAINER= ecrist@secure-computing.net
COMMENT= OpenSSL certificate manager with OpenVPN support
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/../LICENSE
RUN_DEPENDS= zip:archivers/zip
USES= perl5 shebangfix tar:xz
-SHEBANG_FILES= ssl-admin
+USE_GITHUB= yes
+GH_ACCOUNT= ecrist
USE_PERL5= run
+
+SHEBANG_FILES= ssl-admin
+
GNU_CONFIGURE= yes
-SUB_FILES= pkg-message
+
MAKE_ENV= ETCDIR=${PREFIX}/etc BINDIR=${PREFIX}/bin \
MANDIR=${MANPREFIX}/man
NO_ARCH= yes
+SUB_FILES= pkg-message
+
+WRKSRC_SUBDIR= perl
post-patch:
${REINPLACE_CMD} -e 's|`which sed`|${SED}|' ${WRKSRC}/configure
diff --git a/security/ssl-admin/distinfo b/security/ssl-admin/distinfo
index 8995eeb67285..0fbf2b0ee6f2 100644
--- a/security/ssl-admin/distinfo
+++ b/security/ssl-admin/distinfo
@@ -1,2 +1,3 @@
-SHA256 (ssl-admin-1.2.1.tar.xz) = ebe6667c1beb79c7a12400e8a19bb4ec9f78ea7f72e0363d1eb10ed7f4b357ba
-SIZE (ssl-admin-1.2.1.tar.xz) = 12130
+TIMESTAMP = 1631537220
+SHA256 (ecrist-ssl-admin-v1.2.1_GH0.tar.gz) = 7afeb320398a3ef6474b1db446ba0115297401d205da8dc44165c1e1d0e05557
+SIZE (ecrist-ssl-admin-v1.2.1_GH0.tar.gz) = 33769
diff --git a/security/ssl-admin/pkg-plist b/security/ssl-admin/pkg-plist
index c6a6ddc21e41..802bd1a4fa02 100644
--- a/security/ssl-admin/pkg-plist
+++ b/security/ssl-admin/pkg-plist
@@ -1,5 +1,5 @@
bin/ssl-admin
-%%ETCDIR%%/openssl.conf.sample
-%%ETCDIR%%/ssl-admin.conf.sample
+@sample %%ETCDIR%%/openssl.conf.sample
+@sample %%ETCDIR%%/ssl-admin.conf.sample
man/man1/ssl-admin.1.gz
man/man5/ssl-admin.conf.5.gz