aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-24 20:05:17 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-24 20:06:35 +0000
commitf7864f141345fdb45daddd4395082b06e0d5b645 (patch)
tree720a4a31760686fc9941fd5d34143a52e30e8b0b
parentbdbc8cfb2a7afaeb825ad15a80c91b1f53193a37 (diff)
downloadports-f7864f141345fdb45daddd4395082b06e0d5b645.tar.gz
ports-f7864f141345fdb45daddd4395082b06e0d5b645.zip
audio/surge-synthesizer-xt-lv2: Fix build on ARM
... by adding cmake argument that docs require on ARM Reported by: fallout (cherry picked from commit c86b7de05b7e5975f143b9b48cd2ba95eec647a3)
-rw-r--r--audio/surge-synthesizer-xt-lv2/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/audio/surge-synthesizer-xt-lv2/Makefile b/audio/surge-synthesizer-xt-lv2/Makefile
index bb7263e01567..d287e4274236 100644
--- a/audio/surge-synthesizer-xt-lv2/Makefile
+++ b/audio/surge-synthesizer-xt-lv2/Makefile
@@ -63,4 +63,10 @@ BINARY_ALIAS= python=${PYTHON_CMD}
PORTSCOUT= ignore:1 # conflicts with old-gen audio/surge-synthesizer-lv2
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == armv6 || ${ARCH} == armv7 || ${ARCH} == aarch64
+CMAKE_ARGS+= -DARM_NATIVE=native # based on https://github.com/surge-synthesizer/surge/tree/release/1.9.0#building-for-arm-platforms
+.endif
+
.include <bsd.port.mk>