aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2022-03-28 17:58:50 +0000
committerBrooks Davis <brooks@FreeBSD.org>2022-03-28 17:58:50 +0000
commitf7b0e813f098ce7bafad184b77f614b5609d47a1 (patch)
tree0fee464e4697d03937a3e0e01a877f413cc6afcf
parent672ab322850511daa7bfebbee1c0b8c675b01e9e (diff)
downloadports-f7b0e813f098ce7bafad184b77f614b5609d47a1.tar.gz
ports-f7b0e813f098ce7bafad184b77f614b5609d47a1.zip
devel/llvm14: Fix build on 13.0
The guards for using system unwind.h appear to be incorrect so revert that part of 04e074c6fd452983ccfd931de0c43263d27fe1f PR: 262707
-rw-r--r--devel/llvm14/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/devel/llvm14/Makefile b/devel/llvm14/Makefile
index 8e3bb67aa2b8..6079037d489a 100644
--- a/devel/llvm14/Makefile
+++ b/devel/llvm14/Makefile
@@ -134,6 +134,9 @@ CLANG_SUB_LIST= XCC=clang${LLVM_SUFFIX} \
X_COMPILER_TYPE=clang
CLANG_USE= GNOME=libxml2
COMPILER_RT_DESC= Sanitizer libraries
+# An unwind.h is require to build. I think an in-tree one should be used
+# but this seems to work as a workaround...
+COMPILER_RT_BUILD_DEPENDS= libunwind>0:devel/libunwind
COMPILER_RT_CMAKE_ON= -DCOMPILER_RT_INSTALL_PATH=${LLVM_PREFIX}/lib/clang/${LLVM_RELEASE}
# Allow unwind.h to be found reliably
COMPILER_RT_USES= localbase
@@ -270,12 +273,6 @@ MLIR_PATTERN= ${MLIR_COMMANDS:S/^/bin./:tW:C/ */|/g}|mlir|libMLIR|obj.MLIRCAP
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 1300525
-# An unwind.h is require to build. I think an in-tree one should be used
-# but this seems to work as a workaround...
-COMPILER_RT_BUILD_DEPENDS= libunwind>0:devel/libunwind
-.endif
-
.if defined(PPC_ABI) && ${PPC_ABI} == ELFv2
EXTRA_PATCHES= ${FILESDIR}/extra-patch-clang_lib_Driver_ToolChains_Clang.cpp
.endif