aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-30 00:22:13 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-30 00:44:36 +0000
commitf7fb975a9fa69cb8fdfe1643cc5626a3609c6aa7 (patch)
tree8889985085e3527da07d3ce6d0df64a00561ab4d
parent7eed4e252281d4b592dd24bccf8ff5cfa73f794d (diff)
downloadports-f7fb975a9fa69cb8fdfe1643cc5626a3609c6aa7.tar.gz
ports-f7fb975a9fa69cb8fdfe1643cc5626a3609c6aa7.zip
devel/py-s3fs: Add AWSCLI and BOTO3 options
-rw-r--r--devel/py-s3fs/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/devel/py-s3fs/Makefile b/devel/py-s3fs/Makefile
index facc78a6e502..d00110957c72 100644
--- a/devel/py-s3fs/Makefile
+++ b/devel/py-s3fs/Makefile
@@ -21,4 +21,11 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+OPTIONS_DEFINE= AWSCLI BOTO3
+AWSCLI_DESC= Use awscli
+BOTO3_DESC= Use boto3
+
+AWSCLI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}awscli>=1.29.17:devel/py-awscli@${PY_FLAVOR}
+BOTO3_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto3>=1.28.17:www/py-boto3@${PY_FLAVOR}
+
.include <bsd.port.mk>