aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-07-17 09:04:15 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-07-17 09:17:58 +0000
commitf82a33af02bc85af38e635092f72ebf9cc363c2e (patch)
treebf5eae6cc548607dcdbbe0aabfc1784d2ffb621c
parentd620e07dbdba7b4619fccff6c662bc5127e67455 (diff)
downloadports-f82a33af02bc85af38e635092f72ebf9cc363c2e.tar.gz
ports-f82a33af02bc85af38e635092f72ebf9cc363c2e.zip
math/Imath: Update to v3.1.0
Changelog: https://github.com/AcademySoftwareFoundation/Imath/releases/tag/v3.1.0 This will require some minor changes to ports that depend on it.
-rw-r--r--math/Imath/Makefile8
-rw-r--r--math/Imath/distinfo6
-rw-r--r--math/Imath/files/patch-eabc884d079d26afcead5128f7b093978d239ada.diff13
-rw-r--r--math/Imath/pkg-plist4
4 files changed, 24 insertions, 7 deletions
diff --git a/math/Imath/Makefile b/math/Imath/Makefile
index 766db5dcf491..4bce7a75402f 100644
--- a/math/Imath/Makefile
+++ b/math/Imath/Makefile
@@ -1,7 +1,7 @@
# Based on the graphics/ilmbase port that was done by: nork@FreeBSD.org
PORTNAME= Imath
-PORTVERSION= 3.0.5
+PORTVERSION= 3.1.0
CATEGORIES= math devel graphics
MAINTAINER= mandree@FreeBSD.org
@@ -39,10 +39,10 @@ PYTHON_RUN_DEPENDS= ${PYNUMPY}
PYTHON_USES= python
PYTHON_CMAKE_BOOL= PYTHON
-_MAJORVER= 3_0
-_VER= 28
+_MAJORVER= 3_1
+_VER= 29
_MINVER= 0
-_PLVER= 2
+_PLVER= 0
post-install:
.for l in libImath
diff --git a/math/Imath/distinfo b/math/Imath/distinfo
index ee7202fa4db8..c6e81765f58d 100644
--- a/math/Imath/distinfo
+++ b/math/Imath/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1625132900
-SHA256 (AcademySoftwareFoundation-Imath-3.0.5-v3.0.5_GH0.tar.gz) = 38b94c840c6400959ccf647bc1631f96f3170cb081021d774813803e798208bd
-SIZE (AcademySoftwareFoundation-Imath-3.0.5-v3.0.5_GH0.tar.gz) = 528503
+TIMESTAMP = 1626453375
+SHA256 (AcademySoftwareFoundation-Imath-3.1.0-v3.1.0_GH0.tar.gz) = 211c907ab26d10bd01e446da42f073ee7381e1913d8fa48084444bc4e1b4ef87
+SIZE (AcademySoftwareFoundation-Imath-3.1.0-v3.1.0_GH0.tar.gz) = 566048
diff --git a/math/Imath/files/patch-eabc884d079d26afcead5128f7b093978d239ada.diff b/math/Imath/files/patch-eabc884d079d26afcead5128f7b093978d239ada.diff
new file mode 100644
index 000000000000..e7732e008c32
--- /dev/null
+++ b/math/Imath/files/patch-eabc884d079d26afcead5128f7b093978d239ada.diff
@@ -0,0 +1,13 @@
+diff --git a/src/Imath/half.h b/src/Imath/half.h
+index 6b0c7dc..c4a1b03 100644
+--- a/src/Imath/half.h
++++ b/src/Imath/half.h
+@@ -177,7 +177,7 @@
+ /// floats in question.
+ ///
+
+-#if defined(__has_include)
++#if defined(__has_include) && defined(__x86_64__)
+ # if __has_include(<x86intrin.h>)
+ # include <x86intrin.h>
+ # elif __has_include(<intrin.h>)
diff --git a/math/Imath/pkg-plist b/math/Imath/pkg-plist
index e3193a5a35e6..44b2dd139b1f 100644
--- a/math/Imath/pkg-plist
+++ b/math/Imath/pkg-plist
@@ -43,10 +43,12 @@ lib/libImath-%%MAJORVER%%.so.%%VER%%.0.%%PLVER%%
lib/libImath.so
libdata/pkgconfig/Imath.pc
%%PYTHON%%include/Imath/PyImath.h
+%%PYTHON%%include/Imath/PyImathAPI.h
%%PYTHON%%include/Imath/PyImathAutovectorize.h
%%PYTHON%%include/Imath/PyImathBasicTypes.h
%%PYTHON%%include/Imath/PyImathBox.h
%%PYTHON%%include/Imath/PyImathBoxArrayImpl.h
+%%PYTHON%%include/Imath/PyImathBufferProtocol.h
%%PYTHON%%include/Imath/PyImathColor.h
%%PYTHON%%include/Imath/PyImathColor3ArrayImpl.h
%%PYTHON%%include/Imath/PyImathColor4Array2DImpl.h
@@ -56,6 +58,7 @@ libdata/pkgconfig/Imath.pc
%%PYTHON%%include/Imath/PyImathExport.h
%%PYTHON%%include/Imath/PyImathFixedArray.h
%%PYTHON%%include/Imath/PyImathFixedArray2D.h
+%%PYTHON%%include/Imath/PyImathFixedArrayTraits.h
%%PYTHON%%include/Imath/PyImathFixedMatrix.h
%%PYTHON%%include/Imath/PyImathFixedVArray.h
%%PYTHON%%include/Imath/PyImathFrustum.h
@@ -67,6 +70,7 @@ libdata/pkgconfig/Imath.pc
%%PYTHON%%include/Imath/PyImathOperators.h
%%PYTHON%%include/Imath/PyImathPlane.h
%%PYTHON%%include/Imath/PyImathQuat.h
+%%PYTHON%%include/Imath/PyImathQuatOperators.h
%%PYTHON%%include/Imath/PyImathRandom.h
%%PYTHON%%include/Imath/PyImathShear.h
%%PYTHON%%include/Imath/PyImathStringArray.h