aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-07-09 17:20:24 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-07-09 17:36:35 +0000
commitf8a0151c2fbfdfedd776234f07f7d0e30f2a2b50 (patch)
tree79a9e1b9ab542dd916e02c02c33bc0090ad60628
parentc0f139b89306c012b33bdd4d676b107305ba3e06 (diff)
downloadports-f8a0151c2fbfdfedd776234f07f7d0e30f2a2b50.tar.gz
ports-f8a0151c2fbfdfedd776234f07f7d0e30f2a2b50.zip
devel/kdevelop: shuffle dependencies around
With the "lightening of the load" around KDE Frameworks, some of the traditional "batteries included" things have gone missing. Ensure that the IDE comes with the batteries for development of Qt and KDE applications.
-rw-r--r--devel/kdevelop/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/devel/kdevelop/Makefile b/devel/kdevelop/Makefile
index 714a0f1d5f36..2df8e3d2afd4 100644
--- a/devel/kdevelop/Makefile
+++ b/devel/kdevelop/Makefile
@@ -3,6 +3,7 @@
# devel/kdev-python
PORTNAME= kdevelop
DISTVERSION= 5.6.2
+PORTREVISION= 1
CATEGORIES= devel kde
MASTER_SITES= KDE/stable/kdevelop/${DISTVERSION}/src
DIST_SUBDIR= KDE/kdevelop
@@ -38,6 +39,12 @@ USE_QT= concurrent core dbus declarative gui help network \
script sql widgets xml buildtools_build qmake_build
SHEBANG_FILES= kdevplatform/util/kdevplatform_shell_environment.sh \
kdevplatform/util/.zshrc
+# Most ports have ecm_build, testlib_build, but because this is an
+# IDE, which **probably** is used for Qt / KDE development (also
+# other things, but let's guess a target market), pull in some
+# additional development things that are otherwise build-dep-only.
+USE_KDE+= ecm
+USE_QT+= testlib
CMAKE_ARGS= -DCMAKE_POLICY_DEFAULT_CMP0074=NEW -DLLVM_ROOT=${LOCALBASE}/llvm${LLVM_DEFAULT}