aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-04-14 06:40:42 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-04-14 06:44:33 +0000
commitf920019e64c95bd337b846eff601921457919f97 (patch)
tree550747b6bae0fdb32e1373f989914482c6a62638
parenta1e7979120a9e5cb29b66aca2fc411afd1e97157 (diff)
downloadports-f920019e64c95bd337b846eff601921457919f97.tar.gz
ports-f920019e64c95bd337b846eff601921457919f97.zip
Unbreak the build of `math/py-or-tools' against recently updated
`devel/abseil' by using the same treatment as in `math/or-tools'. Reported by: yuri Pointy hat to: danfe
-rw-r--r--math/py-or-tools/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/math/py-or-tools/Makefile b/math/py-or-tools/Makefile
index 8ec653834e69..b1511cd36122 100644
--- a/math/py-or-tools/Makefile
+++ b/math/py-or-tools/Makefile
@@ -48,6 +48,13 @@ SCIP_DESC= Use the SCIP solver # SCIP package isn't built because of licensing
SCIP_CMAKE_BOOL= USE_SCIP
SCIP_LIB_DEPENDS= libscip.so:math/SCIP
+post-patch:
+ @${REINPLACE_CMD} -e '/absl::container/s,^,#,' \
+ ${WRKSRC}/ortools/constraint_solver/CMakeLists.txt \
+ ${WRKSRC}/ortools/glop/CMakeLists.txt \
+ ${WRKSRC}/ortools/linear_solver/CMakeLists.txt \
+ ${WRKSRC}/ortools/sat/CMakeLists.txt
+
do-install: # by default cmake installs the whole or-tools project without the python part, so extract the wheel and install python files manually here
${MKDIR} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
cd ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR} && \