aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-11-12 16:23:35 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-11-19 13:48:55 +0000
commitf988ff1f1c4ce47a90144ea66784949a734918d8 (patch)
tree2fba0062e87a55dde749097577e617b0a858a9ec
parentcb7c09ae6a8e985ca9c7d3afe46ca62ad63511ee (diff)
downloadports-f988ff1f1c4ce47a90144ea66784949a734918d8.tar.gz
ports-f988ff1f1c4ce47a90144ea66784949a734918d8.zip
lang/intel-compute-runtime: update to 21.46.21636
-rw-r--r--lang/intel-compute-runtime/Makefile2
-rw-r--r--lang/intel-compute-runtime/distinfo6
-rw-r--r--lang/intel-compute-runtime/files/patch-no-perf14
3 files changed, 11 insertions, 11 deletions
diff --git a/lang/intel-compute-runtime/Makefile b/lang/intel-compute-runtime/Makefile
index 2c963bd554bf..38a34e678b5c 100644
--- a/lang/intel-compute-runtime/Makefile
+++ b/lang/intel-compute-runtime/Makefile
@@ -1,5 +1,5 @@
PORTNAME= compute-runtime
-DISTVERSION= 21.45.21574
+DISTVERSION= 21.46.21636
CATEGORIES= lang
PKGNAMEPREFIX= intel-
PKGNAMESUFFIX= -${FLAVOR}
diff --git a/lang/intel-compute-runtime/distinfo b/lang/intel-compute-runtime/distinfo
index 5d9f84c36c1d..4317bc08a436 100644
--- a/lang/intel-compute-runtime/distinfo
+++ b/lang/intel-compute-runtime/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1636140707
-SHA256 (intel-compute-runtime-21.45.21574_GH0.tar.gz) = bf76ba2a6dd75ff528b0399fa75058a8ea8799c6b6048c25a4671ff1c699b468
-SIZE (intel-compute-runtime-21.45.21574_GH0.tar.gz) = 4868091
+TIMESTAMP = 1636734215
+SHA256 (intel-compute-runtime-21.46.21636_GH0.tar.gz) = 8e80c566fee646fbb8bb93cfe371723c9f2654d3ba2c7c62adea003add2b2aee
+SIZE (intel-compute-runtime-21.46.21636_GH0.tar.gz) = 4878855
diff --git a/lang/intel-compute-runtime/files/patch-no-perf b/lang/intel-compute-runtime/files/patch-no-perf
index 04729eaa066a..088e2b1541bf 100644
--- a/lang/intel-compute-runtime/files/patch-no-perf
+++ b/lang/intel-compute-runtime/files/patch-no-perf
@@ -32,20 +32,20 @@ level_zero/tools/source/sysman/linux/pmu/pmu_imp.h:12:10: fatal error: 'linux/pe
}
LinuxEngineImp::LinuxEngineImp(OsSysman *pOsSysman, zes_engine_group_t type, uint32_t engineInstance) : engineGroup(type), engineInstance(engineInstance) {
---- level_zero/tools/source/sysman/linux/os_sysman_imp.cpp.orig 2021-10-22 17:59:55 UTC
+--- level_zero/tools/source/sysman/linux/os_sysman_imp.cpp.orig 2021-11-12 16:23:35 UTC
+++ level_zero/tools/source/sysman/linux/os_sysman_imp.cpp
-@@ -47,9 +47,11 @@ ze_result_t LinuxSysmanImp::init() {
- auto rootPciPathOfGpuDevice = getPciRootPortDirectoryPath(realRootPath);
- PlatformMonitoringTech::create(pParentSysmanDeviceImp->deviceHandles, pFsAccess, rootPciPathOfGpuDevice, mapOfSubDeviceIdToPmtObject);
+@@ -36,9 +36,11 @@ ze_result_t LinuxSysmanImp::init() {
+ }
+ DEBUG_BREAK_IF(nullptr == pSysfsAccess);
+#ifdef __linux__
pPmuInterface = PmuInterface::create(this);
DEBUG_BREAK_IF(nullptr == pPmuInterface);
+#endif
- auto loc = realRootPath.find_last_of('/');
- std::string pciBDF = realRootPath.substr(loc + 1, std::string::npos);
- pFwUtilInterface = FirmwareUtil::create(pciBDF);
+ pFwUtilInterface = FirmwareUtil::create(pDrm->getPciPath());
+ return createPmtHandles();
+ }
--- level_zero/tools/source/sysman/linux/os_sysman_imp.h.orig 2021-10-01 16:31:56 UTC
+++ level_zero/tools/source/sysman/linux/os_sysman_imp.h
@@ -14,7 +14,9 @@