aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 14:13:19 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:06:08 +0000
commitfa39b281adb9ca0fdce94b03f783f44ef296cdd9 (patch)
treeeeda2fc8f0d4046a92dd809032b9fc41c7b1bdfc
parentcd8081bb5590971fa9d2d11a58e3d5f64c5436a3 (diff)
downloadports-fa39b281adb9ca0fdce94b03f783f44ef296cdd9.tar.gz
ports-fa39b281adb9ca0fdce94b03f783f44ef296cdd9.zip
net-im/py-mattermostdriver: Add py-mattermostdriver 7.3.2
mattermostdriver is the Python Mattermost Driver for API v4. You interact with this module mainly by using the Driver class. If you want to access information about the logged in user, like the user id, you can access them by using Driver.client.userid.
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/py-mattermostdriver/Makefile23
-rw-r--r--net-im/py-mattermostdriver/distinfo3
-rw-r--r--net-im/py-mattermostdriver/pkg-descr5
4 files changed, 32 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 63ce6b19620c..8db413a7f55e 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -111,6 +111,7 @@
SUBDIR += purple-slack
SUBDIR += py-fbmq
SUBDIR += py-matrix-synapse
+ SUBDIR += py-mattermostdriver
SUBDIR += py-nbxmpp
SUBDIR += py-punjab
SUBDIR += py-python-telegram-bot
diff --git a/net-im/py-mattermostdriver/Makefile b/net-im/py-mattermostdriver/Makefile
new file mode 100644
index 000000000000..edd2ece9c7c4
--- /dev/null
+++ b/net-im/py-mattermostdriver/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= mattermostdriver
+PORTVERSION= 7.3.2
+CATEGORIES= net-im python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python Mattermost Driver
+WWW= https://vaelor.github.io/python-mattermost-driver/ \
+ https://github.com/Vaelor/python-mattermost-driver
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.25:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}websockets>=8:devel/py-websockets@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net-im/py-mattermostdriver/distinfo b/net-im/py-mattermostdriver/distinfo
new file mode 100644
index 000000000000..16559403a2f2
--- /dev/null
+++ b/net-im/py-mattermostdriver/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1708448842
+SHA256 (mattermostdriver-7.3.2.tar.gz) = 2e4d7b4a17d3013e279c6f993746ea18cd60b45d8fa3be24f47bc2de22b9b3b4
+SIZE (mattermostdriver-7.3.2.tar.gz) = 22144
diff --git a/net-im/py-mattermostdriver/pkg-descr b/net-im/py-mattermostdriver/pkg-descr
new file mode 100644
index 000000000000..9b0c961f07cf
--- /dev/null
+++ b/net-im/py-mattermostdriver/pkg-descr
@@ -0,0 +1,5 @@
+mattermostdriver is the Python Mattermost Driver for API v4.
+
+You interact with this module mainly by using the Driver class. If you want to
+access information about the logged in user, like the user id, you can access
+them by using Driver.client.userid.