aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 18:23:06 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 18:26:14 +0000
commitfa5149297a9b8f6c884128f9d06629e29f7832cf (patch)
tree8a3e7a8e9cadb697df63d68604cbd3ff12dabdd5
parent492a7f81b14ced60bb6094ca1c7d50596a3d2c0c (diff)
downloadports-fa5149297a9b8f6c884128f9d06629e29f7832cf.tar.gz
ports-fa5149297a9b8f6c884128f9d06629e29f7832cf.zip
science/crf++: Fix build with llvm16
- Mark DEPRECATED as last upstream activity was in 2015 - Set EXPIRATION_DATE to 2023-09-30 - Pet portclippy Sponsored by: The FreeBSD Foundation
-rw-r--r--science/crf++/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/science/crf++/Makefile b/science/crf++/Makefile
index 53ee1a38372a..777825138448 100644
--- a/science/crf++/Makefile
+++ b/science/crf++/Makefile
@@ -2,7 +2,7 @@ PORTNAME= crf++
# 0.59 as defined in
# https://github.com/taku910/crfpp/commit/d78526835e4cfcc4822156724edda8a3839327c2
DISTVERSION= 0.59
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science math
PATCH_SITES= https://patch-diff.githubusercontent.com/raw/taku910/crfpp/pull/:pr
PATCHFILES= 15.patch:-p1:pr \
@@ -17,19 +17,28 @@ LICENSE_COMB= dual
LICENSE_FILE_BSD3CLAUSE= ${WRKSRC}/BSD
LICENSE_FILE_LGPL21+ = ${WRKSRC}/LGPL
+DEPRECATED= Last upstream activity was in 2015
+EXPIRATION_DATE= 2023-09-30
+
USES= libtool
USE_GITHUB= yes
GH_ACCOUNT= taku910
GH_PROJECT= crfpp
GH_TAGNAME= 1dc92a606f874a4fe52603803364cc1d90f952fb
USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
+
INSTALL_TARGET= install-strip
PORTEXAMPLES= JapaneseNE basenp chunking seg
OPTIONS_DEFINE= EXAMPLES
+post-patch:
+ @${REINPLACE_CMD} -e 's|CXXFLAGS=\"-O3 -Wall|CXXFLAGS=\"-O3 -Wall --std=c++14|g' \
+ ${WRKSRC}/configure
+
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAPLESDIR}
(cd ${WRKSRC}/example && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})