aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-19 08:21:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-19 08:46:11 +0000
commitfadadd92e69dc54d23bc41f1386d40967b1372a9 (patch)
tree577e338309f8e9b51c5b473b63ed95b0dd88f5a8
parent78701c99c11a8ab41f6826bb871259b874ab553f (diff)
downloadports-fadadd92e69dc54d23bc41f1386d40967b1372a9.tar.gz
ports-fadadd92e69dc54d23bc41f1386d40967b1372a9.zip
science/openems: Change to vtk8 because the app using this library doesn't support vtk9
-rw-r--r--science/openems/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/science/openems/Makefile b/science/openems/Makefile
index 083f233dcd3d..2893f6fee19a 100644
--- a/science/openems/Makefile
+++ b/science/openems/Makefile
@@ -2,6 +2,7 @@ PORTNAME= openems
DISTVERSIONPREFIX= v
DISTVERSION= 0.0.35-71
DISTVERSIONSUFFIX= -g4c24b6e
+PORTREVISION= 1
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
@@ -10,21 +11,27 @@ COMMENT= Electromagnetic field solver using the EC-FDTD method
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
+# many dependencies below are induced by vtk8, but not vtk9
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libCSXCAD.so:cad/csxcad \
+ libexpat.so:textproc/expat2 \
libfparser-4.5.so:math/fparser \
libhdf5.so:science/hdf5 \
+ libpng16.so:graphics/png \
libsz.so:science/szip \
+ libtiff.so:graphics/tiff \
libtinyxml.so:textproc/tinyxml \
- libvtkCommonCore-9.0.so:math/vtk9
+ libvtkCommonCore-8.2.so:math/vtk8 # some related packages don't support vtk9 yet, see https://github.com/thliebig/QCSXCAD/issues/6#issuecomment-901633240
-USES= cmake pkgconfig
+USES= cmake jpeg pkgconfig
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= thliebig
GH_PROJECT= openEMS
+CMAKE_ARGS= -DVTK_DIR=${LOCALBASE}/lib/vtk-8.2/cmake/vtk-8.2
+
CXXFLAGS+= -I${LOCALBASE}/include/fparser # fparser.pc probably returns a wrong value
DATADIR= ${PREFIX}/share/openEMS