aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Li <vishwin@FreeBSD.org>2024-02-27 20:08:12 +0000
committerCharlie Li <vishwin@FreeBSD.org>2024-02-27 20:09:35 +0000
commitfb23a4055e248a1aff5857a0bc99fc91607f525f (patch)
treea182bb8d62414cbc1ee2a7ead19c38db05240193
parent0d63ea90835a7c4ab8a957423488ef1b5acad527 (diff)
downloadports-fb23a4055e248a1aff5857a0bc99fc91607f525f.tar.gz
ports-fb23a4055e248a1aff5857a0bc99fc91607f525f.zip
devel/py-pytest-drop-dup-tests: add ${PY_SETUPTOOLS} to BUILD_DEPENDS
setuptools-scm is not a PEP-517 build backend; add the real one. Otherwise this build will fail once the linked PR is committed. With hat: python PR: 272134
-rw-r--r--devel/py-pytest-drop-dup-tests/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/devel/py-pytest-drop-dup-tests/Makefile b/devel/py-pytest-drop-dup-tests/Makefile
index d187fa87e4d4..39ca8acb92f2 100644
--- a/devel/py-pytest-drop-dup-tests/Makefile
+++ b/devel/py-pytest-drop-dup-tests/Makefile
@@ -11,7 +11,8 @@ WWW= https://github.com/nicoddemus/pytest-drop-dup-tests
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR} \
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tox>0:devel/py-tox@${PY_FLAVOR}