aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2024-02-12 12:20:01 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2024-02-18 11:32:07 +0000
commitfb34e270eef29f3a3c0b8d0c1c5956615335542e (patch)
tree722c86f423920a847ef1541cda4984385a80de84
parent775ff5dfef3d317706f73151e2bef856aa1e7d3b (diff)
downloadports-fb34e270eef29f3a3c0b8d0c1c5956615335542e.tar.gz
ports-fb34e270eef29f3a3c0b8d0c1c5956615335542e.zip
graphics/py-pdf2image: New port
Wrapper to convert pdf to a pil image list
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-pdf2image/Makefile23
-rw-r--r--graphics/py-pdf2image/distinfo3
-rw-r--r--graphics/py-pdf2image/pkg-descr2
4 files changed, 29 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 91bb51a36dfc..8dc13c692006 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -916,6 +916,7 @@
SUBDIR += py-optimize-images
SUBDIR += py-osmnet
SUBDIR += py-pandana
+ SUBDIR += py-pdf2image
SUBDIR += py-photocollage
SUBDIR += py-piexif
SUBDIR += py-pillow
diff --git a/graphics/py-pdf2image/Makefile b/graphics/py-pdf2image/Makefile
new file mode 100644
index 000000000000..0dde6308816e
--- /dev/null
+++ b/graphics/py-pdf2image/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= pdf2image
+PORTVERSION= 1.17.0
+CATEGORIES= graphics python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= grembo@FreeBSD.org
+COMMENT= Wrapper to convert pdf to a pil image list
+WWW= https://github.com/Belval/pdf2image
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
+ pdftocairo:graphics/poppler-utils \
+ pdftoppm:graphics/poppler-utils
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-pdf2image/distinfo b/graphics/py-pdf2image/distinfo
new file mode 100644
index 000000000000..0c391a841d68
--- /dev/null
+++ b/graphics/py-pdf2image/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1707593750
+SHA256 (pdf2image-1.17.0.tar.gz) = eaa959bc116b420dd7ec415fcae49b98100dda3dd18cd2fdfa86d09f112f6d57
+SIZE (pdf2image-1.17.0.tar.gz) = 12811
diff --git a/graphics/py-pdf2image/pkg-descr b/graphics/py-pdf2image/pkg-descr
new file mode 100644
index 000000000000..db5e15e540c3
--- /dev/null
+++ b/graphics/py-pdf2image/pkg-descr
@@ -0,0 +1,2 @@
+A python (3.7+) module that wraps pdftoppm and pdftocairo to convert PDF to a
+PIL Image object