aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2022-10-24 16:22:19 +0000
committerThierry Thomas <thierry@FreeBSD.org>2022-10-26 17:58:26 +0000
commitfb5d8423ae1d43ff5012df1e37ba8b8c843a69fe (patch)
treea5735760e124fce1952d81f54fc89c1f067ad8a3
parent33f3c23490c31d982bf5c7d9a4c381e14510f5a1 (diff)
downloadports-fb5d8423ae1d43ff5012df1e37ba8b8c843a69fe.tar.gz
ports-fb5d8423ae1d43ff5012df1e37ba8b8c843a69fe.zip
science/erkale: chase libXC 6.0.0
-rw-r--r--science/erkale/Makefile2
-rw-r--r--science/erkale/files/patch-src_dftfuncs.cpp38
2 files changed, 39 insertions, 1 deletions
diff --git a/science/erkale/Makefile b/science/erkale/Makefile
index 776388757f96..5a47285ac273 100644
--- a/science/erkale/Makefile
+++ b/science/erkale/Makefile
@@ -1,6 +1,6 @@
PORTNAME= erkale
DISTVERSION= g20220405
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
diff --git a/science/erkale/files/patch-src_dftfuncs.cpp b/science/erkale/files/patch-src_dftfuncs.cpp
new file mode 100644
index 000000000000..7961ddc433b2
--- /dev/null
+++ b/science/erkale/files/patch-src_dftfuncs.cpp
@@ -0,0 +1,38 @@
+--- src/dftfuncs.cpp.orig 2022-04-05 18:34:51 UTC
++++ src/dftfuncs.cpp
+@@ -434,7 +434,7 @@ double exact_exchange(int func_id) {
+ }
+
+
+-#if XC_MAJOR_VERSION >= 6
++#if XC_MAJOR_VERSION > 6
+ switch(xc_hyb_type(&func)) {
+ case(XC_HYB_HYBRID):
+ f=xc_hyb_exx_coef(&func);
+@@ -480,7 +480,7 @@ bool is_supported(int func_id) {
+ throw std::runtime_error(oss.str());
+ }
+ // Get flag
+-#if XC_MAJOR_VERSION >= 6
++#if XC_MAJOR_VERSION > 6
+ switch(xc_hyb_type(&func)) {
+ case(XC_HYB_SEMILOCAL):
+ case(XC_HYB_HYBRID):
+@@ -514,7 +514,7 @@ bool is_range_separated(int func_id, bool check) {
+ oss << "Functional "<<func_id<<" not found!";
+ throw std::runtime_error(oss.str());
+ }
+-#if XC_MAJOR_VERSION >= 6
++#if XC_MAJOR_VERSION > 6
+ ans=(xc_hyb_type(&func) == XC_HYB_CAM);
+ #else
+ // Get flag
+@@ -571,7 +571,7 @@ void range_separation(int func_id, double & omega, dou
+ xc_func_set_ext_params(&func, pars.memptr());
+ }
+
+-#if XC_MAJOR_VERSION >= 6
++#if XC_MAJOR_VERSION > 6
+ switch(xc_hyb_type(&func)) {
+ case(XC_HYB_HYBRID):
+ case(XC_HYB_CAM):