aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-27 19:44:00 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-27 19:48:06 +0000
commitfb80bc28b376e3c321df665cf7e94add97d616d7 (patch)
tree270912ba05bd3d12f922d2f35d42b0db7d59e4a9
parentdbfb7431bb2799d01191bb5df11ecc4953faed22 (diff)
downloadports-fb80bc28b376e3c321df665cf7e94add97d616d7.tar.gz
ports-fb80bc28b376e3c321df665cf7e94add97d616d7.zip
devel/py-installer: Add py-installer 0.2.3
This is a low-level library for installing a Python package from a wheel distribution. It provides basic functionality and abstractions for handling wheels and installing packages from wheels. - Logic for "unpacking" a wheel (i.e. installation). - Abstractions for various parts of the unpacking process. - Extensible simple implementations of the abstractions. - Platform-independent Python script wrapper generation. WWW: https://github.com/pradyunsg/installer
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-installer/Makefile26
-rw-r--r--devel/py-installer/distinfo3
-rw-r--r--devel/py-installer/pkg-descr10
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index de251f194795..12358cd22353 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4587,6 +4587,7 @@
SUBDIR += py-iniconfig
SUBDIR += py-inifile
SUBDIR += py-iniparse
+ SUBDIR += py-installer
SUBDIR += py-intbitset
SUBDIR += py-intervals
SUBDIR += py-intervaltree
diff --git a/devel/py-installer/Makefile b/devel/py-installer/Makefile
new file mode 100644
index 000000000000..41d3a06c8947
--- /dev/null
+++ b/devel/py-installer/Makefile
@@ -0,0 +1,26 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= installer
+PORTVERSION= 0.2.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Library for installing Python wheels
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 30700
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-resources>=0:devel/py-importlib-resources@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-installer/distinfo b/devel/py-installer/distinfo
new file mode 100644
index 000000000000..0806f909c311
--- /dev/null
+++ b/devel/py-installer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632760420
+SHA256 (installer-0.2.3.tar.gz) = 82c899f5e3c78303242df9c9ca7ac58001c9806d8c23fa2772be769d1f560fe5
+SIZE (installer-0.2.3.tar.gz) = 310274
diff --git a/devel/py-installer/pkg-descr b/devel/py-installer/pkg-descr
new file mode 100644
index 000000000000..7baa82b559c4
--- /dev/null
+++ b/devel/py-installer/pkg-descr
@@ -0,0 +1,10 @@
+This is a low-level library for installing a Python package from a wheel
+distribution. It provides basic functionality and abstractions for handling
+wheels and installing packages from wheels.
+
+- Logic for "unpacking" a wheel (i.e. installation).
+- Abstractions for various parts of the unpacking process.
+- Extensible simple implementations of the abstractions.
+- Platform-independent Python script wrapper generation.
+
+WWW: https://github.com/pradyunsg/installer