aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-06-30 12:11:46 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-06-30 12:37:24 +0000
commitfb9677dec35874886abfa33da1b1e426a0bb97ec (patch)
treee051fbeba475a6a17efb585f5a57a1c618466e01
parent3705eeafd2b6a3fc443fc146fa8354f3d8b82321 (diff)
downloadports-fb9677dec35874886abfa33da1b1e426a0bb97ec.tar.gz
ports-fb9677dec35874886abfa33da1b1e426a0bb97ec.zip
x11-wm/gamescope: temporarily use static wlroots after f2820b6cc217
-rw-r--r--x11-wm/gamescope/Makefile20
-rw-r--r--x11-wm/gamescope/distinfo2
-rw-r--r--x11-wm/gamescope/files/patch-private-wlroots35
3 files changed, 55 insertions, 2 deletions
diff --git a/x11-wm/gamescope/Makefile b/x11-wm/gamescope/Makefile
index 96074dff52fd..990ddd821046 100644
--- a/x11-wm/gamescope/Makefile
+++ b/x11-wm/gamescope/Makefile
@@ -16,8 +16,6 @@ COMMENT= Micro-compositor from SteamOS
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN= fails to build after https://github.com/swaywm/wlroots/commit/9ecfa4343a6d
-
BUILD_DEPENDS= glslangValidator:graphics/glslang \
evdev-proto>0:devel/evdev-proto \
vulkan-headers>0:graphics/vulkan-headers \
@@ -39,4 +37,22 @@ GH_TUPLE= emersion:libliftoff:b08bbaa:libliftoff/subprojects/libliftoff
CPPFLAGS+= -D_WITH_DPRINTF # XXX Remove after FreeBSD 11 EOL
PLIST_FILES= bin/${PORTNAME}
+# Bundle wlroots due to breaking changes:
+# https://github.com/swaywm/wlroots/commit/9ecfa4343a6d
+# https://github.com/swaywm/wlroots/commit/a109a80dca50
+BUILD_DEPENDS:= ${BUILD_DEPENDS:N*wlroots*} \
+ xwayland-devel>0:x11-servers/xwayland-devel
+LIB_DEPENDS:= ${LIB_DEPENDS:N*wlroots*} \
+ libudev.so:devel/libudev-devd \
+ libseat.so:sysutils/seatd \
+ libinput.so:x11/libinput \
+ libxcb-errors.so:x11/xcb-util-errors \
+ libxcb-render-util.so:x11/xcb-util-renderutil \
+ libxcb-icccm.so:x11/xcb-util-wm
+RUN_DEPENDS+= xwayland-devel>0:x11-servers/xwayland-devel
+USE_XORG+= pixman xcb
+USE_GL+= gbm egl
+GH_TUPLE+= swaywm:wlroots:0.13.0:wlroots/subprojects/wlroots
+PLIST_FILES+= "@comment libdata/pkgconfig/wlroots.pc"
+
.include <bsd.port.mk>
diff --git a/x11-wm/gamescope/distinfo b/x11-wm/gamescope/distinfo
index 23b3d9c7e22c..43a46796152d 100644
--- a/x11-wm/gamescope/distinfo
+++ b/x11-wm/gamescope/distinfo
@@ -3,6 +3,8 @@ SHA256 (Plagman-gamescope-3.8.4_GH0.tar.gz) = 761d0baa20b683cb3f3bb0126229a05b29
SIZE (Plagman-gamescope-3.8.4_GH0.tar.gz) = 72030
SHA256 (emersion-libliftoff-b08bbaa_GH0.tar.gz) = bc689419a96d5e2428b77d3cf9e95f532ae89295345bdaf288df24adc4803a04
SIZE (emersion-libliftoff-b08bbaa_GH0.tar.gz) = 27461
+SHA256 (swaywm-wlroots-0.13.0_GH0.tar.gz) = f6bea37fd4a6f5e5f552b83d61adae8c73e64b0bcb9ae0ab464ebcd9309d3cf3
+SIZE (swaywm-wlroots-0.13.0_GH0.tar.gz) = 503575
SHA256 (8fae1ff56a62.patch) = 7a636fec88d914047abed0c91268ae1b7779f48e36c74efd37868f2c7ba3955e
SIZE (8fae1ff56a62.patch) = 2778
SHA256 (f36133f27fbc.patch) = e4aa6245782f96387c7083c749da6a3cd84f4a320ec70b448984572c37f76962
diff --git a/x11-wm/gamescope/files/patch-private-wlroots b/x11-wm/gamescope/files/patch-private-wlroots
new file mode 100644
index 000000000000..68b8cc175721
--- /dev/null
+++ b/x11-wm/gamescope/files/patch-private-wlroots
@@ -0,0 +1,35 @@
+wlroots 0.13.0 is out-of-date and has no other consumers. Keep it
+private to gamescope package for now.
+
+--- subprojects/wlroots/include/meson.build.orig 2021-04-07 19:19:31 UTC
++++ subprojects/wlroots/include/meson.build
+@@ -17,7 +17,9 @@ if not features.get('xdg-foreign')
+ ]
+ endif
+
++if not meson.is_subproject()
+ install_subdir('wlr',
+ install_dir: get_option('includedir'),
+ exclude_files: exclude_files,
+ )
++endif
+--- subprojects/wlroots/include/wlr/meson.build.orig 2021-04-07 19:19:31 UTC
++++ subprojects/wlroots/include/wlr/meson.build
+@@ -21,4 +21,6 @@ ver_h = configure_file(
+ configuration: version_data,
+ )
+
++if not meson.is_subproject()
+ install_headers(conf_h, ver_h, subdir: 'wlr')
++endif
+--- subprojects/wlroots/meson.build.orig 2021-04-07 19:19:31 UTC
++++ subprojects/wlroots/meson.build
+@@ -153,7 +153,7 @@ lib_wlr = library(
+ soversion: soversion,
+ dependencies: wlr_deps,
+ include_directories: [wlr_inc, proto_inc],
+- install: true,
++ install: not meson.is_subproject(),
+ link_args: symbols_flag,
+ link_depends: symbols_file,
+ )