aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-02-01 16:26:31 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-02-08 02:45:23 +0000
commitfba6c610d303634715eb7fdde52ba6660576bd2d (patch)
treeae5e56655502c34a439c463c0660e4a43a80f021
parent61cd6326134cafd47e1c9273d01af3afe69f2921 (diff)
downloadports-fba6c610d303634715eb7fdde52ba6660576bd2d.tar.gz
ports-fba6c610d303634715eb7fdde52ba6660576bd2d.zip
benchmarks/vkoverhead: add new port
vkoverhead is a tool for evaluating CPU-based overhead of Vulkan drivers. It was inspired heavily by drawoverhead from piglit. ## Features * extreme granularity for profiling specific scenarios * simple to use * CSV output for ease of script parsing * zero dependencies https://github.com/zmike/vkoverhead
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/vkoverhead/Makefile31
-rw-r--r--benchmarks/vkoverhead/distinfo7
-rw-r--r--benchmarks/vkoverhead/pkg-descr8
4 files changed, 47 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index e66dcc2ca0e6..1ad8596bae0b 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -113,6 +113,7 @@
SUBDIR += uperf
SUBDIR += vegeta
SUBDIR += vkmark
+ SUBDIR += vkoverhead
SUBDIR += vkpeak
SUBDIR += webbench
SUBDIR += wrk
diff --git a/benchmarks/vkoverhead/Makefile b/benchmarks/vkoverhead/Makefile
new file mode 100644
index 000000000000..bf1e07d87e2c
--- /dev/null
+++ b/benchmarks/vkoverhead/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= vkoverhead
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.2
+CATEGORIES= benchmarks
+
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= 1a37beb59ac8.patch:-p1 # https://github.com/zmike/vkoverhead/pull/18
+PATCHFILES+= 62c8ad1a795f.patch:-p1 # https://github.com/zmike/vkoverhead/pull/12
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Evaluate CPU overhead of Vulkan drivers
+WWW= https://github.com/zmike/vkoverhead
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BROKEN_i386= fails to build due -Werror=int-conversion
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mako>0:textproc/py-mako@${PY_FLAVOR}
+RUN_DEPENDS= vulkan-loader>0:graphics/vulkan-loader
+
+USES= compiler:c11 meson pkgconfig python:build
+USE_GITHUB= yes
+GH_ACCOUNT= zmike
+PLIST_FILES= bin/${PORTNAME}
+
+post-patch:
+# Derive Python version from Meson
+ @${REINPLACE_CMD} -e "s,'python3',," ${WRKSRC}/meson.build
+
+.include <bsd.port.mk>
diff --git a/benchmarks/vkoverhead/distinfo b/benchmarks/vkoverhead/distinfo
new file mode 100644
index 000000000000..d4bb7751314c
--- /dev/null
+++ b/benchmarks/vkoverhead/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1675268791
+SHA256 (zmike-vkoverhead-v1.2_GH0.tar.gz) = 9b105cb218b66f26552a9055a70fe20ff239b891762f650a19d78bfe24ab0d22
+SIZE (zmike-vkoverhead-v1.2_GH0.tar.gz) = 999054
+SHA256 (1a37beb59ac8.patch) = 0f4d99cb62a64e9d6fce26eb49289e343dc7f8f1e9235bcbe546e19e4280742a
+SIZE (1a37beb59ac8.patch) = 710
+SHA256 (62c8ad1a795f.patch) = 7ca952381d658bb73eb8ab9fcc0bcff4d58aa37e3f6583a7fd46eec9ca7db8d6
+SIZE (62c8ad1a795f.patch) = 648
diff --git a/benchmarks/vkoverhead/pkg-descr b/benchmarks/vkoverhead/pkg-descr
new file mode 100644
index 000000000000..5fc36a01e1dd
--- /dev/null
+++ b/benchmarks/vkoverhead/pkg-descr
@@ -0,0 +1,8 @@
+vkoverhead is a tool for evaluating CPU-based overhead of Vulkan
+drivers. It was inspired heavily by drawoverhead from piglit.
+
+## Features
+* extreme granularity for profiling specific scenarios
+* simple to use
+* CSV output for ease of script parsing
+* zero dependencies