aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-01 02:40:28 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-01 02:40:28 +0000
commitfbf47a8a60990218d71e8828065b1cab3d75bfb9 (patch)
tree3c6587bde7adbe5f87555726f476f6a3a16e6ff3
parentfaf97a481bfd54f1ebaa205508234cedd6a0aaef (diff)
downloadports-fbf47a8a60990218d71e8828065b1cab3d75bfb9.tar.gz
ports-fbf47a8a60990218d71e8828065b1cab3d75bfb9.zip
graphics/kgeotag: only use webengine where it's actually supported
-rw-r--r--graphics/kgeotag/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/kgeotag/Makefile b/graphics/kgeotag/Makefile
index cea87c9b0ff1..a8b731dde9fe 100644
--- a/graphics/kgeotag/Makefile
+++ b/graphics/kgeotag/Makefile
@@ -17,7 +17,13 @@ USE_KDE= coreaddons config configwidgets crash i18n libkexiv2 \
ecm_build
# From stage-qa; these are not checked explicitly, but link
# transitively though other KDE components (mostly Marble).
-USE_QT+= dbus declarative location network printsupport webchannel webengine xml
+USE_QT+= dbus declarative location network printsupport webchannel xml
USE_KDE+= auth codecs widgetsaddons
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == aarch64 || ${ARCH} == amd64 || ${ARCH} == i386
+USE_QT+= webengine
+.endif
+
.include <bsd.port.mk>