aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalf Gebhart <gebhart@secnetix.de>2023-11-29 18:18:35 +0000
committerRenato Botelho <garga@FreeBSD.org>2023-11-29 18:20:48 +0000
commitfc1d174e5cec8f1699f840d0216868da658aa30a (patch)
tree2e7abe42a2b2ea5b6c7450b0664c3ae799768af9
parentba86aef8c7c3439a736f9f021ddc342ae68d81bb (diff)
downloadports-fc1d174e5cec8f1699f840d0216868da658aa30a.tar.gz
ports-fc1d174e5cec8f1699f840d0216868da658aa30a.zip
www/mod_umask: Fix build on FreeBSD 14+
PR: 275429
-rw-r--r--www/mod_umask/Makefile5
-rw-r--r--www/mod_umask/files/patch-src_mod__umask.c19
2 files changed, 21 insertions, 3 deletions
diff --git a/www/mod_umask/Makefile b/www/mod_umask/Makefile
index 5c6f97243fdd..95fab0d45927 100644
--- a/www/mod_umask/Makefile
+++ b/www/mod_umask/Makefile
@@ -11,13 +11,12 @@ WWW= http://www.outoforder.cc/projects/httpd/mod_umask/
LICENSE= APACHE20
-BROKEN_FreeBSD_14= fails to build: incompatible function pointer types
-
USES= apache tar:bzip2
-GNU_CONFIGURE= yes
AP_FAST_BUILD= yes
AP_GENPLIST= yes
SRC_FILE= src/${PORTNAME}.c
+GNU_CONFIGURE= yes
+
.include <bsd.port.mk>
diff --git a/www/mod_umask/files/patch-src_mod__umask.c b/www/mod_umask/files/patch-src_mod__umask.c
new file mode 100644
index 000000000000..aeda748019bb
--- /dev/null
+++ b/www/mod_umask/files/patch-src_mod__umask.c
@@ -0,0 +1,19 @@
+--- src/mod_umask.c.orig 2004-10-12 19:03:16 UTC
++++ src/mod_umask.c
+@@ -26,6 +26,7 @@
+ *
+ */
+
++#include <sys/stat.h>
+ #include "httpd.h"
+ #include "http_core.h"
+ #include "http_config.h"
+@@ -42,7 +43,7 @@ struct umask_config_rec
+ long int mask;
+ };
+
+-static void *umask_create_config(apr_pool_t * p, char *dir)
++static void *umask_create_config(apr_pool_t * p, server_rec *dir)
+ {
+ umask_config_rec *dConfig = apr_pcalloc(p, sizeof(*dConfig));
+