aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2022-10-16 14:49:30 +0000
committerThierry Thomas <thierry@FreeBSD.org>2022-10-16 15:01:23 +0000
commitfc6eb8efd1bf9486cb610a73d43150bd6cd67b16 (patch)
treeaba004d890091e59a6e01072aba7d234cf0e6461
parent2994c79c32a7ddb44aa42b5b5856d412c29dcf85 (diff)
downloadports-fc6eb8efd1bf9486cb610a73d43150bd6cd67b16.tar.gz
ports-fc6eb8efd1bf9486cb610a73d43150bd6cd67b16.zip
science/v_sim: add missing dependencies + strip libs
Since I’m there, add missing dependencies and strip libraries.
-rw-r--r--science/v_sim/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/science/v_sim/Makefile b/science/v_sim/Makefile
index 95b81aae6546..ad3ac35dd8b8 100644
--- a/science/v_sim/Makefile
+++ b/science/v_sim/Makefile
@@ -1,6 +1,6 @@
PORTNAME= v_sim
DISTVERSION= 3.8.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= science
MAINTAINER= thierry@FreeBSD.org
@@ -36,7 +36,7 @@ USES= autoreconf blaslapack compiler:c11 fortran gl gmake gnome \
shebangfix tar:bzip2 xorg
SHEBANG_GLOB= *.py
USE_XORG= x11
-USE_GNOME= cairo gtk30 intltool introspection
+USE_GNOME= cairo gtk30 gdkpixbuf2 intltool introspection
USE_GL= gl glu
USE_GITLAB= yes
GL_ACCOUNT= l_sim
@@ -72,10 +72,8 @@ PLIST_SUB+= AB="@comment "
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
-PLIST_SUB+= NLS=""
.else
USES+= gettext-tools
-PLIST_SUB+= NLS="@comment "
.endif
pre-configure:
@@ -97,4 +95,8 @@ pre-configure-EXAMPLES-off:
${REINPLACE_CMD} -e 's|: install-v_simexamplesDATA|:|' \
${WRKSRC}/lib/python/Makefile.am
+post-install:
+ ${FIND} ${STAGEDIR}${PREFIX}/lib -type f -name "lib*.so.8.0.0" | \
+ ${XARGS} ${STRIP_CMD}
+
.include <bsd.port.mk>