aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2023-07-05 19:00:13 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2023-07-05 19:12:33 +0000
commitfc84bbd28e3e576b9573de6933a92e51e495d9ed (patch)
tree7c6d3fbc79344a8ae5abda4daa54910cc1cce60b
parentbf8c260a35d6f1b301356ae1b553df5e7be1ff0b (diff)
downloadports-fc84bbd28e3e576b9573de6933a92e51e495d9ed.tar.gz
ports-fc84bbd28e3e576b9573de6933a92e51e495d9ed.zip
net-p2p/amule: Unbreak clang16
The port does not work with C++17 which is the default since clang 16. This can be removed once that port starts working with C++17. Reported by: pkg-fallout MFH: 2023Q3 (cherry picked from commit 60fbad1670fec827eb6035816be246819bbbf08e)
-rw-r--r--net-p2p/amule/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/net-p2p/amule/Makefile b/net-p2p/amule/Makefile
index 6e5e6c511408..775074c776ba 100644
--- a/net-p2p/amule/Makefile
+++ b/net-p2p/amule/Makefile
@@ -16,6 +16,10 @@ LIB_DEPENDS= libcryptopp.so:security/cryptopp
USES= bison compiler:c++11-lang cpe desktop-file-utils gmake \
localbase:ldflags perl5 pkgconfig shebangfix tar:xz
+# amule 2.3.3 does not work with C++17 which is the default since
+# clang 16. This can be removed once that port starts working with C++17 and
+# has its own USE_CXXSTD removed.
+USE_CXXSTD= c++11
USE_PERL5= build
USE_WX= 3.0
WX_CONF_ARGS= absolute