aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-11-17 08:34:09 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-11-17 09:20:04 +0000
commitfca135644fd02bc1e2c81dc59f61c93148f64d5d (patch)
tree4627540eb5cd97c4fcc1acff34182b3edeb949db
parent3b99812420d00551a796ae92853ba35d42575c24 (diff)
downloadports-fca135644fd02bc1e2c81dc59f61c93148f64d5d.tar.gz
ports-fca135644fd02bc1e2c81dc59f61c93148f64d5d.zip
bsd.port.mk: clean up DEV_WARNINGS about migrations that are over
-rw-r--r--Mk/Uses/gl.mk3
-rw-r--r--Mk/Uses/motif.mk3
-rw-r--r--Mk/bsd.port.mk40
3 files changed, 0 insertions, 46 deletions
diff --git a/Mk/Uses/gl.mk b/Mk/Uses/gl.mk
index 8ecd95a4403a..6bfba723773e 100644
--- a/Mk/Uses/gl.mk
+++ b/Mk/Uses/gl.mk
@@ -46,10 +46,7 @@ LIB_DEPENDS+= ${_GL_${_component}_LIB_DEPENDS}
.endfor
# We only need to include xorg.mk if we want USE_XORG modules
-# USES+=xorg does not provide any functionality, it just silences an error
-# message about USES=xorg not being set
.if defined(USE_XORG) && !empty(USE_XORG)
-USES+= xorg
.include "${USESDIR}/xorg.mk"
.endif
diff --git a/Mk/Uses/motif.mk b/Mk/Uses/motif.mk
index 8828ceb4c4d1..3e0f4e9036f2 100644
--- a/Mk/Uses/motif.mk
+++ b/Mk/Uses/motif.mk
@@ -26,10 +26,7 @@ MOTIFLIB?= -L${LOCALBASE}/lib -lXm
MAKE_ENV+= MOTIFLIB="${MOTIFLIB}"
# We only need to include xorg.mk if we want USE_XORG modules
-# USES+=xorg does not provide any functionality, it just silences an error
-# message about USES=xorg not being set
.if defined(USE_XORG) && !empty(USE_XORG)
-USES+= xorg
.include "${USESDIR}/xorg.mk"
.endif
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 317b65f748e2..ad50a4af5334 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1377,16 +1377,6 @@ PKGCOMPATDIR?= ${LOCALBASE}/lib/compat/pkg
.sinclude "${odir}/Mk/bsd.overlay.mk"
.endfor
-.if defined(USE_XORG) && (!defined(USES) || !${USES:Mxorg})
-DEV_WARNING+= "Using USE_XORG alone is deprecated, please use USES=xorg"
-USES+= xorg
-.endif
-
-.if defined(USE_PHP) && (!defined(USES) || ( defined(USES) && !${USES:Mphp*} ))
-DEV_WARNING+= "Using USE_PHP alone is deprecated, please use USES=php"
-USES+= php
-.endif
-
.if defined(USE_JAVA)
.include "${PORTSDIR}/Mk/bsd.java.mk"
.endif
@@ -1416,26 +1406,6 @@ USES+= apache:${USE_APACHE:C/2([0-9])/2.\1/g}
.include "${PORTSDIR}/Mk/bsd.gecko.mk"
.endif
-.if (defined(USE_GNOME) || defined(INSTALLS_ICONS)) && empty(USES:Mgnome)
-DEV_WARNING+= "Using USE_GNOME alone is deprecated, please add USES=gnome."
-USES+= gnome
-.endif
-
-.if defined(USE_MATE) && empty(USES:Mmate)
-DEV_WARNING+= "Using USE_MATE alone is deprecated, please add USES=mate."
-USES+= mate
-.endif
-
-.if defined(USE_GL) && (!defined(USES) || !${USES:Mgl})
-DEV_WARNING+= "Using USE_GL alone is deprecated, please add USES=gl."
-USES+= gl
-.endif
-
-.if defined(USE_SDL) && (!defined(USES) || !${USES:Msdl})
-DEV_WARNING+= "Using USE_SDL alone is deprecated, please add USES=sdl."
-USES+= sdl
-.endif
-
.if defined(USE_MYSQL)
USE_MYSQL:= ${USE_MYSQL:N[yY][eE][sS]:Nclient}
.if defined(WANT_MYSQL_VER)
@@ -1970,11 +1940,6 @@ _FORCE_POST_PATTERNS= rmdir kldxref mkfontscale mkfontdir fc-cache \
.sinclude "${odir}/Mk/bsd.overlay.mk"
.endfor
-.if defined(USE_XORG) && (!defined(USES) || ( defined(USES) && !${USES:Mxorg} ))
-DEV_WARNING+= "Using USE_XORG alone is deprecated, please use USES=xorg"
-_USES_POST+= xorg
-.endif
-
.if defined(USE_GSTREAMER1)
.include "${PORTSDIR}/Mk/bsd.gstreamer.mk"
.endif
@@ -1987,11 +1952,6 @@ _USES_POST+= xorg
.include "${PORTSDIR}/Mk/bsd.ocaml.mk"
.endif
-.if defined(USE_PHP) && (!defined(USES) || ( defined(USES) && !${USES:Mphp*} ))
-DEV_WARNING+= "Using USE_PHP alone is deprecated, please use USES=php"
-_USES_POST+= php
-.endif
-
.if defined(USE_WX) || defined(USE_WX_NOT)
.include "${PORTSDIR}/Mk/bsd.wx.mk"
.endif