aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@FreeBSD.org>2022-08-03 20:51:17 +0000
committerDmitri Goutnik <dmgk@FreeBSD.org>2022-08-03 21:35:13 +0000
commitfcbe735f93fd788ec441228a34c5b7046c039fc9 (patch)
treee521f95d2d4018cabff7366cbdba3f6dbf8ba95a
parentb42522214dcc52b9a932af5661d38d426a5b8adb (diff)
downloadports-fcbe735f93fd788ec441228a34c5b7046c039fc9.tar.gz
ports-fcbe735f93fd788ec441228a34c5b7046c039fc9.zip
all: Keep ports that need go1.18 on 1.18
Some ports are not (yet) buildable with go1.19, keep them on 1.18 for now.
-rw-r--r--dns/doggo/Makefile2
-rw-r--r--net-im/dendrite/Makefile2
-rw-r--r--net/cloudflared/Makefile2
-rw-r--r--net/nncp/Makefile2
-rw-r--r--net/ooni-probe-cli/Makefile2
-rw-r--r--net/storj/Makefile2
-rw-r--r--net/syncthing/Makefile2
-rw-r--r--net/traefik/Makefile2
-rw-r--r--net/wireproxy/Makefile2
-rw-r--r--security/acmetool/Makefile2
-rw-r--r--security/xray-core/Makefile2
-rw-r--r--sysutils/ipfs-go/Makefile2
-rw-r--r--sysutils/ipget/Makefile2
-rw-r--r--www/adguardhome/Makefile2
14 files changed, 14 insertions, 14 deletions
diff --git a/dns/doggo/Makefile b/dns/doggo/Makefile
index 4a1afca2fcb5..6330ef483888 100644
--- a/dns/doggo/Makefile
+++ b/dns/doggo/Makefile
@@ -11,7 +11,7 @@ COMMENT= Modern command-line DNS client (like dig)
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= go:modules
+USES= go:1.18,modules
GO_MODULE= github.com/mr-karan/doggo
GO_TARGET= ./cmd/${PORTNAME}
diff --git a/net-im/dendrite/Makefile b/net-im/dendrite/Makefile
index 0b0c0c82e9e5..861bb798c036 100644
--- a/net-im/dendrite/Makefile
+++ b/net-im/dendrite/Makefile
@@ -9,7 +9,7 @@ COMMENT= Matrix protocol homeserver
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= go:modules
+USES= go:1.18,modules
PLIST_SUB= PORTNAME=${PORTNAME}
USE_RC_SUBR= ${PORTNAME}
USERS= ${PORTNAME}
diff --git a/net/cloudflared/Makefile b/net/cloudflared/Makefile
index 36934e351327..12f71a5ca008 100644
--- a/net/cloudflared/Makefile
+++ b/net/cloudflared/Makefile
@@ -10,7 +10,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ca_root_nss>=0:security/ca_root_nss
-USES= cpe go:modules
+USES= cpe go:1.18,modules
USE_RC_SUBR= ${PORTNAME}
USE_GITHUB= yes
GH_ACCOUNT= cloudflare
diff --git a/net/nncp/Makefile b/net/nncp/Makefile
index 1e22baf91b45..a8e92b826bae 100644
--- a/net/nncp/Makefile
+++ b/net/nncp/Makefile
@@ -10,7 +10,7 @@ COMMENT= Utilities for secure store-and-forward files, mail, command exchanging
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= go:modules,no_targets tar:xz
+USES= go:1.18,modules,no_targets tar:xz
USE_RC_SUBR= nncp-caller nncp-daemon nncp-toss
diff --git a/net/ooni-probe-cli/Makefile b/net/ooni-probe-cli/Makefile
index 573971a5b0dc..7adab6d6a2fb 100644
--- a/net/ooni-probe-cli/Makefile
+++ b/net/ooni-probe-cli/Makefile
@@ -11,7 +11,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ca_root_nss>=0:security/ca_root_nss
-USES= go:modules
+USES= go:1.18,modules
GO_MODULE= github.com/ooni/probe-cli/v3
GO_TARGET= ./cmd/ooniprobe
diff --git a/net/storj/Makefile b/net/storj/Makefile
index a60c063be791..5e6c629e3f56 100644
--- a/net/storj/Makefile
+++ b/net/storj/Makefile
@@ -8,7 +8,7 @@ COMMENT= Decentralized cloud object storage
LICENSE= AGPLv3
-USES= go:modules
+USES= go:1.18,modules
USE_GITHUB= yes
.include "${.CURDIR}/Makefile.deps"
diff --git a/net/syncthing/Makefile b/net/syncthing/Makefile
index 4e5a0d0e7e24..9ab85cf778d9 100644
--- a/net/syncthing/Makefile
+++ b/net/syncthing/Makefile
@@ -13,7 +13,7 @@ COMMENT= Encrypted file sync tool
LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/${PORTNAME}/LICENSE
-USES= cpe go:modules
+USES= cpe go:1.18,modules
USE_RC_SUBR= syncthing syncthing-discosrv syncthing-relaysrv syncthing-relaypoolsrv
diff --git a/net/traefik/Makefile b/net/traefik/Makefile
index 38dfd7bc631f..3bffa8483d17 100644
--- a/net/traefik/Makefile
+++ b/net/traefik/Makefile
@@ -11,7 +11,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
BUILD_DEPENDS= go-bindata:devel/go-bindata
-USES= cpe go:modules tar:xz
+USES= cpe go:1.18,modules tar:xz
USE_RC_SUBR= traefik
diff --git a/net/wireproxy/Makefile b/net/wireproxy/Makefile
index 4cddc913ec1d..2dfe0c7439c7 100644
--- a/net/wireproxy/Makefile
+++ b/net/wireproxy/Makefile
@@ -10,7 +10,7 @@ COMMENT= Wireguard client that exposes itself as a socks5 proxy
LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= go:modules
+USES= go:1.18,modules
GO_MODULE= github.com/octeep/wireproxy
GO_TARGET= ./cmd/wireproxy
diff --git a/security/acmetool/Makefile b/security/acmetool/Makefile
index 138f077d5abc..9c227e7a1356 100644
--- a/security/acmetool/Makefile
+++ b/security/acmetool/Makefile
@@ -9,7 +9,7 @@ COMMENT= CLI tool for automatically acquiring certificates from ACME servers
LICENSE= MIT
-USES= go
+USES= go:1.18
USE_GITHUB= yes
GH_ACCOUNT= hlandau
diff --git a/security/xray-core/Makefile b/security/xray-core/Makefile
index 4a560b20bbe3..a55c2c1a2faa 100644
--- a/security/xray-core/Makefile
+++ b/security/xray-core/Makefile
@@ -10,7 +10,7 @@ COMMENT= Set of network penetration tools
LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= go:modules
+USES= go:1.18,modules
GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
GO_TARGET= ./main:xray
diff --git a/sysutils/ipfs-go/Makefile b/sysutils/ipfs-go/Makefile
index 17798d287f9b..a76752ab25d1 100644
--- a/sysutils/ipfs-go/Makefile
+++ b/sysutils/ipfs-go/Makefile
@@ -15,7 +15,7 @@ LICENSE_COMB= dual
LICENSE_FILE_MIT= ${WRKSRC}/LICENSE-MIT
LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE-APACHE
-USES= cpe go:modules
+USES= cpe go:1.18,modules
CPE_VENDOR= protocol
diff --git a/sysutils/ipget/Makefile b/sysutils/ipget/Makefile
index 959f0140bb85..57259911b621 100644
--- a/sysutils/ipget/Makefile
+++ b/sysutils/ipget/Makefile
@@ -10,7 +10,7 @@ COMMENT= Retrieve files over IPFS and save them locally
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= go:modules
+USES= go:1.18,modules
GO_MODULE= github.com/ipfs/ipget
diff --git a/www/adguardhome/Makefile b/www/adguardhome/Makefile
index ca7dbd134b77..db3a367e1d52 100644
--- a/www/adguardhome/Makefile
+++ b/www/adguardhome/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ca_root_nss>=0:security/ca_root_nss
-USES= cpe go:modules
+USES= cpe go:1.18,modules
GO_MODULE= github.com/AdguardTeam/AdGuardHome
GO_BUILDFLAGS= -ldflags="-s -w -X github.com/AdguardTeam/AdGuardHome/internal/version.version=${DISTVERSION}" # workaround for https://github.com/AdguardTeam/AdGuardHome/issues/4774