aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-03-04 21:31:19 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-03-22 15:36:28 +0000
commitfcf0cc114ab8c9868bb926e79340a685c033a42a (patch)
treea80ec2b2d4506707f232c180a81a47e15f75e225
parent2cb8397dda337787d36a82b67411be197da0cac5 (diff)
downloadports-fcf0cc114ab8c9868bb926e79340a685c033a42a.tar.gz
ports-fcf0cc114ab8c9868bb926e79340a685c033a42a.zip
devel/glib20: update to 2.76.0
Changes: https://gitlab.gnome.org/GNOME/glib/-/releases/2.76.0 Reported by: GitLab (notify releases) PR: 270087 Exp-run by: antoine Approved by: tcberner
-rw-r--r--devel/glib20/Makefile6
-rw-r--r--devel/glib20/distinfo6
-rw-r--r--devel/glib20/files/patch-glib_gspawn.c25
-rw-r--r--devel/glib20/files/patch-glib_meson.build15
-rw-r--r--devel/glib20/pkg-plist12
5 files changed, 38 insertions, 26 deletions
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 92157b70acd7..d737e0e1b885 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -1,5 +1,5 @@
PORTNAME= glib
-DISTVERSION= 2.74.6
+DISTVERSION= 2.76.0
PORTEPOCH= 2
CATEGORIES= devel
MASTER_SITES= GNOME
@@ -29,7 +29,7 @@ MESON_ARGS= -Db_lundef=false \
-Ddefault_library=both \
-Dinstalled_tests=false \
-Dlibmount=disabled \
- -Dlocalstatedir=/var \
+ -Druntime_dir=/var/run \
-Dselinux=disabled \
-Dxattr=false
BINARY_ALIAS= python3=${PYTHON_CMD}
@@ -38,7 +38,7 @@ CPE_VENDOR= gnome
CONFLICTS_INSTALL= p5-Giovanni
-_LIBVERSION= 0.7400.6
+_LIBVERSION= 0.7600.0
PLIST_SUB= LIBVERSION=${_LIBVERSION}
OPTIONS_DEFINE= DEBUG GTKDOC FAM_ALTBACKEND MANPAGES NLS TEST
diff --git a/devel/glib20/distinfo b/devel/glib20/distinfo
index 232cdcdaa15c..e35900e602f7 100644
--- a/devel/glib20/distinfo
+++ b/devel/glib20/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1677930464
-SHA256 (gnome/glib-2.74.6.tar.xz) = 069cf7e51cd261eb163aaf06c8d1754c6835f31252180aff5814e5afc7757fbc
-SIZE (gnome/glib-2.74.6.tar.xz) = 5217312
+TIMESTAMP = 1678459405
+SHA256 (gnome/glib-2.76.0.tar.xz) = 525bb703b807142e1aee5ccf222c344e8064b21c0c45677ef594e587874c6797
+SIZE (gnome/glib-2.76.0.tar.xz) = 5268620
SHA256 (gnome/f6c40b1d27ed.patch) = 5ec18921942e1be13aad3de6c1ad829a46bf0cbbdbc1c3d1ef2247e4657ec473
SIZE (gnome/f6c40b1d27ed.patch) = 803
diff --git a/devel/glib20/files/patch-glib_gspawn.c b/devel/glib20/files/patch-glib_gspawn.c
index b34a4cd8da6a..939ef8168c1f 100644
--- a/devel/glib20/files/patch-glib_gspawn.c
+++ b/devel/glib20/files/patch-glib_gspawn.c
@@ -1,6 +1,6 @@
---- glib/gspawn.c.orig 2020-12-17 03:47:11.474608400 -0800
-+++ glib/gspawn.c 2021-02-17 13:58:15.271434000 -0800
-@@ -51,6 +51,12 @@
+--- glib/gspawn.c.orig 2023-03-10 14:33:15 UTC
++++ glib/gspawn.c
+@@ -54,6 +54,12 @@
#include <sys/syscall.h> /* for syscall and SYS_getdents64 */
#endif
@@ -13,9 +13,9 @@
#include "gspawn.h"
#include "gspawn-private.h"
#include "gthread.h"
-@@ -1204,6 +1210,33 @@ filename_to_fd (const char *p)
+@@ -1231,6 +1237,33 @@ g_spawn_check_exit_status (gint wait_status,
+ return g_spawn_check_wait_status (wait_status, error);
}
- #endif
+#ifdef __FreeBSD__
+static int
@@ -46,17 +46,18 @@
+
/* This function is called between fork() and exec() and hence must be
* async-signal-safe (see signal-safety(7)). */
- static int
-@@ -1228,6 +1261,12 @@ safe_fdwalk (int (*cb)(void *data, int fd), void *data
-
- #if 0 && defined(HAVE_SYS_RESOURCE_H)
- struct rlimit rl;
-+#endif
+ static gssize
+@@ -1432,6 +1465,13 @@ safe_fdwalk (int (*cb)(void *data, int fd), void *data
+ * may fail on non-Linux operating systems. See safe_fdwalk_with_invalid_fds
+ * for a slower alternative.
+ */
+
+#ifdef __FreeBSD__
++ gint res = 0;
+ if (fdwalk2(cb, data, &res) == 0)
+ return res;
+ /* If any sysctl/malloc call fails continue with the fall back method */
- #endif
++#endif
#ifdef __linux__
+ gint fd;
diff --git a/devel/glib20/files/patch-glib_meson.build b/devel/glib20/files/patch-glib_meson.build
index 40cc18b594b6..a2852a624916 100644
--- a/devel/glib20/files/patch-glib_meson.build
+++ b/devel/glib20/files/patch-glib_meson.build
@@ -1,11 +1,10 @@
---- glib/meson.build.orig 2022-09-17 18:38:17 UTC
+--- glib/meson.build.orig 2023-03-10 14:33:15 UTC
+++ glib/meson.build
-@@ -379,7 +379,7 @@ libglib = library('glib-2.0',
- link_args : [noseh_link_args, glib_link_flags, win32_ldflags],
- include_directories : configinc,
- link_with: [charset_lib, gnulib_lib],
-- dependencies : [pcre2, thread_dep, librt] + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep],
-+ dependencies : [pcre2, thread_dep, librt] + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep] + libutil,
+@@ -422,6 +422,7 @@ libglib = library('glib-2.0',
+ pcre2,
+ platform_deps,
+ thread_dep,
++ libutil,
+ ],
c_args : glib_c_args,
objc_args : glib_c_args,
- )
diff --git a/devel/glib20/pkg-plist b/devel/glib20/pkg-plist
index 4442dc452b5d..67da0c1fd546 100644
--- a/devel/glib20/pkg-plist
+++ b/devel/glib20/pkg-plist
@@ -90,6 +90,7 @@ include/glib-2.0/gio/ginetsocketaddress.h
include/glib-2.0/gio/ginitable.h
include/glib-2.0/gio/ginputstream.h
include/glib-2.0/gio/gio-autocleanups.h
+include/glib-2.0/gio/gio-visibility.h
include/glib-2.0/gio/gio.h
include/glib-2.0/gio/gioenums.h
include/glib-2.0/gio/gioenumtypes.h
@@ -215,6 +216,7 @@ include/glib-2.0/glib/giochannel.h
include/glib-2.0/glib/gkeyfile.h
include/glib-2.0/glib/glib-autocleanups.h
include/glib-2.0/glib/glib-typeof.h
+include/glib-2.0/glib/glib-visibility.h
include/glib-2.0/glib/glist.h
include/glib-2.0/glib/gmacros.h
include/glib-2.0/glib/gmain.h
@@ -224,6 +226,7 @@ include/glib-2.0/glib/gmem.h
include/glib-2.0/glib/gmessages.h
include/glib-2.0/glib/gnode.h
include/glib-2.0/glib/goption.h
+include/glib-2.0/glib/gpathbuf.h
include/glib-2.0/glib/gpattern.h
include/glib-2.0/glib/gpoll.h
include/glib-2.0/glib/gprimes.h
@@ -265,6 +268,7 @@ include/glib-2.0/glib/gversion.h
include/glib-2.0/glib/gversionmacros.h
include/glib-2.0/glib/gwin32.h
include/glib-2.0/gmodule.h
+include/glib-2.0/gmodule/gmodule-visibility.h
include/glib-2.0/gobject/gbinding.h
include/glib-2.0/gobject/gbindinggroup.h
include/glib-2.0/gobject/gboxed.h
@@ -274,6 +278,7 @@ include/glib-2.0/gobject/glib-enumtypes.h
include/glib-2.0/gobject/glib-types.h
include/glib-2.0/gobject/gmarshal.h
include/glib-2.0/gobject/gobject-autocleanups.h
+include/glib-2.0/gobject/gobject-visibility.h
include/glib-2.0/gobject/gobject.h
include/glib-2.0/gobject/gobjectnotifyqueue.c
include/glib-2.0/gobject/gparam.h
@@ -357,6 +362,9 @@ share/gettext/its/gschema.loc
%%DATADIR%%-2.0/codegen/codegen_main.py
%%DATADIR%%-2.0/codegen/codegen_main.pyc
%%DATADIR%%-2.0/codegen/codegen_main.pyo
+%%DATADIR%%-2.0/codegen/codegen_md.py
+%%DATADIR%%-2.0/codegen/codegen_md.pyc
+%%DATADIR%%-2.0/codegen/codegen_md.pyo
%%DATADIR%%-2.0/codegen/codegen_rst.py
%%DATADIR%%-2.0/codegen/codegen_rst.pyc
%%DATADIR%%-2.0/codegen/codegen_rst.pyo
@@ -552,6 +560,7 @@ share/gettext/its/gschema.loc
%%GTKDOC%%share/gtk-doc/html/gio/api-index-2-70.html
%%GTKDOC%%share/gtk-doc/html/gio/api-index-2-72.html
%%GTKDOC%%share/gtk-doc/html/gio/api-index-2-74.html
+%%GTKDOC%%share/gtk-doc/html/gio/api-index-2-76.html
%%GTKDOC%%share/gtk-doc/html/gio/api-index-deprecated.html
%%GTKDOC%%share/gtk-doc/html/gio/api-index-full.html
%%GTKDOC%%share/gtk-doc/html/gio/application.html
@@ -689,6 +698,7 @@ share/gettext/its/gschema.loc
%%GTKDOC%%share/gtk-doc/html/glib/api-index-2-70.html
%%GTKDOC%%share/gtk-doc/html/glib/api-index-2-72.html
%%GTKDOC%%share/gtk-doc/html/glib/api-index-2-74.html
+%%GTKDOC%%share/gtk-doc/html/glib/api-index-2-76.html
%%GTKDOC%%share/gtk-doc/html/glib/api-index-2-8.html
%%GTKDOC%%share/gtk-doc/html/glib/api-index-deprecated.html
%%GTKDOC%%share/gtk-doc/html/glib/api-index-full.html
@@ -721,6 +731,7 @@ share/gettext/its/gschema.loc
%%GTKDOC%%share/gtk-doc/html/glib/glib-Error-Reporting.html
%%GTKDOC%%share/gtk-doc/html/glib/glib-File-Utilities.html
%%GTKDOC%%share/gtk-doc/html/glib/glib-GDateTime.html
+%%GTKDOC%%share/gtk-doc/html/glib/glib-GPathBuf.html
%%GTKDOC%%share/gtk-doc/html/glib/glib-GTimeZone.html
%%GTKDOC%%share/gtk-doc/html/glib/glib-GUuid.html
%%GTKDOC%%share/gtk-doc/html/glib/glib-GVariant.html
@@ -835,6 +846,7 @@ share/gettext/its/gschema.loc
%%GTKDOC%%share/gtk-doc/html/gobject/api-index-2-70.html
%%GTKDOC%%share/gtk-doc/html/gobject/api-index-2-72.html
%%GTKDOC%%share/gtk-doc/html/gobject/api-index-2-74.html
+%%GTKDOC%%share/gtk-doc/html/gobject/api-index-2-76.html
%%GTKDOC%%share/gtk-doc/html/gobject/api-index-2-8.html
%%GTKDOC%%share/gtk-doc/html/gobject/api-index-deprecated.html
%%GTKDOC%%share/gtk-doc/html/gobject/api-index-full.html