aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-04-13 00:27:03 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-04-13 00:29:17 +0000
commitfd20bf82b699c91e1ddc0b92ddc98b038483c706 (patch)
treee2358b41ba98a8be76f8d364fac114fe8ec8c2af
parentfdbd0bce7c7691e74abc96410a73283ed6804b70 (diff)
downloadports-fd20bf82b699c91e1ddc0b92ddc98b038483c706.tar.gz
ports-fd20bf82b699c91e1ddc0b92ddc98b038483c706.zip
biology/mothur: Update to 1.45.2
Numerous bug fixes and enhancements since 1.43.0 Approved by: yuri
-rw-r--r--biology/mothur/Makefile5
-rw-r--r--biology/mothur/distinfo6
-rw-r--r--biology/mothur/files/patch-Makefile23
-rw-r--r--biology/mothur/files/patch-source_endiannessmacros.h19
4 files changed, 25 insertions, 28 deletions
diff --git a/biology/mothur/Makefile b/biology/mothur/Makefile
index cd379b8b9e23..052c7316a429 100644
--- a/biology/mothur/Makefile
+++ b/biology/mothur/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mothur
DISTVERSIONPREFIX= v
-DISTVERSION= 1.43.0
+DISTVERSION= 1.45.2
CATEGORIES= biology
MAINTAINER= yuri@FreeBSD.org
@@ -11,8 +11,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
BUILD_DEPENDS= bash:shells/bash
-USES= compiler:c++11-lang gmake localbase readline shebangfix
-SHEBANG_FILES= source/uchime_src/mk
+USES= compiler:c++11-lang gmake localbase readline
USE_GITHUB= yes
ALL_TARGET= ${PORTNAME}
diff --git a/biology/mothur/distinfo b/biology/mothur/distinfo
index a1cbdc3202d9..aa53703b0440 100644
--- a/biology/mothur/distinfo
+++ b/biology/mothur/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1570294640
-SHA256 (mothur-mothur-v1.43.0_GH0.tar.gz) = 12ccd95a85bec3bb1564b8feabd244ea85413973740754803d01fc71ecb0a2c1
-SIZE (mothur-mothur-v1.43.0_GH0.tar.gz) = 1665073
+TIMESTAMP = 1618235513
+SHA256 (mothur-mothur-v1.45.2_GH0.tar.gz) = 73fddddfeea140537b8b037da971964091b2149177e376d98d19ba8a2183e471
+SIZE (mothur-mothur-v1.45.2_GH0.tar.gz) = 1614451
diff --git a/biology/mothur/files/patch-Makefile b/biology/mothur/files/patch-Makefile
index 9d0709f1ea26..106b43e4e311 100644
--- a/biology/mothur/files/patch-Makefile
+++ b/biology/mothur/files/patch-Makefile
@@ -1,6 +1,16 @@
---- Makefile.orig 2019-09-30 19:02:13 UTC
+--- Makefile.orig 2021-04-09 18:28:13 UTC
+++ Makefile
-@@ -100,7 +100,7 @@ endif
+@@ -53,6 +53,9 @@ endif
+ CXXFLAGS += -std=c++11 -pthread -DVERSION=${VERSION} -DRELEASE_DATE=${RELEASE_DATE}
+ LDFLAGS += -std=c++11 -pthread
+
++# uchime requires gmake
++MAKE ?= gmake
++
+ ifeq ($(strip $(MOTHUR_FILES)),"\"Enter_your_default_path_here\"")
+ else
+ CXXFLAGS += -DMOTHUR_FILES=${MOTHUR_FILES}
+@@ -109,7 +112,7 @@ endif
subdirs := $(sort $(dir $(filter-out $(skipUchime), $(wildcard source/*/))))
subDirIncludes = $(patsubst %, -I %, $(subdirs))
subDirLinking = $(patsubst %, -L%, $(subdirs))
@@ -9,7 +19,7 @@
LDFLAGS += $(subDirLinking)
-@@ -109,8 +109,8 @@ endif
+@@ -118,14 +121,14 @@ endif
#
OBJECTS=$(patsubst %.cpp,%.o,$(wildcard $(addsuffix *.cpp,$(subdirs))))
OBJECTS+=$(patsubst %.c,%.o,$(wildcard $(addsuffix *.c,$(subdirs))))
@@ -20,3 +30,10 @@
mothur : $(OBJECTS) uchime
$(CXX) $(LDFLAGS) $(TARGET_ARCH) -o $@ $(OBJECTS) $(LIBS)
+
+ uchime :
+- cd source/uchime_src && export CXX=$(CXX) && make clean && make && mv uchime ../../ && cd ..
++ cd source/uchime_src && export CXX=$(CXX) && ${MAKE} clean && ${MAKE} && mv uchime ../../ && cd ..
+
+ install : mothur
+
diff --git a/biology/mothur/files/patch-source_endiannessmacros.h b/biology/mothur/files/patch-source_endiannessmacros.h
deleted file mode 100644
index 923cfbd9e621..000000000000
--- a/biology/mothur/files/patch-source_endiannessmacros.h
+++ /dev/null
@@ -1,19 +0,0 @@
---- source/endiannessmacros.h.orig 2020-10-19 10:22:23 UTC
-+++ source/endiannessmacros.h
-@@ -53,16 +53,6 @@
- # define SP_BIG_ENDIAN
- #endif
-
--/*
-- * PowerPC
-- */
--#if defined(__ppc__) || defined(__ppc)
--# if defined(SP_LITTLE_ENDIAN)
--# undef SP_LITTLE_ENDIAN
--# endif
--# define SP_BIG_ENDIAN
--#endif
--
- /* Some catch-alls */
- #if defined(__LITTLE_ENDIAN__) || defined(__LITTLEENDIAN__)
- # define SP_LITTLE_ENDIAN