aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-09-12 16:32:54 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-09-12 16:38:03 +0000
commitfde73a13c618cce1b2ee3324c25f2c424c3ab94d (patch)
treea4cb034a20a764c11f2c5cc53efbbf9dfd6db059
parent981d307926eb4017516cf343b441c0d969e08cac (diff)
downloadports-fde73a13c618cce1b2ee3324c25f2c424c3ab94d.tar.gz
ports-fde73a13c618cce1b2ee3324c25f2c424c3ab94d.zip
graphics/filament: Fix build when ccache is present
Fix shabangs in ccache scripts that fialement uses. This caused failures. Also: this project looks up the ccache program and uses ccach. when it is present. This logic is now adjusted and it only uses ccache when it is enabled through the ports framework. PR: 266297 Reported by: amdmi3@
-rw-r--r--graphics/filament/Makefile5
-rw-r--r--graphics/filament/files/patch-CMakeLists.txt11
2 files changed, 14 insertions, 2 deletions
diff --git a/graphics/filament/Makefile b/graphics/filament/Makefile
index 4fc6f4584900..242fd880ad33 100644
--- a/graphics/filament/Makefile
+++ b/graphics/filament/Makefile
@@ -15,16 +15,19 @@ BROKEN_i386= compilation breaks: register r11 is only available in 64-bit mode
BUILD_DEPENDS= bash:shells/bash \
evdev-proto>0:devel/evdev-proto
-USES= cmake compiler:c++17-lang localbase:ldflags sdl xorg
+USES= cmake compiler:c++17-lang localbase:ldflags sdl shebangfix xorg
USE_SDL= sdl2
USE_XORG= x11
USE_GITHUB= yes
GH_ACCOUNT= google
+SHEBANG_FILES= build/launch-c.in build/launch-cxx.in
+
#CMAKE_ON= BUILD_SHARED_LIBS # not yet supported, see https://github.com/google/filament/issues/1075
CMAKE_OFF= USE_STATIC_LIBCXX FILAMENT_ENABLE_JAVA
CMAKE_ARGS+= -DDIST_DIR="." # prevent subdirectory for libraries
+CMAKE_ARGS+= -DUSE_CCACHE:BOOL=${CCACHE_ENABLED:tu}
LDFLAGS+= -lexecinfo -lSDL2
diff --git a/graphics/filament/files/patch-CMakeLists.txt b/graphics/filament/files/patch-CMakeLists.txt
index fac357ef46bd..c6ad0a518526 100644
--- a/graphics/filament/files/patch-CMakeLists.txt
+++ b/graphics/filament/files/patch-CMakeLists.txt
@@ -1,5 +1,14 @@
---- CMakeLists.txt.orig 2022-08-18 20:34:20 UTC
+--- CMakeLists.txt.orig 2022-08-31 16:04:08 UTC
+++ CMakeLists.txt
+@@ -66,7 +66,7 @@ endif()
+ # Support for ccache
+ # ==================================================================================================
+ find_program(CCACHE_PROGRAM ccache)
+-if (CCACHE_PROGRAM)
++if (USE_CCACHE AND CCACHE_PROGRAM)
+ set(C_LAUNCHER "${CCACHE_PROGRAM}")
+ set(CXX_LAUNCHER "${CCACHE_PROGRAM}")
+
@@ -99,6 +99,7 @@ set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
# ==================================================================================================
if (UNIX AND NOT APPLE AND NOT ANDROID AND NOT WEBGL)