aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-05 17:16:21 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-05 17:30:23 +0000
commitfe0f823dff5b3b3f5efad2595ad51dcf3262f9dc (patch)
tree21d718003f91e507d96f2774d2cdf291a17152c3
parentf29e8bccf1415ae688d1e1d145de3ab2d5842b59 (diff)
downloadports-fe0f823dff5b3b3f5efad2595ad51dcf3262f9dc.tar.gz
ports-fe0f823dff5b3b3f5efad2595ad51dcf3262f9dc.zip
devel/py-jupyterlab-server: Update to 2.20.0
- Update WWW and clean up pkg-descr Changes: https://github.com/jupyterlab/jupyterlab_server/releases
-rw-r--r--devel/py-jupyterlab-server/Makefile20
-rw-r--r--devel/py-jupyterlab-server/distinfo6
-rw-r--r--devel/py-jupyterlab-server/pkg-descr2
3 files changed, 13 insertions, 15 deletions
diff --git a/devel/py-jupyterlab-server/Makefile b/devel/py-jupyterlab-server/Makefile
index e9f98713f1d9..36436c35af7e 100644
--- a/devel/py-jupyterlab-server/Makefile
+++ b/devel/py-jupyterlab-server/Makefile
@@ -1,6 +1,5 @@
PORTNAME= jupyterlab-server
-PORTVERSION= 2.16.3
-PORTREVISION= 2
+PORTVERSION= 2.20.0
CATEGORIES= devel python
MASTER_SITES= PYPI \
https://github.com/jupyterlab/jupyterlab_server/releases/download/v${PORTVERSION}/
@@ -9,19 +8,20 @@ DISTNAME= jupyterlab_server-${PORTVERSION}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= JupyterLab Server
-WWW= https://jupyter.org/
+WWW= https://jupyter.org/ \
+ https://github.com/jupyterlab/jupyterlab_server
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=1.5:devel/py-hatchling@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=0:devel/py-babel@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=2.10:devel/py-babel@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Jinja2>=3.0.3:devel/py-Jinja2@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}json5>=0:devel/py-json5@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}jsonschema>=3.0.1:devel/py-jsonschema@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}jupyter-server>=1.8<2:devel/py-jupyter-server@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}json5>=0.9.0:devel/py-json5@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jsonschema>=4.17.3:devel/py-jsonschema@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jupyter-server>=1.21<3:devel/py-jupyter-server@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=21.3:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.28:www/py-requests@${PY_FLAVOR}
USES= python:3.7+
USE_PYTHON= autoplist concurrent pep517
@@ -31,7 +31,7 @@ NO_ARCH= yes
OPTIONS_DEFINE= OPENAPI
OPENAPI_DESC= OpenAPI support
-OPENAPI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openapi-core>=0.14.2:devel/py-openapi-core@${PY_FLAVOR} \
+OPENAPI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openapi-core>=0.16.1<0.17:devel/py-openapi-core@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ruamel.yaml>=0:devel/py-ruamel.yaml@${PY_FLAVOR}
.include <bsd.port.pre.mk>
diff --git a/devel/py-jupyterlab-server/distinfo b/devel/py-jupyterlab-server/distinfo
index 8497de564d74..e13ab53c7252 100644
--- a/devel/py-jupyterlab-server/distinfo
+++ b/devel/py-jupyterlab-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1669057765
-SHA256 (jupyterlab_server-2.16.3.tar.gz) = 635a0b176a901f19351c02221a124e59317c476f511200409b7d867e8b2905c3
-SIZE (jupyterlab_server-2.16.3.tar.gz) = 66680
+TIMESTAMP = 1679498696
+SHA256 (jupyterlab_server-2.20.0.tar.gz) = 75e81a8ef23f561b70f5c9a76de2ab9ebb291358b371d6260f51af7e347da719
+SIZE (jupyterlab_server-2.20.0.tar.gz) = 70481
diff --git a/devel/py-jupyterlab-server/pkg-descr b/devel/py-jupyterlab-server/pkg-descr
index f7affe9514f9..df5b826966b7 100644
--- a/devel/py-jupyterlab-server/pkg-descr
+++ b/devel/py-jupyterlab-server/pkg-descr
@@ -2,5 +2,3 @@ The application author creates a JupyterLab build on their machine using the
core JupyterLab application. They can then serve their files by subclassing the
LabServerApp with the appropriate configuration and creating a Python entry
point that launches the app.
-
-See also: https://github.com/jupyterlab/jupyterlab_server