aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2023-03-21 17:06:36 +0000
committerBrooks Davis <brooks@FreeBSD.org>2023-03-21 17:49:18 +0000
commitfe5b536020489ef3c0c437a09f31dd32751fbf0a (patch)
tree44622116d94b6756d2134f0c89ffcd6f574526d8
parentff55c506e67baff442f49ba9152eb9c1fc77dce5 (diff)
downloadports-fe5b536020489ef3c0c437a09f31dd32751fbf0a.tar.gz
ports-fe5b536020489ef3c0c437a09f31dd32751fbf0a.zip
devel/llvm16: Welcome 16.0.0 release
See the release announcement for links to various release notes: https://discourse.llvm.org/t/llvm-16-0-0-release/ Sponsored by: DARPA
-rw-r--r--devel/llvm16/Makefile2
-rw-r--r--devel/llvm16/distinfo6
-rw-r--r--devel/llvm16/files/patch-compiler-rt_lib_builtins_CMakeLists.txt50
3 files changed, 4 insertions, 54 deletions
diff --git a/devel/llvm16/Makefile b/devel/llvm16/Makefile
index b507ccace909..ee4d0e27d0dc 100644
--- a/devel/llvm16/Makefile
+++ b/devel/llvm16/Makefile
@@ -1,5 +1,5 @@
PORTNAME= llvm
-DISTVERSION= 16.0.0rc3
+DISTVERSION= 16.0.0
PORTREVISION= 1
CATEGORIES= devel lang
MASTER_SITES= https://github.com/llvm/llvm-project/releases/download/llvmorg-${DISTVERSION:S/rc/-rc/}/ \
diff --git a/devel/llvm16/distinfo b/devel/llvm16/distinfo
index dad7c5bd7c45..9508a78fe09c 100644
--- a/devel/llvm16/distinfo
+++ b/devel/llvm16/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1677085118
-SHA256 (llvm-project-16.0.0rc3.src.tar.xz) = 8fa9792a1a04f78d023b87c5e5bd25010d5f73a5c0ae1830e897d85821ee9325
-SIZE (llvm-project-16.0.0rc3.src.tar.xz) = 117914548
+TIMESTAMP = 1679336124
+SHA256 (llvm-project-16.0.0.src.tar.xz) = 9a56d906a2c81f16f06efc493a646d497c53c2f4f28f0cb1f3c8da7f74350254
+SIZE (llvm-project-16.0.0.src.tar.xz) = 117933476
diff --git a/devel/llvm16/files/patch-compiler-rt_lib_builtins_CMakeLists.txt b/devel/llvm16/files/patch-compiler-rt_lib_builtins_CMakeLists.txt
deleted file mode 100644
index e26ae7cf0634..000000000000
--- a/devel/llvm16/files/patch-compiler-rt_lib_builtins_CMakeLists.txt
+++ /dev/null
@@ -1,50 +0,0 @@
---- compiler-rt/lib/builtins/CMakeLists.txt.orig 2022-11-29 10:05:58 UTC
-+++ compiler-rt/lib/builtins/CMakeLists.txt
-@@ -183,11 +183,14 @@ if(COMPILER_RT_HAS_BFLOAT16 AND NOT APPLE)
-
- # Build BF16 files only when "__bf16" is available.
- if(COMPILER_RT_HAS_BFLOAT16 AND NOT APPLE)
-- set(GENERIC_SOURCES
-- ${GENERIC_SOURCES}
-+ set(GENERIC_BF_SOURCES
- truncdfbf2.c
- truncsfbf2.c
- )
-+ set(GENERIC_SOURCES
-+ ${GENERIC_SOURCES}
-+ ${GENERIC_BF_SOURCES}
-+ )
- endif()
-
- # TODO: Several "tf" files (and divtc3.c, but not multc3.c) are in
-@@ -360,6 +363,10 @@ if (NOT MSVC)
- i386/chkstk2.S
- )
- endif()
-+
-+ if(${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
-+ list(REMOVE_ITEM i386_SOURCES ${GENERIC_BF_SOURCES})
-+ endif()
- else () # MSVC
- # Use C versions of functions when building on MSVC
- # MSVC's assembler takes Intel syntax, not AT&T syntax.
-@@ -703,8 +710,6 @@ else ()
- append_list_if(COMPILER_RT_ENABLE_CET -fcf-protection=full BUILTIN_CFLAGS)
- endif()
-
-- append_list_if(COMPILER_RT_HAS_FLOAT16 -DCOMPILER_RT_HAS_FLOAT16 BUILTIN_CFLAGS)
--
- append_list_if(COMPILER_RT_HAS_STD_C11_FLAG -std=c11 BUILTIN_CFLAGS)
-
- # These flags would normally be added to CMAKE_C_FLAGS by the llvm
-@@ -775,6 +780,10 @@ else ()
- )
-
- set(deps_aarch64 lse_builtin_symlinks)
-+ endif()
-+
-+ if(NOT (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD" AND ${arch} STREQUAL "i386"))
-+ append_list_if(COMPILER_RT_HAS_FLOAT16 -DCOMPILER_RT_HAS_FLOAT16 BUILTIN_CFLAGS)
- endif()
-
- add_compiler_rt_runtime(clang_rt.builtins