aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 14:31:40 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:07:06 +0000
commitff0c646cf747737248b076d0e1dee4aa8e8a9a90 (patch)
treef62216485d07529f6ae6843243aff3755b596f99
parent3c72ab22acebe1423059335cae999f3c70ebf3e7 (diff)
downloadports-ff0c646cf747737248b076d0e1dee4aa8e8a9a90.tar.gz
ports-ff0c646cf747737248b076d0e1dee4aa8e8a9a90.zip
databases/py-fakeredis: Update to 2.21.1
- Add PROBABILISTIC option Changes: https://github.com/cunla/fakeredis-py/releases
-rw-r--r--databases/py-fakeredis/Makefile8
-rw-r--r--databases/py-fakeredis/distinfo6
-rw-r--r--databases/py-fakeredis/files/patch-pyproject.toml13
3 files changed, 11 insertions, 16 deletions
diff --git a/databases/py-fakeredis/Makefile b/databases/py-fakeredis/Makefile
index 6dd75667a0fc..599e93037b06 100644
--- a/databases/py-fakeredis/Makefile
+++ b/databases/py-fakeredis/Makefile
@@ -1,5 +1,5 @@
PORTNAME= fakeredis
-PORTVERSION= 2.20.1
+PORTVERSION= 2.21.1
CATEGORIES= databases python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -27,10 +27,12 @@ USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes
-OPTIONS_DEFINE= JSON LUA
-LUA_DESC= Lua support
+OPTIONS_DEFINE= JSON LUA PROBABILISTIC
+LUA_DESC= Lua support
+PROBABILISTIC_DESC= Probabilistic data structure support
JSON_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonpath-ng>=1.5<2:devel/py-jsonpath-ng@${PY_FLAVOR}
LUA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lupa>=1.14<3.0:lang/py-lupa@${PY_FLAVOR}
+PROBABILISTIC_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyprobables>=0.6<1:math/py-pyprobables@${PY_FLAVOR}
.include <bsd.port.mk>
diff --git a/databases/py-fakeredis/distinfo b/databases/py-fakeredis/distinfo
index 5ff2f13acf9f..d872a8313a6a 100644
--- a/databases/py-fakeredis/distinfo
+++ b/databases/py-fakeredis/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1702543634
-SHA256 (fakeredis-2.20.1.tar.gz) = a2a5ccfcd72dc90435c18cde284f8cdd0cb032eb67d59f3fed907cde1cbffbbd
-SIZE (fakeredis-2.20.1.tar.gz) = 122874
+TIMESTAMP = 1708449092
+SHA256 (fakeredis-2.21.1.tar.gz) = 773bd03c38fe745c0c03c5b4ebb92521a25d3306f903c0ca65706bf65cf19e2a
+SIZE (fakeredis-2.21.1.tar.gz) = 128540
diff --git a/databases/py-fakeredis/files/patch-pyproject.toml b/databases/py-fakeredis/files/patch-pyproject.toml
index ea9c0c5061b3..7feaf196da04 100644
--- a/databases/py-fakeredis/files/patch-pyproject.toml
+++ b/databases/py-fakeredis/files/patch-pyproject.toml
@@ -1,18 +1,11 @@
---- pyproject.toml.orig 2023-09-25 21:51:17 UTC
+--- pyproject.toml.orig 2024-02-15 14:54:18 UTC
+++ pyproject.toml
-@@ -46,7 +46,7 @@ python = "^3.7"
+@@ -46,7 +46,7 @@ lupa = { version = ">=1.14,<3.0", optional = true }
redis = ">=4"
sortedcontainers = "^2"
lupa = { version = ">=1.14,<3.0", optional = true }
-jsonpath-ng = { version = "^1.6", optional = true }
+jsonpath-ng = { version = "^1.5", optional = true }
- pybloom-live = { version = "^4.0", optional = true }
+ pyprobables = { version = "^0.6", optional = true }
[tool.poetry.extras]
-@@ -104,4 +104,4 @@ exclude = [
- '.venv',
- '.github',
- '__pycache__',
--]
-\ No newline at end of file
-+]