aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2023-03-20 09:20:01 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2023-03-20 09:23:02 +0000
commitffbbc33b066edf2eb2ec49177c7aa87481a80c18 (patch)
tree85ae08283d0d3a2bd4040e6d8cc0b376dd5da9e9
parent0237865bf85563ab8fb315d21b602dd31cccad52 (diff)
downloadports-ffbbc33b066edf2eb2ec49177c7aa87481a80c18.tar.gz
ports-ffbbc33b066edf2eb2ec49177c7aa87481a80c18.zip
security/pam_ssh_agent_auth: update to latest commit 099beb2
Upstream has incorporated a patch we had locally, and fixed a misleading comment in their documentation. While here, update WWW
-rw-r--r--security/pam_ssh_agent_auth/Makefile6
-rw-r--r--security/pam_ssh_agent_auth/distinfo6
-rw-r--r--security/pam_ssh_agent_auth/files/patch-ssh-ecdsa.c42
3 files changed, 6 insertions, 48 deletions
diff --git a/security/pam_ssh_agent_auth/Makefile b/security/pam_ssh_agent_auth/Makefile
index f75f3cc83684..c177972eb465 100644
--- a/security/pam_ssh_agent_auth/Makefile
+++ b/security/pam_ssh_agent_auth/Makefile
@@ -1,15 +1,15 @@
PORTNAME= pam_ssh_agent_auth
PORTVERSION= 0.10.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MAINTAINER= matthew@FreeBSD.org
COMMENT= PAM module which permits authentication via ssh-agent
-WWW= http://pamsshagentauth.sourceforge.net/
+WWW= https://github.com/jbeverly/pam_ssh_agent_auth
USE_GITHUB= yes
GH_ACCOUNT= jbeverly
-GH_TAGNAME= 7ff7858
+GH_TAGNAME= 099beb2
GH_TUPLE= floodyberry:ed25519-donna:8757bd4:floodyberry_ed25519_donna/ed25519-donna
BROKEN_mips64= fails to compile: ed25519-donna-portable.h:85:4: Need a uint128_t implementation!
diff --git a/security/pam_ssh_agent_auth/distinfo b/security/pam_ssh_agent_auth/distinfo
index 57aefdab777e..6bff9f977611 100644
--- a/security/pam_ssh_agent_auth/distinfo
+++ b/security/pam_ssh_agent_auth/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1593675977
-SHA256 (jbeverly-pam_ssh_agent_auth-0.10.4-7ff7858_GH0.tar.gz) = 57b9d93c5ddfa157fe795a48dc8f913a8fb35d22085997d5062595020d5811c2
-SIZE (jbeverly-pam_ssh_agent_auth-0.10.4-7ff7858_GH0.tar.gz) = 307123
+TIMESTAMP = 1679303675
+SHA256 (jbeverly-pam_ssh_agent_auth-0.10.4-099beb2_GH0.tar.gz) = 3a95a2c23d23e6130b5200b2c26e9fbf9466d8d80954b154dd5e1680319b8d8c
+SIZE (jbeverly-pam_ssh_agent_auth-0.10.4-099beb2_GH0.tar.gz) = 307178
SHA256 (floodyberry-ed25519-donna-8757bd4_GH0.tar.gz) = bc0d6c06ee9b23b03a47f11c75fbe88abcaac08834ced07e297d0674f0710bff
SIZE (floodyberry-ed25519-donna-8757bd4_GH0.tar.gz) = 1169879
diff --git a/security/pam_ssh_agent_auth/files/patch-ssh-ecdsa.c b/security/pam_ssh_agent_auth/files/patch-ssh-ecdsa.c
deleted file mode 100644
index b684b134d92d..000000000000
--- a/security/pam_ssh_agent_auth/files/patch-ssh-ecdsa.c
+++ /dev/null
@@ -1,42 +0,0 @@
---- ssh-ecdsa.c.orig 2019-07-08 16:36:13 UTC
-+++ ssh-ecdsa.c
-@@ -46,7 +46,7 @@ ssh_ecdsa_sign(const Key *key, u_char **sigp, u_int *l
- u_int len, dlen;
- Buffer b, bb;
- #if OPENSSL_VERSION_NUMBER >= 0x10100005L
-- BIGNUM *r, *s;
-+ BIGNUM *r = NULL, *s = NULL;
- #endif
-
- if (key == NULL || key->type != KEY_ECDSA || key->ecdsa == NULL) {
-@@ -137,20 +137,27 @@ ssh_ecdsa_verify(const Key *key, const u_char *signatu
-
- /* parse signature */
- if ((sig = ECDSA_SIG_new()) == NULL)
-- pamsshagentauth_fatal("ssh_ecdsa_verify: DSA_SIG_new failed");
-+ pamsshagentauth_fatal("ssh_ecdsa_verify: ECDSA_SIG_new failed");
-
- pamsshagentauth_buffer_init(&b);
- pamsshagentauth_buffer_append(&b, sigblob, len);
- #if OPENSSL_VERSION_NUMBER < 0x10100005L
- if ((pamsshagentauth_buffer_get_bignum2_ret(&b, sig->r) == -1) ||
- (pamsshagentauth_buffer_get_bignum2_ret(&b, sig->s) == -1))
-+ pamsshagentauth_fatal("ssh_ecdsa_verify:"
-+ "pamsshagentauth_buffer_get_bignum2_ret failed");
- #else
-- DSA_SIG_get0(sig, &r, &s);
-+ if ((r = BN_new()) == NULL)
-+ pamsshagentauth_fatal("ssh_ecdsa_verify: BN_new failed");
-+ if ((s = BN_new()) == NULL)
-+ pamsshagentauth_fatal("ssh_ecdsa_verify: BN_new failed");
- if ((pamsshagentauth_buffer_get_bignum2_ret(&b, r) == -1) ||
- (pamsshagentauth_buffer_get_bignum2_ret(&b, s) == -1))
--#endif
- pamsshagentauth_fatal("ssh_ecdsa_verify:"
- "pamsshagentauth_buffer_get_bignum2_ret failed");
-+ if (ECDSA_SIG_set0(sig, r, s) != 1)
-+ pamsshagentauth_fatal("ssh_ecdsa_verify: ECDSA_SIG_set0 failed");
-+#endif
-
- /* clean up */
- memset(sigblob, 0, len);