aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2021-07-17 13:02:41 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2021-07-17 20:31:40 +0000
commitffdb67aee0747f0465be6a2f0f897ddfac8ecaee (patch)
tree3bbfb484995478d8996699d448c73a722b53ae23
parent8739e447a3e238dbf8fec694ec3dc29e150b1431 (diff)
downloadports-ffdb67aee0747f0465be6a2f0f897ddfac8ecaee.tar.gz
ports-ffdb67aee0747f0465be6a2f0f897ddfac8ecaee.zip
textproc/docproj: Remove legacy dependencies
Clean the current port for people just building the new documentation with Hugo/Asciidoctor. Keep the old dependencies list on a new port textproc/docproj-legacy. Reviewed by: hrs Approved by: doceng (with hat) Differential Revision: https://reviews.freebsd.org/D31019
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/docproj-legacy/Makefile73
-rw-r--r--textproc/docproj-legacy/pkg-descr9
-rw-r--r--textproc/docproj/Makefile63
4 files changed, 88 insertions, 58 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index cf10baa69d6e..f5bd81e1096a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -151,6 +151,7 @@
SUBDIR += docbook2odf
SUBDIR += docbookrx
SUBDIR += docproj
+ SUBDIR += docproj-legacy
SUBDIR += dom4j
SUBDIR += domc
SUBDIR += dsssl-docbook-modular
diff --git a/textproc/docproj-legacy/Makefile b/textproc/docproj-legacy/Makefile
new file mode 100644
index 000000000000..3d16945b7ad5
--- /dev/null
+++ b/textproc/docproj-legacy/Makefile
@@ -0,0 +1,73 @@
+# Created by: Nik Clayton <nik@FreeBSD.org>
+
+PORTNAME= docproj
+PORTVERSION= 3.1
+CATEGORIES= textproc
+PKGNAMESUFFIX= -legacy
+
+MAINTAINER= doceng@FreeBSD.org
+COMMENT= Meta-port for the FreeBSD Legacy Documentation Project
+
+RUN_DEPENDS= ${LOCALBASE}/share/xml/dtd/xhtml/xhtml.soc:textproc/xhtml \
+ ${LOCALBASE}/share/xml/xmlcharent/catalog:textproc/xmlcharent \
+ ${LOCALBASE}/share/xsl/iso-schematron/xslt1/iso_schematron_skeleton_for_xslt1.xsl:textproc/iso-schematron-xslt \
+ docbook-xsl-ns>=1.78.1_4:textproc/docbook-xsl-ns \
+ docbook>0:textproc/docbook \
+ links:www/links1 \
+ p5-XML-Parser>=2.41:textproc/p5-XML-Parser \
+ peps:graphics/peps \
+ pngtopnm:graphics/netpbm \
+ scr2png:graphics/scr2png \
+ scr2txt:textproc/scr2txt \
+ xsltproc:textproc/libxslt \
+ zip:archivers/zip
+
+USES= ghostscript:run metaport perl5
+USE_PERL5= run
+
+OPTIONS_DEFINE= CJK DBLATEX FOP GIT GROFF IGOR JING TRANSLATOR
+OPTIONS_DEFAULT= CJK GIT GROFF IGOR TRANSLATOR
+
+CJK_DESC= CJK support
+DBLATEX_DESC= dblatex PDF renderer (experimental, requires TeXLive)
+FOP_DESC= FOP PDF renderer (requires Java)
+GIT_DESC= Git support
+GROFF_DESC= Groff support from ports
+IGOR_DESC= Igor automated proofreader for documentation
+JING_DESC= Jing for advanced RELAX NG validation
+TRANSLATOR_DESC= Tools for translators
+
+CJK_RUN_DEPENDS= html2text:textproc/html2text
+DBLATEX_RUN_DEPENDS= dblatex:textproc/dblatex
+DBLATEX_USE= TEX=xetex
+FOP_RUN_DEPENDS= ${_FONTS} \
+ fop:textproc/fop
+GIT_RUN_DEPENDS= git:devel/git
+GROFF_USES= groff:run
+IGOR_RUN_DEPENDS= igor:textproc/igor
+JING_RUN_DEPENDS= jing:textproc/jing
+TRANSLATOR_RUN_DEPENDS= itstool:textproc/itstool \
+ msgcat:devel/gettext-tools
+
+_FONTS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSansMono.ttf:x11-fonts/dejavu \
+ ${LOCALBASE}/share/fonts/Droid/DroidSans.ttf:x11-fonts/droid-fonts-ttf \
+ ${LOCALBASE}/share/fonts/GentiumPlus/GentiumPlus-Regular.ttf:x11-fonts/gentium-plus \
+ ${LOCALBASE}/share/fonts/Lohit/Lohit-Bengali.ttf:x11-fonts/lohit
+_FONTS_CJK= ${LOCALBASE}/share/fonts/ipa/ipam.otf:japanese/font-ipa \
+ ${LOCALBASE}/share/fonts/nanum-ttf/NanumBarunGothic.ttf:korean/nanumfonts-ttf \
+ ${LOCALBASE}/share/fonts/TrueType/gkai00mp.ttf:chinese/arphicttf
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MFOP} || ${PORT_OPTIONS:MDBLATEX}
+ONLY_FOR_ARCHS= amd64 i386
+CJK_RUN_DEPENDS+= ${_FONTS_CJK}
+.endif
+
+# generate MINIMALDOCPORTS for src/release/Makefile.inc.docports.
+# (XXX: incomplete yet)
+minimaldocports:
+ @${ECHO_CMD} "MINIMALDOCPORTS= \\"
+ @${MAKE} all-depends-list | ${SED} -e 's,^${PORTSDIR}/, ,' -e 's,$$, \\,'
+
+.include <bsd.port.mk>
diff --git a/textproc/docproj-legacy/pkg-descr b/textproc/docproj-legacy/pkg-descr
new file mode 100644
index 000000000000..35b52bfee1aa
--- /dev/null
+++ b/textproc/docproj-legacy/pkg-descr
@@ -0,0 +1,9 @@
+The FreeBSD Documentation Project maintains the FAQ, Handbook and tutorials.
+
+This package does not contain anything by itself -- it is a
+"meta-port" that depends on other text processing packages. Its sole
+purpose is to require dependencies so users can install this package only
+and have all the Documentation Project stuff pulled in by the port/package
+dependency mechanism.
+
+WWW: https://www.freebsd.org/docproj
diff --git a/textproc/docproj/Makefile b/textproc/docproj/Makefile
index f31a57b2c90f..b51aff598dcb 100644
--- a/textproc/docproj/Makefile
+++ b/textproc/docproj/Makefile
@@ -1,78 +1,25 @@
-# Created by: Nik Clayton <nik@FreeBSD.org>
-
PORTNAME= docproj
-PORTVERSION= 3.0
-PORTREVISION= 1
+PORTVERSION= 4.0
CATEGORIES= textproc
MAINTAINER= doceng@FreeBSD.org
COMMENT= Meta-port for the FreeBSD Documentation Project
RUN_DEPENDS= asciidoctor:textproc/rubygem-asciidoctor \
- ${LOCALBASE}/share/xml/dtd/xhtml/xhtml.soc:textproc/xhtml \
- ${LOCALBASE}/share/xml/xmlcharent/catalog:textproc/xmlcharent \
- ${LOCALBASE}/share/xsl/iso-schematron/xslt1/iso_schematron_skeleton_for_xslt1.xsl:textproc/iso-schematron-xslt \
- docbook-xsl-ns>=1.78.1_4:textproc/docbook-xsl-ns \
- docbook>0:textproc/docbook \
hugo:www/gohugo \
- links:www/links1 \
- p5-XML-Parser>=2.41:textproc/p5-XML-Parser \
- peps:graphics/peps \
- pngtopnm:graphics/netpbm \
rougify:textproc/rubygem-rouge \
- scr2png:graphics/scr2png \
- scr2txt:textproc/scr2txt \
- xsltproc:textproc/libxslt \
- zip:archivers/zip
-USES= ghostscript:run metaport perl5 python:3.6+,run
-USE_PERL5= run
+USES= metaport python:3.6+,run
-OPTIONS_DEFINE= CJK DBLATEX FOP GIT GROFF IGOR JING PDF TRANSLATOR
-OPTIONS_DEFAULT= CJK GIT GROFF IGOR PDF TRANSLATOR
+OPTIONS_DEFINE= GIT IGOR PDF TRANSLATOR
+OPTIONS_DEFAULT= GIT IGOR PDF TRANSLATOR
-CJK_DESC= CJK support
-DBLATEX_DESC= dblatex PDF renderer (experimental, requires TeXLive)
-FOP_DESC= FOP PDF renderer (requires Java)
-GIT_DESC= Git support
-GROFF_DESC= Groff support from ports
IGOR_DESC= Igor automated proofreader for documentation
-JING_DESC= Jing for advanced RELAX NG validation
TRANSLATOR_DESC= Tools for translators
-CJK_RUN_DEPENDS= html2text:textproc/html2text
-DBLATEX_RUN_DEPENDS= dblatex:textproc/dblatex
-DBLATEX_USE= TEX=xetex
-FOP_RUN_DEPENDS= ${_FONTS} \
- fop:textproc/fop
GIT_RUN_DEPENDS= git:devel/git
-GROFF_USES= groff:run
IGOR_RUN_DEPENDS= igor:textproc/igor
-JING_RUN_DEPENDS= jing:textproc/jing
PDF_RUN_DEPENDS= asciidoctor-pdf:textproc/rubygem-asciidoctor-pdf
-TRANSLATOR_RUN_DEPENDS= itstool:textproc/itstool \
- msgcat:devel/gettext-tools \
- po4a>=0.63_1:textproc/po4a
-
-_FONTS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSansMono.ttf:x11-fonts/dejavu \
- ${LOCALBASE}/share/fonts/Droid/DroidSans.ttf:x11-fonts/droid-fonts-ttf \
- ${LOCALBASE}/share/fonts/GentiumPlus/GentiumPlus-Regular.ttf:x11-fonts/gentium-plus \
- ${LOCALBASE}/share/fonts/Lohit/Lohit-Bengali.ttf:x11-fonts/lohit
-_FONTS_CJK= ${LOCALBASE}/share/fonts/ipa/ipam.otf:japanese/font-ipa \
- ${LOCALBASE}/share/fonts/nanum-ttf/NanumBarunGothic.ttf:korean/nanumfonts-ttf \
- ${LOCALBASE}/share/fonts/TrueType/gkai00mp.ttf:chinese/arphicttf
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MFOP} || ${PORT_OPTIONS:MDBLATEX}
-ONLY_FOR_ARCHS= amd64 i386
-CJK_RUN_DEPENDS+= ${_FONTS_CJK}
-.endif
-
-# generate MINIMALDOCPORTS for src/release/Makefile.inc.docports.
-# (XXX: incomplete yet)
-minimaldocports:
- @${ECHO_CMD} "MINIMALDOCPORTS= \\"
- @${MAKE} all-depends-list | ${SED} -e 's,^${PORTSDIR}/, ,' -e 's,$$, \\,'
+TRANSLATOR_RUN_DEPENDS= po4a>=0.63_1:textproc/po4a
.include <bsd.port.mk>