aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorGuangyuan Yang <ygy@FreeBSD.org>2020-12-29 15:30:13 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2020-12-29 15:30:13 +0000
commit5252e4c5ba0a615bc24638998e078e04e93be857 (patch)
treec9518d49b238c77147f30263ac46910e73c42672 /chinese
parent784693f56c9c8899036fc4aa340be19676b514c8 (diff)
downloadports-5252e4c5ba0a615bc24638998e078e04e93be857.tar.gz
ports-5252e4c5ba0a615bc24638998e078e04e93be857.zip
chinese/rime-*: Use CP instead of RLN for data files from localbase
For data files from localbase (in ${LOCALBASE}/share/rime-data), copy them to the build directory instead of symbolically linking them. Submitted by: Ka Ho Ng <khng300@gmail.com> Approved by: lwhsu Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D27716
Notes
Notes: svn path=/head/; revision=559588
Diffstat (limited to 'chinese')
-rw-r--r--chinese/rime-bopomofo/Makefile3
-rw-r--r--chinese/rime-cangjie/Makefile3
-rw-r--r--chinese/rime-cantonese/Makefile3
-rw-r--r--chinese/rime-luna-pinyin/Makefile3
-rw-r--r--chinese/rime-stroke/Makefile3
-rw-r--r--chinese/rime-terra-pinyin/Makefile3
6 files changed, 12 insertions, 6 deletions
diff --git a/chinese/rime-bopomofo/Makefile b/chinese/rime-bopomofo/Makefile
index c1460a1ee8ad..740ec9a9f03c 100644
--- a/chinese/rime-bopomofo/Makefile
+++ b/chinese/rime-bopomofo/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rime-bopomofo
DISTVERSION= g20190120
+PORTREVISION= 1
CATEGORIES= chinese textproc
MAINTAINER= khng300@gmail.com
@@ -45,7 +46,7 @@ do-build:
@${MKDIR} ${MY_OUTDIR}
@${RLN} ${WRKSRC}/* ${MY_OUTDIR}
.for i in ${PRELUDE_FILES} ${ESSAY_FILES} ${TERRA_PINYIN_FILES}
- @${RLN} ${LOCALBASE}/share/rime-data/${i} ${MY_OUTDIR}
+ @${CP} ${LOCALBASE}/share/rime-data/${i} ${MY_OUTDIR}
.endfor
.for i in ${SCHEMA_FILES}
rime_deployer --compile ${WRKSRC}/${i} ${MY_OUTDIR}
diff --git a/chinese/rime-cangjie/Makefile b/chinese/rime-cangjie/Makefile
index 43c8249ea101..e4b0aa9f045e 100644
--- a/chinese/rime-cangjie/Makefile
+++ b/chinese/rime-cangjie/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rime-cangjie
DISTVERSION= g20201030
+PORTREVISION= 1
CATEGORIES= chinese textproc
MAINTAINER= khng300@gmail.com
@@ -38,7 +39,7 @@ do-build:
@${MKDIR} ${MY_OUTDIR}
@${RLN} ${WRKSRC}/* ${MY_OUTDIR}
.for i in ${PRELUDE_FILES} ${ESSAY_FILES}
- @${RLN} ${LOCALBASE}/share/rime-data/${i} ${MY_OUTDIR}
+ @${CP} ${LOCALBASE}/share/rime-data/${i} ${MY_OUTDIR}
.endfor
.for i in ${SCHEMA_FILES}
rime_deployer --compile ${WRKSRC}/${i} ${MY_OUTDIR}
diff --git a/chinese/rime-cantonese/Makefile b/chinese/rime-cantonese/Makefile
index 392debd11b40..c31737f8cf94 100644
--- a/chinese/rime-cantonese/Makefile
+++ b/chinese/rime-cantonese/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rime-cantonese
DISTVERSION= g20201212
+PORTREVISION= 1
CATEGORIES= chinese textproc
MAINTAINER= khng300@gmail.com
@@ -43,7 +44,7 @@ do-build:
@${MKDIR} ${MY_OUTDIR}
@${RLN} ${WRKSRC}/* ${MY_OUTDIR}
.for i in ${PRELUDE_FILES} ${ESSAY_FILES}
- @${RLN} ${LOCALBASE}/share/rime-data/${i} ${MY_OUTDIR}
+ @${CP} ${LOCALBASE}/share/rime-data/${i} ${MY_OUTDIR}
.endfor
.for i in ${SCHEMA_FILES}
rime_deployer --compile ${WRKSRC}/${i} ${MY_OUTDIR}
diff --git a/chinese/rime-luna-pinyin/Makefile b/chinese/rime-luna-pinyin/Makefile
index 8e67bb431b2c..ba4ea875e0d4 100644
--- a/chinese/rime-luna-pinyin/Makefile
+++ b/chinese/rime-luna-pinyin/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rime-luna-pinyin
DISTVERSION= g20201105
+PORTREVISION= 1
CATEGORIES= chinese textproc
MAINTAINER= khng300@gmail.com
@@ -43,7 +44,7 @@ do-build:
@${MKDIR} ${MY_OUTDIR}
@${RLN} ${WRKSRC}/* ${MY_OUTDIR}
.for i in ${PRELUDE_FILES} ${ESSAY_FILES}
- @${RLN} ${LOCALBASE}/share/rime-data/${i} ${MY_OUTDIR}
+ @${CP} ${LOCALBASE}/share/rime-data/${i} ${MY_OUTDIR}
.endfor
.for i in ${SCHEMA_FILES}
rime_deployer --compile ${WRKSRC}/${i} ${MY_OUTDIR}
diff --git a/chinese/rime-stroke/Makefile b/chinese/rime-stroke/Makefile
index 3fcb4296126d..f63916de37e5 100644
--- a/chinese/rime-stroke/Makefile
+++ b/chinese/rime-stroke/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rime-stroke
DISTVERSION= g20191221
+PORTREVISION= 1
CATEGORIES= chinese textproc
MAINTAINER= khng300@gmail.com
@@ -39,7 +40,7 @@ do-build:
@${MKDIR} ${MY_OUTDIR}
@${RLN} ${WRKSRC}/* ${MY_OUTDIR}
.for i in ${PRELUDE_FILES} ${ESSAY_FILES}
- @${RLN} ${LOCALBASE}/share/rime-data/${i} ${MY_OUTDIR}
+ @${CP} ${LOCALBASE}/share/rime-data/${i} ${MY_OUTDIR}
.endfor
.for i in ${SCHEMA_FILES}
rime_deployer --compile ${WRKSRC}/${i} ${MY_OUTDIR}
diff --git a/chinese/rime-terra-pinyin/Makefile b/chinese/rime-terra-pinyin/Makefile
index a93c4b895305..20002d91ee58 100644
--- a/chinese/rime-terra-pinyin/Makefile
+++ b/chinese/rime-terra-pinyin/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rime-terra-pinyin
DISTVERSION= g20201018
+PORTREVISION= 1
CATEGORIES= chinese textproc
MAINTAINER= khng300@gmail.com
@@ -39,7 +40,7 @@ do-build:
@${MKDIR} ${MY_OUTDIR}
@${RLN} ${WRKSRC}/* ${MY_OUTDIR}
.for i in ${PRELUDE_FILES} ${ESSAY_FILES}
- @${RLN} ${LOCALBASE}/share/rime-data/${i} ${MY_OUTDIR}
+ @${CP} ${LOCALBASE}/share/rime-data/${i} ${MY_OUTDIR}
.endfor
.for i in ${SCHEMA_FILES}
rime_deployer --compile ${WRKSRC}/${i} ${MY_OUTDIR}