aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2022-03-10 04:01:06 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2022-03-10 04:01:06 +0000
commit864a1f86fa20ecd88eec31e8b8bf02edfeef66f9 (patch)
tree7e3fbf15c03afc683035742a4f3fc4f2b341a50f /deskutils
parent159bf5bb4c5952b3dce73d2c0aa7b2ff83bbd430 (diff)
downloadports-864a1f86fa20ecd88eec31e8b8bf02edfeef66f9.tar.gz
ports-864a1f86fa20ecd88eec31e8b8bf02edfeef66f9.zip
deskutils/mindforger: update the port to version 1.54.0
Apply a minor fix so that correct version would be reported in the About dialog and window title (the tree had been tagged for the release before the fix had been committed to the master). Reported by: portscout
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/mindforger/Makefile3
-rw-r--r--deskutils/mindforger/distinfo6
-rw-r--r--deskutils/mindforger/files/patch-app_app.pro9
-rw-r--r--deskutils/mindforger/files/patch-lib_src_gear_string__utils.h15
4 files changed, 18 insertions, 15 deletions
diff --git a/deskutils/mindforger/Makefile b/deskutils/mindforger/Makefile
index cf5df8b3c2aa..f57e835cf78d 100644
--- a/deskutils/mindforger/Makefile
+++ b/deskutils/mindforger/Makefile
@@ -1,7 +1,7 @@
# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
PORTNAME= mindforger
-PORTVERSION= 1.53.0
+PORTVERSION= 1.54.0
CATEGORIES= deskutils
MAINTAINER= danfe@FreeBSD.org
@@ -48,6 +48,7 @@ post-patch:
${WRKSRC}/app/src/qt/note_view_presenter.cpp \
${WRKSRC}/app/src/qt/note_view_presenter.h \
${WRKSRC}/app/src/qt/outline_header_view_presenter.cpp
+ @${REINPLACE_CMD} -e 's/53/54/' ${WRKSRC}/lib/src/app_info.h
@${REINPLACE_CMD} -e 's/_current_dir_name(/cwd(nullptr, 0/' \
${WRKSRC}/lib/src/gear/file_utils.cpp
diff --git a/deskutils/mindforger/distinfo b/deskutils/mindforger/distinfo
index 277f63fcc09e..3210b7a11c92 100644
--- a/deskutils/mindforger/distinfo
+++ b/deskutils/mindforger/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1640528172
-SHA256 (dvorka-mindforger-1.53.0_GH0.tar.gz) = a8a917c4b6eb28b16ab09322108049408c9bcb897baeba786042c1bcb1389ce7
-SIZE (dvorka-mindforger-1.53.0_GH0.tar.gz) = 2137346
+TIMESTAMP = 1641748185
+SHA256 (dvorka-mindforger-1.54.0_GH0.tar.gz) = 1f274b810cf1a4ee31e7d3aa9adc21660f11d2cfff23e1e6950141d96068de5a
+SIZE (dvorka-mindforger-1.54.0_GH0.tar.gz) = 2128313
SHA256 (dvorka-cmark-4ca8688_GH0.tar.gz) = 8486c44ed23ae3865f5ebba034e319ed9e65340ffca1df09a4edd4b4677ab6cb
SIZE (dvorka-cmark-4ca8688_GH0.tar.gz) = 288979
diff --git a/deskutils/mindforger/files/patch-app_app.pro b/deskutils/mindforger/files/patch-app_app.pro
index 07e4ced9de25..dba5719015cd 100644
--- a/deskutils/mindforger/files/patch-app_app.pro
+++ b/deskutils/mindforger/files/patch-app_app.pro
@@ -1,13 +1,14 @@
---- app/app.pro.orig 2021-12-26 14:16:12 UTC
+--- app/app.pro.orig 2022-01-09 17:09:45 UTC
+++ app/app.pro
-@@ -137,12 +137,8 @@ macx {
+@@ -160,13 +160,8 @@ macx {
./src/qt/spelling/dictionary_provider_voikko.cpp
} else:unix {
-- # pkgconfig-based configuration does not work @ Ubuntu distribution build
+- # pkgconfig-based configuration does not work @ Ubuntu
- # CONFIG += link_pkgconfig
- # PKGCONFIG += hunspell
-- # hardcoded paths are unfortunately more robust:
+-
+- # hardcoded paths are (unfortunately) more robust:
- INCLUDEPATH += /usr/include/hunspell
- LIBS += -lhunspell
+ CONFIG += link_pkgconfig
diff --git a/deskutils/mindforger/files/patch-lib_src_gear_string__utils.h b/deskutils/mindforger/files/patch-lib_src_gear_string__utils.h
index 65a3b2159cc7..a439ac5ea776 100644
--- a/deskutils/mindforger/files/patch-lib_src_gear_string__utils.h
+++ b/deskutils/mindforger/files/patch-lib_src_gear_string__utils.h
@@ -1,11 +1,12 @@
---- lib/src/gear/string_utils.h.orig 2020-03-08 17:03:52 UTC
+--- lib/src/gear/string_utils.h.orig 2022-01-09 17:09:45 UTC
+++ lib/src/gear/string_utils.h
-@@ -114,12 +114,12 @@ static inline char *stringTrim(const char *s) {
- }
-
- static inline std::string &stringLeftTrim(std::string& s) {
-- s.erase(s.begin(), std::find_if(s.begin(), s.end(), std::not1(std::ptr_fun<int, int>(isspace))));
-+ s.erase(s.begin(), std::find_if(s.begin(), s.end(), [](int c) { return !std::isspace(c); }));
+@@ -118,13 +118,13 @@ static inline std::string &stringLeftTrim(std::string&
+ s.begin(),
+ std::find_if(s.begin(),
+ s.end(),
+- std::not1(std::ptr_fun<int, int>(isspace)))
++ [](int c) { return !std::isspace(c); })
+ );
return s;
}