aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2022-02-16 22:21:31 +0000
committerCy Schubert <cy@FreeBSD.org>2022-02-16 22:24:15 +0000
commit86afb138d28a8f79e2e50f4103edb9f1d3178c10 (patch)
treeb7d1e511c360e9b7b5132b5f3c7afe82b8e06003 /deskutils
parent94a3c67e0b1ee5c1bb1fd743947e964a53ef243f (diff)
downloadports-86afb138d28a8f79e2e50f4103edb9f1d3178c10.tar.gz
ports-86afb138d28a8f79e2e50f4103edb9f1d3178c10.zip
deskutils/plan: Update to 1.12
This version of plan includes many bug fixes and a new feature. Look at the HISTORY file in the source tarball to see what has changed.
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/plan/Makefile4
-rw-r--r--deskutils/plan/distinfo5
-rw-r--r--deskutils/plan/files/patch-Makefile22
-rw-r--r--deskutils/plan/files/patch-sublist.c58
4 files changed, 67 insertions, 22 deletions
diff --git a/deskutils/plan/Makefile b/deskutils/plan/Makefile
index e9e4f870ea72..42cc1d29adef 100644
--- a/deskutils/plan/Makefile
+++ b/deskutils/plan/Makefile
@@ -3,8 +3,7 @@
# Also update ports/japanese/plan/ (ja-plan) when this port is updated
PORTNAME= plan
-PORTVERSION= 1.10.1
-PORTREVISION= 1
+PORTVERSION= 1.12
CATEGORIES+= deskutils
MASTER_SITES= https://cschubert.com/distfiles/plan/ \
ftp://ftp.bitrot.de/pub/plan/ \
@@ -15,6 +14,7 @@ COMMENT= X/Motif schedule planner with calendar
FETCH_ARGS= -Fr --no-passive
USES= motif
+USE_XORG= xt sm ice x11 xext
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
ALL_TARGET= freebsd
diff --git a/deskutils/plan/distinfo b/deskutils/plan/distinfo
index f2a0ff468523..b0d790b80f3c 100644
--- a/deskutils/plan/distinfo
+++ b/deskutils/plan/distinfo
@@ -1,2 +1,3 @@
-SHA256 (plan-1.10.1.tar.gz) = 05aaaada18f34949dc38e207300a8f975c1eb60b93502e10db68822b59b4184f
-SIZE (plan-1.10.1.tar.gz) = 462560
+TIMESTAMP = 1645045108
+SHA256 (plan-1.12.tar.gz) = b637346e072276f4595c9cabed78e0c8c7b06f4c3509e4c42ddebed9512c2155
+SIZE (plan-1.12.tar.gz) = 439996
diff --git a/deskutils/plan/files/patch-Makefile b/deskutils/plan/files/patch-Makefile
index 45ae58d1e2c4..324030cc89f8 100644
--- a/deskutils/plan/files/patch-Makefile
+++ b/deskutils/plan/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2007-07-03 15:08:52.000000000 -0300
-+++ Makefile 2009-10-05 22:12:11.000000000 -0300
+--- Makefile.orig 2017-10-25 07:17:42.000000000 -0700
++++ Makefile 2022-02-16 13:38:09.182449000 -0800
@@ -8,19 +8,19 @@
# after "=", this is parsed and rewritten by the configure script.
#
@@ -64,11 +64,11 @@
NBSD_C = -ansi -I/usr/X11R6/include -DBSD -DRABBITS -DNOLOCK -DNOREGEX\
-DNO_MOTIF
-FBSD_C = -ansi -I/usr/X11R6/include -DBSD -DNOLOCK -DNOREGEX -DRABBITS\
-+FBSD_C = -ansi -I$(LOCALBASE)/include -DBSD -DNOLOCK -DNOREGEX -DRABBITS\
++FBSD_C = -ansi -I$(LOCALBASE)/include -DBSD -DNOLOCK -DRABBITS\
-DSTDLIBMALLOC
OBSD_C = -ansi -I/usr/X11R6/include -DBSD -DRABBITS -DNOLOCK -DNOREGEX\
-DNO_MOTIF -DSTDLIBMALLOC
-@@ -221,10 +225,10 @@
+@@ -226,10 +230,10 @@
BSDIG_L2= -L/usr/X11/lib -lc
NBSD_L1 = -L/usr/X11R6/lib -lXm -lXt -lX11
NBSD_L2 = -L/usr/X11R6/lib -lc
@@ -82,8 +82,8 @@
+OBSD_L2 =
LINUX_L1= -L/usr/X11R6/lib -L/usr/lib/X11R6/lib -lXm -lXt -lX11 -lXpm -lc -lXext -lICE -lX11
LINUX_L2= -lc
- SLINUX_L1= -L/usr/X11R6/lib -L/usr/lib/X11R6/lib -lSM /usr/X11R6/lib/libXm.a -lXt -lX11 /usr/X11R6/lib/libXpm.a -lc -lXext -lSM -lICE -lX11
-@@ -291,7 +295,7 @@
+ DEBIAN_L1= -L/usr/X11R6/lib -L/usr/lib/X11R6/lib -lXm -lXt -lX11 -lXpm -lc -lXext -lICE -lX11
+@@ -298,7 +302,7 @@
@echo " make bsdi BSDI/386"
@echo " make bsdig BSDI/386 with gcc"
@echo " make netbsd NetBSD/i386 1.0A (maybe others too)"
@@ -92,7 +92,7 @@
@echo " make openbsd OpenBSD"
@echo " make svr4 SVR4 Using gcc"
@echo " make news4 Sony NEWS-OS4.x"
-@@ -542,7 +546,7 @@
+@@ -552,7 +556,7 @@
$(CCLINE) -c -DLIB=\"$(LIB)\" $<
holiday.o: holiday.c $(MAKEFILE)
@@ -101,16 +101,16 @@
util.o: util.c $(MAKEFILE)
$(CCLINE) -c -DPATH=\"$(LIB):$(DIR):$(HELP)\" $<
-@@ -617,10 +621,10 @@
+@@ -627,10 +631,10 @@
LIST = README HISTORY plan.spec holiday/* language/* misc/* src/resources.h.bigfonts web/*
SRC = Makefile $(P_SRC) daemon.c $(N_SRC) $(S_SRC) $(INC) $(S_INC) configure
-LDIR = /usr/X11R6/lib
-+LDIR = $(LOCALBASE)/lib
++LDIR = ${LOCALBASE}/lib
BINDIR = plan-$(VERSION)
gMYCC = gcc
-gCF = -m32 -I/usr/X11R6/include -D_POSIX_SOURCE -DNOLOCK -DLINUX -Dlinux
-+gCF = -m32 -I$(LOCALBASE)/include -D_POSIX_SOURCE -DNOLOCK -DLINUX -Dlinux
- gL1F = -L$(LDIR) $(LDIR)/libXm.a -lXt -lX11 $(LDIR)/libXpm.a -lc -lXext -lICE -lXp -lX11
++gCF = -m32 -I${LOCALBASE}/include -D_POSIX_SOURCE -DNOLOCK -DLINUX -Dlinux
+ gL1F = -L$(LDIR) $(LDIR)/libXm.a -lXt -lX11 $(LDIR)/libXpm.a -lc -lXext -lICE -lX11
gL2F = -lc
diff --git a/deskutils/plan/files/patch-sublist.c b/deskutils/plan/files/patch-sublist.c
index a6f2f9518c88..8a144022e24e 100644
--- a/deskutils/plan/files/patch-sublist.c
+++ b/deskutils/plan/files/patch-sublist.c
@@ -1,11 +1,55 @@
---- sublist.c.orig Sun May 2 12:23:15 1999
-+++ sublist.c Thu Jun 17 13:09:05 1999
-@@ -23,7 +23,7 @@
- #define regcmp re_comp
+--- sublist.c.orig 2017-10-16 23:29:05.000000000 -0700
++++ sublist.c 2022-02-16 13:53:48.815414000 -0800
+@@ -20,7 +20,7 @@
+ #define CHUNK 100 /* sublist allocation unit */
+
+ #ifndef NOREGEX
+-#if defined(linux)
++#if defined(linux) || defined(__FreeBSD__)
+ #include <regex.h>
+ #else
+ #define regex_t char
+@@ -30,12 +30,14 @@
#define regex re_exec
+ extern char *regcmp(), *regex(), *__loc1;
#endif
--#if defined(linux) || defined(__EMX__)
-+#if defined(linux) || defined(__EMX__) || defined(POSIX_REGEX)
- #define regcmp regcomp
+-#if defined(__EMX__) || defined(__FreeBSD_kernel__)
+-#define regcmp regcomp
++#if defined(__EMX__) || defined(__FreeBSD__)
++#define regcmp(a, b) regcomp(a, b, REG_BASIC)
#define regex regexec
++#ifndef __FreeBSD__
+ extern char *regcmp(), *regex(), *__loc1;
#endif
+ #endif
++#endif
+ extern int search_mode; /* 0=case, 1=lit, 2=regex */
+ extern struct user *user; /* user list (from file_r.c) */
+ static void append_entry(struct sublist **, struct entry *);
+@@ -93,7 +95,7 @@
+ #ifndef NOREGEX
+ regex_t *preg = 0;
+ if (search_mode == 2) {
+-#if defined(linux)
++#if defined(linux) || defined(__FreeBSD__)
+ preg = (regex_t *)malloc(sizeof(regex_t));
+ if (regcomp(preg, key, 0)) {
+ #else
+@@ -114,7 +116,7 @@
+ append_entry(&w->sublist, ep);
+ #ifndef NOREGEX
+ if (search_mode == 2) {
+-#if defined(linux)
++#if defined(linux) || defined(__FreeBSD__)
+ regfree(preg);
+ free(preg);
+ #else
+@@ -215,7 +217,7 @@
+
+ #ifndef NOREGEX
+ case 2: {
+-#if defined(linux)
++#if defined(linux) || defined(__FreeBSD__)
+ return(regexec(preg, string, 0, 0, 0) == 0);
+ #else
+ char dummy[1024];