aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorJaap Akkerhuis <jaap@NLnetLabs.nl>2022-02-18 15:44:53 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-02-18 15:48:03 +0000
commit449c5b803288d5b6afbee5c9b3650835f379b7f7 (patch)
treed70c6a64a459092735e46136b64b7a0841cd26d0 /dns
parent6ad6ff76763ac0c33ba507b51faf52a70556dcb2 (diff)
downloadports-449c5b803288d5b6afbee5c9b3650835f379b7f7.tar.gz
ports-449c5b803288d5b6afbee5c9b3650835f379b7f7.zip
dns/nsd: Update version 4.3.9=>4.4.0
- Pet portclippy This release changes the memory allocation for outgoing zonetransfers, and this reduces the memory footprint. The defaults for the amounts are the same as before, but there are config options to configure the memory usage. There are also bug fixes. 4.4.0 ================ FEATURES: - Merge #193: Lower memory usage of the XFRD process by default. Instead of preallocating all elements, they are allocated when used. There are options for managing the memory usage, defaults are the same as before. xfrd-tcp-max sets the number of sockets for tcp connections that xfrd can make to download zone contents. And xfrd-tcp-pipeline the number of simultaneous transfers over the same connection. BUG FIXES: - Fix #200: nsd-checkzone succeeds even with incorrect serial in SOA record. - Merge #204 from jonathangray: correct some spelling mistakes. - Fix to change file mode before changing file owner for the nsd-control unix socket file. - Fix to document nsd-checkzone -p in the man page for nsd-checkzone. - Fix #206: build with --without-ssl fails. - Merge #207 Sync nsd-control-setup with unbound-control-setup to generate certificates with SANs. - Fix unit tests for nds-control-setup exit code and the xfrd-tcp-max default. PR: 262034 Approved by: jaap@NLnetLabs.nl (maintainer) Relnotes: https://nlnetlabs.nl/news/2022/Feb/17/nsd-4.4.0-released/
Diffstat (limited to 'dns')
-rw-r--r--dns/nsd/Makefile58
-rw-r--r--dns/nsd/distinfo6
2 files changed, 32 insertions, 32 deletions
diff --git a/dns/nsd/Makefile b/dns/nsd/Makefile
index 6c973ee52767..6f8d0754cd1c 100644
--- a/dns/nsd/Makefile
+++ b/dns/nsd/Makefile
@@ -1,7 +1,7 @@
# Created by: alexis
PORTNAME= nsd
-DISTVERSION= 4.3.9
+DISTVERSION= 4.4.0
CATEGORIES= dns
MASTER_SITES= https://www.nlnetlabs.nl/downloads/nsd/
@@ -11,10 +11,10 @@ COMMENT= Authoritative only non-recursive name server
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cpe ssl
-
LIB_DEPENDS= libevent.so:devel/libevent
+USES= cpe ssl
+
CPE_VENDOR= nlnetlabs
USE_RC_SUBR= nsd
@@ -23,7 +23,6 @@ NSDGROUP?= nsd
NSDLSDIR= /var
NSDDBDIR= /var/db/nsd
NSDRUNDIR= /var/run/nsd
-NSDMAX_IPS?= 512
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=${NSDLSDIR} \
@@ -34,14 +33,14 @@ CONFIGURE_ARGS= --localstatedir=${NSDLSDIR} \
--with-ssl=${OPENSSLBASE} \
--with-user=${NSDUSER}
+USERS= ${NSDUSER}
+GROUPS= ${NSDGROUP}
+
PLIST_SUB= NSDDBDIR=${NSDDBDIR} \
NSDGROUP=${NSDGROUP} \
NSDRUNDIR=${NSDRUNDIR} \
NSDUSER=${NSDUSER}
-USERS= ${NSDUSER}
-GROUPS= ${NSDGROUP}
-
PORTDOCS= CREDITS ChangeLog LICENSE NSD-4-features NSD-DATABASE \
NSD-DIFFFILE NSD-FOR-BIND-USERS README README.icc RELNOTES \
REQUIREMENTS TESTPLAN TODO UPGRADING coding-style \
@@ -54,37 +53,38 @@ OPTIONS_DEFAULT= BIND8_STATS LARGEFILE MINRESPSIZE NSEC3 RADIXTREE RRL \
ZONE_STATS
OPTIONS_SUB= yes
-MUNIN_PLUGIN_IMPLIES= BIND8_STATS
-
-ROOT_SERVER_DESC= Configure as a root server
-LARGEFILE_DESC= Largefile support
BIND8_STATS_DESC= BIND8-like NSTATS & XSTATS
CHECKING_DESC= Internal run-time checks
-NSEC3_DESC= NSEC3 support
+DNSTAP_DESC= Enable dnstap logging support
+LARGEFILE_DESC= Largefile support
MINRESPSIZE_DESC= Minimial response sizing
MMAP_DESC= Use mmap instead of malloc (experimental)
-RRL_DESC= Response Rate Limiting
-ZONE_STATS_DESC= Separate statistics for each zone
MUNIN_PLUGIN_DESC= Install Munin plugin (requires BIND8_STATS)
-RADIXTREE_DESC= Enabled: more (15%) memory use but less CPU cycles
+NSEC3_DESC= NSEC3 support
PACKED_DESC= Enable packed structures for reduced memory use
-DNSTAP_DESC= Enable dnstap logging support
+RADIXTREE_DESC= Enabled: more (15%) memory use but less CPU cycles
+ROOT_SERVER_DESC= Configure as a root server
+RRL_DESC= Response Rate Limiting
+ZONE_STATS_DESC= Separate statistics for each zone
-ROOT_SERVER_CONFIGURE_ENABLE= root-server
-LARGEFILE_CONFIGURE_ENABLE= largefile
BIND8_STATS_CONFIGURE_ENABLE= bind8-stats
CHECKING_CONFIGURE_ENABLE= checking
-NSEC3_CONFIGURE_ENABLE= nsec3
+DNSTAP_LIB_DEPENDS= libfstrm.so:devel/fstrm \
+ libprotobuf-c.so:devel/protobuf-c
+DNSTAP_CONFIGURE_ENABLE= dnstap
+IPV6_CONFIGURE_ENABLE= ipv6
+LARGEFILE_CONFIGURE_ENABLE= largefile
MINRESPSIZE_CONFIGURE_ENABLE= minimal-responses
MMAP_CONFIGURE_ENABLE= mmap
+MUNIN_PLUGIN_IMPLIES= BIND8_STATS
+NSEC3_CONFIGURE_ENABLE= nsec3
+PACKED_CONFIGURE_ENABLE= packed
+RADIXTREE_CONFIGURE_ENABLE= radix-tree
+ROOT_SERVER_CONFIGURE_ENABLE= root-server
RRL_CONFIGURE_ENABLE= ratelimit
ZONE_STATS_CONFIGURE_ENABLE= zone-stats
-IPV6_CONFIGURE_ENABLE= ipv6
-RADIXTREE_CONFIGURE_ENABLE= radix-tree
-PACKED_CONFIGURE_ENABLE= packed
-DNSTAP_CONFIGURE_ENABLE= dnstap
-DNSTAP_LIB_DEPENDS= libfstrm.so:devel/fstrm \
- libprotobuf-c.so:devel/protobuf-c
+
+NSDMAX_IPS?= 512
post-build-MUNIN_PLUGIN-on:
${REINPLACE_CMD} \
@@ -102,13 +102,13 @@ post-install:
${STAGEDIR}${PREFIX}/sbin/nsd-checkzone \
${STAGEDIR}${PREFIX}/sbin/nsd-control
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${STAGEDIR}${DOCSDIR}
+
post-install-MUNIN_PLUGIN-on:
${MKDIR} ${STAGEDIR}${PREFIX}/share/munin/plugins
${INSTALL_SCRIPT} ${WRKSRC}/contrib/nsd_munin_ \
${STAGEDIR}${PREFIX}/share/munin/plugins
-post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${STAGEDIR}${DOCSDIR}
-
.include <bsd.port.mk>
diff --git a/dns/nsd/distinfo b/dns/nsd/distinfo
index ff8fe5c1ed84..c22dcf3ee096 100644
--- a/dns/nsd/distinfo
+++ b/dns/nsd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1639041936
-SHA256 (nsd-4.3.9.tar.gz) = 531549f09289ecbd05829e14bb34563294d85b9edde2c613a00f597af2135e8d
-SIZE (nsd-4.3.9.tar.gz) = 1222919
+TIMESTAMP = 1645095864
+SHA256 (nsd-4.4.0.tar.gz) = cfcd6fdd99344ca5a7ef7c2940c241bcef471fc3252ba3dcbd4c57e0638e8836
+SIZE (nsd-4.4.0.tar.gz) = 1226433