aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-15 08:41:20 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-15 08:41:20 +0000
commit5ba3ec8f7b88490a906a0b04d7c07c857ac4d79b (patch)
tree26edfadd8efc897e7b4dd8dca8e54c4fb56da3cc /games
parent5240cba2437ed1f3f59eab2052420b13a448b621 (diff)
downloadports-5ba3ec8f7b88490a906a0b04d7c07c857ac4d79b.tar.gz
ports-5ba3ec8f7b88490a906a0b04d7c07c857ac4d79b.zip
games/tome4: fix build on powerpc
Force GCC: In file included from ../src/luajit2/src/host/buildvm_lib.c:6: In file included from ../src/luajit2/src/host/buildvm.h:16: ../src/luajit2/src/lj_arch.h:295:2: error: "Need at least GCC 4.3 or newer"
Diffstat (limited to 'games')
-rw-r--r--games/tome4/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/games/tome4/Makefile b/games/tome4/Makefile
index 9849d48a1222..fb98a46e8bcc 100644
--- a/games/tome4/Makefile
+++ b/games/tome4/Makefile
@@ -18,10 +18,9 @@ BUILD_DEPENDS= premake4:devel/premake4
LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
libpng.so:graphics/png
-USES= compiler:c++11-lang gl gmake openal:al sdl tar:bzip2 xorg
+USES= gl gmake openal:al sdl tar:bzip2 xorg
USE_SDL= image2 sdl2 ttf2
USE_GL= gl glu
-USE_CSTD= gnu89
SUB_FILES= tome4
MAKE_JOBS_UNSAFE= yes
@@ -34,7 +33,13 @@ WRKSRC= ${WRKDIR}/t-engine4-src-${DISTVERSION}
MAKE_ARGS+= config=release verbose=yes ARCH="" CC=${CC} CXX=${CXX}
LDFLAGS_i386= -Wl,-znotext
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc
+USES+= compiler:gcc-c++11-lib
+.else
+USES+= compiler:c++11-lang
+.endif
pre-build:
@${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/premake4.lua
@@ -55,4 +60,4 @@ do-install:
${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>