aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-15 08:41:15 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-15 08:41:15 +0000
commit05931c0cc85b2fdfb03258db121648adf562f0ca (patch)
tree23d1f5a003fa00d01a055e5492bdec66677aef47 /math
parentc5e96ec080e3cedce10bc48f3d062f0402aafa46 (diff)
downloadports-05931c0cc85b2fdfb03258db121648adf562f0ca.tar.gz
ports-05931c0cc85b2fdfb03258db121648adf562f0ca.zip
math/csdp: fix build on powerpc
LLVM on powerpc doesn't have libomp: cc -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -fopenmp -ansi -Wall -DBIT64 -DUSEOPENMP -DSETNUMTHREADS -DUSESIGTERM -DUSEGETTIME -I../include -c -o op_o.o op_o.c op_o.c:15:10: fatal error: 'omp.h' file not found
Diffstat (limited to 'math')
-rw-r--r--math/csdp/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/math/csdp/Makefile b/math/csdp/Makefile
index d6254a763116..9319f4d5b148 100644
--- a/math/csdp/Makefile
+++ b/math/csdp/Makefile
@@ -29,6 +29,12 @@ PLIST_FILES= bin/complement \
bin/rand_graph \
bin/theta
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc
+USES+= compiler:gcc-c++11-lib
+.endif
+
post-stage:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*