aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-07 17:46:56 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-07 18:10:52 +0000
commit9f2a4e0fc9613b53ed48f9e254add382688ed9b1 (patch)
tree3d4a2bae5a9318248e9e3a459b4df258a4082ab6 /math
parent244a84012fd5b5fca19495363064695e871f3223 (diff)
downloadports-9f2a4e0fc9613b53ed48f9e254add382688ed9b1.tar.gz
ports-9f2a4e0fc9613b53ed48f9e254add382688ed9b1.zip
math/py-mutatormath: Add py-mutatormath 3.0.1
MutatorMath is a Python library for the calculation of piecewise linear interpolations in n-dimensions with any number of masters. It was developed for interpolating data related to fonts, but if can handle any arithmetic object. - The objects/ subpackage contains the general calculation tools. - The ufo/ subpackage contains tools to specifically process UFO data. - MutatorMath has no user interface, just the math. WWW: https://github.com/LettError/MutatorMath
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/py-mutatormath/Makefile25
-rw-r--r--math/py-mutatormath/distinfo3
-rw-r--r--math/py-mutatormath/pkg-descr8
4 files changed, 37 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 504d32ff2cf2..411a27be730d 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -870,6 +870,7 @@
SUBDIR += py-mpmath
SUBDIR += py-munkres
SUBDIR += py-munkres10
+ SUBDIR += py-mutatormath
SUBDIR += py-ndindex
SUBDIR += py-networkx
SUBDIR += py-nevergrad
diff --git a/math/py-mutatormath/Makefile b/math/py-mutatormath/Makefile
new file mode 100644
index 000000000000..583d99bf5efc
--- /dev/null
+++ b/math/py-mutatormath/Makefile
@@ -0,0 +1,25 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= mutatormath
+PORTVERSION= 3.0.1
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= MutatorMath-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python for piecewise linear interpolation in multiple dimensions with multiple, arbitrarily placed, masters
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}defcon>=0.3.5:x11-fonts/py-defcon@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}fontMath>=0.4.8:x11-fonts/py-fontMath@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}fonttools>=3.32.0:print/py-fonttools@${PY_FLAVOR}
+
+USES= python:3.7+ zip
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-mutatormath/distinfo b/math/py-mutatormath/distinfo
new file mode 100644
index 000000000000..1e8a31176cbf
--- /dev/null
+++ b/math/py-mutatormath/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1646057856
+SHA256 (MutatorMath-3.0.1.zip) = 8127c1ffad1646f11a953752296c43f5d88cbd5293fff03f093d916b0bc13864
+SIZE (MutatorMath-3.0.1.zip) = 421722
diff --git a/math/py-mutatormath/pkg-descr b/math/py-mutatormath/pkg-descr
new file mode 100644
index 000000000000..8c66052359ce
--- /dev/null
+++ b/math/py-mutatormath/pkg-descr
@@ -0,0 +1,8 @@
+MutatorMath is a Python library for the calculation of piecewise linear
+interpolations in n-dimensions with any number of masters. It was developed for
+interpolating data related to fonts, but if can handle any arithmetic object.
+- The objects/ subpackage contains the general calculation tools.
+- The ufo/ subpackage contains tools to specifically process UFO data.
+- MutatorMath has no user interface, just the math.
+
+WWW: https://github.com/LettError/MutatorMath