aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-05-13 02:20:22 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-05-13 02:23:20 +0000
commit5192c2840e16dcae91a3947edbd51c90874cb9f6 (patch)
treef03a8d753acda251b89da78f1a5e3c6f081b16d3 /net-p2p
parent463524251ec67b7717b5d6d42796ee056ee6c032 (diff)
downloadports-5192c2840e16dcae91a3947edbd51c90874cb9f6.tar.gz
ports-5192c2840e16dcae91a3947edbd51c90874cb9f6.zip
net-p2p/ktorrent: register build-time conflict against net-p2p/libtorrent
Both `net-p2p/libktorrent' (direct dependency) and `net-p2p/libtorrent' (unrelated port) install `torrent/torrent.h' header file, albeit in the different locations: /usr/local/include/torrent/torrent.h /usr/local/include/KF5/libktorrent/torrent/torrent.h The problem is that when both ports are installed, the first header is being included which in turn breaks the build in a not-so-obvious way: In file included from libktcore/ktcore_autogen/mocs_compilation.cpp:22: In file included from libktcore/ktcore_autogen/WEMDBQPFF4/moc_magnetmanager.cpp:10: In file included from libktcore/ktcore_autogen/WEMDBQPFF4/../../../../ktorrent-21.04.0/libktcore/torrent/magnetmanager.h:26: /usr/local/include/KF5/libktorrent/magnet/magnetdownloader.h:104:5: error: unknown type name 'Torrent' Torrent tor; ^ In file included from libktcore/ktcore_autogen/mocs_compilation.cpp:22: libktcore/ktcore_autogen/WEMDBQPFF4/moc_magnetmanager.cpp:86:34: error: cannot initialize object parameter of type 'bt::MagnetDownloader' with an expression of type 'kt::MagnetDownloader' return bt::MagnetDownloader::qt_metacast(_clname); ^~~~~~~~~~~ libktcore/ktcore_autogen/WEMDBQPFF4/moc_magnetmanager.cpp:91:33: error: cannot initialize object parameter of type 'bt::MagnetDownloader' with an expression of type 'kt::MagnetDownloader' _id = bt::MagnetDownloader::qt_metacall(_c, _id, _a); ^~~~~~~~~~~
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/net-p2p/ktorrent/Makefile b/net-p2p/ktorrent/Makefile
index 057c77769605..9b8c8ffd6758 100644
--- a/net-p2p/ktorrent/Makefile
+++ b/net-p2p/ktorrent/Makefile
@@ -8,6 +8,8 @@ CATEGORIES= net-p2p kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= BitTorrent client for KDE
+CONFLICTS_BUILD= libtorrent
+
USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
LIB_DEPENDS= libKF5Torrent.so:net-p2p/libktorrent \